Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
03-30-2008, 04:44 PM   #1
Senior Member
azcavalier's Avatar

Join Date: Oct 2007
Location: Blacksburg, VA
Photos: Gallery
Posts: 135
Service for my K10D? Suggestions?

So I think that I have two issues. I'm seeing some spots when I look through the viewfinder, whether the lens is on or not. I tried cleaning the mirror and the underside (exposed) side of the...is it the prism? But the spots are still there. I can actually look up through the prism and see the offending particle. I probably shouldn't try to get to that myself, should I? It doesn't show up on any images, though, so it's just an annoyance. Does anyone have any experience similar to this?

Also, I think that my autofocus has issues. I was recently taking pictures, outside on a sunny day of buildings on the campus of Washington and Lee Univ. and Virginia Military Institute with my Tamron 18-200mm lens, using the Program mode and center-point AF, nothing fancy, and my pictures turned out horrible. Blurry everywhere. But the autofocus had found it's focal point, and it was just off. I also took some more on campus here at Virginia Tech about three days ago. There was good light, and I was using the Aperture Priority mode with the same lens, and again they just turned out horrible. It *could* be the lens, or a combination of the two. I need to try with some other lenses just to be sure. But is this a known issue with DSLRs? This is my first, and I'm not sure what to expect. Do DSLRs need to have their autofocusing system recalibrated every so often? If so, how much can I expect to have to cough up? I've had my camera for about 18 months, so it's out of warranty.

I'll post the pictures later.

03-30-2008, 06:54 PM   #2
Site Supporter
wtlwdwgn's Avatar

Join Date: Jan 2007
Location: Billings, MT
Photos: Gallery | Albums
Posts: 9,333
I recently sent my K10 and 2 DA* lenses to Pentax USA for focus adjustment and they came back within 2 weeks all nice and clean and working just fine.
03-30-2008, 08:19 PM   #3
Senior Member
azcavalier's Avatar

Join Date: Oct 2007
Location: Blacksburg, VA
Photos: Gallery
Posts: 135
Original Poster
QuoteOriginally posted by wtlwdwgn Quote
I recently sent my K10 and 2 DA* lenses to Pentax USA for focus adjustment and they came back within 2 weeks all nice and clean and working just fine.
If you don't mind me asking, about how much did they charge?
03-31-2008, 11:44 AM   #4
Site Supporter
wtlwdwgn's Avatar

Join Date: Jan 2007
Location: Billings, MT
Photos: Gallery | Albums
Posts: 9,333
QuoteOriginally posted by azcavalier Quote
If you don't mind me asking, about how much did they charge?
Zip, nada, nichts. It was under warranty. I paid shipping down and they paid it back.

04-01-2008, 03:47 AM   #5
Veteran Member




Join Date: Jan 2007
Location: Buffalo, NY
Photos: Gallery
Posts: 324
I bought my k10d back when it first came out. Nov 06. I just sent it in last month. I was out of warranty and it cost me 252.00. Got it back in 3 weeks. I was torn wether to fix it, or sell everything and go to canon. Long story short, I had it fixed and it works great now.

My belief is that they upgraded some of the parts sometime in 2007 which improved the K10's focusing. People who have bought K10d in the late half of 2007 have chimed in on some of the threads here saying thier camera works great, while the complaints are usually from buyers who ran out and grabbed a K10d in the first 6 months it was out. A closer look into camera data reveals the early models to be model revision 1.1, and the models that were bought in late 2007 to be model revision 8.1 The camera I sent in left as a model rev. 1.1 and came back as 8.1, which leads me to believe they changed or adjusted 7 items in the camera. This is all speculation on my part as I've had a hard time getting answers on exactly what was replaced or adjusted. This also leads ME to believe that the K20d really does have the same focusing system as the K10d. Its the 8.1 version. The same people who ran out and bought the K20d are most likely the same who bought the K10d when it first came out. Therefore the K20d seems to be alot better than thier K10D (which is probly a model rev. 1.1)
Thats why we see all the threads with statements about how much faster and more accurate thier new K20d focusing is.
What I would be interested in is a comparason between a K10d model rev. 8.1, and a K20d. Keep in mind this is all just my opinion. I have 2 K10d's that are model rev 8.1 now and they both seem to be spot on, I'm very satisfied. I'm glad I didnt jump ship.
04-01-2008, 04:14 AM   #6
Veteran Member




Join Date: Dec 2007
Location: Jacksonville, FL
Photos: Gallery
Posts: 531
QuoteOriginally posted by azcavalier Quote
So I think that I have two issues. I'm seeing some spots when I look through the viewfinder, whether the lens is on or not. I tried cleaning the mirror and the underside (exposed) side of the...is it the prism? But the spots are still there. I can actually look up through the prism and see the offending particle. I probably shouldn't try to get to that myself, should I? It doesn't show up on any images, though, so it's just an annoyance. Does anyone have any experience similar to this?
You can remove the focus screen and blow it off (out of the camera), then replace it. That should remove your dust problem. Or consider getting a new Katz-Eye focusing screen, since you need to remove the focus-screen anyway!
04-01-2008, 05:03 AM   #7
Veteran Member




Join Date: Dec 2006
Location: Outside of Philly
Posts: 1,564
I had a good experience with Pentax Service. My K10D had problems driving the SDM on my 50-135mm. It took them just about two weeks for them to fix it and send it back. I had to pay shipping to Colorado (less than 10 bucks) and they shipped it UPS back to me. No charge since it was a warranty repair. They fixed the autofocus and also did a good job of cleaning the sensor and the usual schmutz that gets inside the viewfinder.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
autofocus, camera, campus, dslr, dslrs, horrible, issues, lens, mode, photography, pictures, prism, virginia
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Need help: My K10D is at Pentax Service: What now?(the Poll!) Deimo Pentax DSLR Discussion 23 01-13-2010 11:45 AM
K10d service in Vancouver, BC? Blake Pentax DSLR Discussion 4 06-29-2009 09:49 PM
Pentax Canada - K10D Service experience getmoresoon Pentax DSLR Discussion 2 02-11-2009 08:17 PM
K10D Service Menu and AF Adjust! nosnoop Pentax DSLR Discussion 54 12-08-2008 02:49 PM
K10d back from service, and pictures from an old Chinon 50mm Fireball Pentax DSLR Discussion 2 09-13-2007 09:31 PM



All times are GMT -7. The time now is 06:53 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top