Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
07-14-2015, 05:33 PM - 1 Like   #1351
Senior Member
Stumpy's Avatar

Join Date: Sep 2014
Location: Devon UK
Posts: 105
RNAS Yeovilton International Air Day GX-10 + Tamron 18-200

Attached Images
View Picture EXIF
SAMSUNG GX10  Photo 
07-14-2015, 06:42 PM   #1352
Pentaxian
paulh's Avatar

Join Date: Sep 2010
Location: DFW Texas
Photos: Gallery | Albums
Posts: 13,687
QuoteOriginally posted by Stumpy Quote
RNAS Yeovilton International Air Day GX-10 + Tamron 18-200
nice shot, very dramatic with all the smoke!
07-14-2015, 08:14 PM   #1353
Pentaxian
tromboads's Avatar

Join Date: Apr 2012
Location: Melbs
Photos: Gallery | Albums
Posts: 1,148
Indeed! Good on ya little Tamron And well done Photographer
07-15-2015, 01:06 AM - 1 Like   #1354
Site Supporter
Dartmoor Dave's Avatar

Join Date: Aug 2012
Location: Dartmoor, UK
Photos: Albums
Posts: 933
QuoteOriginally posted by Stumpy Quote
RNAS Yeovilton International Air Day GX-10 + Tamron 18-200

Great shot with a real sense of drama. And it's great to see that I'm not the only nutter in Devon using the GX-10 version of the K10D.

07-15-2015, 01:23 AM   #1355
Site Supporter




Join Date: Nov 2008
Location: Waikikamukau
Photos: Albums
Posts: 969
Anyone using pktriggercord in Linux for tethering their K10d ? and if so what firmware version is the K10d running and what Linux o/s ?

I am trying to troubleshoot a tethering problem and have a suspicion that firmware 1.20 and up (where compatibility for Pentax Remote Assistant was introduced) may be the stopper.

I am hoping that with such a large group of users at least one or more of you may have some info to share.
07-15-2015, 03:07 AM   #1356
Pentaxian
tromboads's Avatar

Join Date: Apr 2012
Location: Melbs
Photos: Gallery | Albums
Posts: 1,148
Why Hello there. I tried for a while (running what ever the latest firmware) but confessed I gave up and tried to use the windows one through wine. Then gave up and used a VM and the native windows one :P

Then it wasn't that exciting anymore.

OH WAIT I REMEMBER!

I want a GUI and I couldn't be bothered with the CLI. ... shame I know. But it worked great.

(running slackware 14.1 64bit)

Last edited by tromboads; 07-15-2015 at 03:17 AM.
07-15-2015, 12:24 PM   #1357
Site Supporter




Join Date: Nov 2008
Location: Waikikamukau
Photos: Albums
Posts: 969
QuoteQuote:
(running what ever the latest firmware)(running slackware 14.1 64bit)
Excellent info..thanks.!
Yes, I tried Pktether in Wine too before I discovered that Wine doesn't support usb so was never going to find the camera...

Used Virtualbox WinXP and Pktether but Virtualbox usb 2.0 transfer speed is throttled to usb 1.1 so that wasn't much fun.

The pktriggercord cli version works well for me but is a little fiddly to use for stacking.

It seems that only it's GUI is affected and possibly because the firmware expects to see Windows for tethering to PRA....
The more instances and usage reports I can garner will help to confirm or eliminate this.
07-16-2015, 04:43 AM   #1358
Senior Member




Join Date: Mar 2013
Photos: Gallery | Albums
Posts: 165
QuoteOriginally posted by Stumpy Quote
RNAS Yeovilton International Air Day GX-10 + Tamron 18-200
Good shot!

07-16-2015, 06:09 AM   #1359
Pentaxian
tromboads's Avatar

Join Date: Apr 2012
Location: Melbs
Photos: Gallery | Albums
Posts: 1,148
Wait wine doesn't support USB... well that would have saved me some time

But.. wait no I don't suppose I've tried to connect a USB drive whilst in a wine environment.. lol Ha!
07-16-2015, 01:25 PM   #1360
Site Supporter
Dartmoor Dave's Avatar

Join Date: Aug 2012
Location: Dartmoor, UK
Photos: Albums
Posts: 933
I've had some spare time this evening so I've had a go at using pktriggercord with my GX-10 version of the K10D and Ubuntu 14.04. The camera is successfully detected, but pktriggercord crashes as soon as I try to change any settings.

And as bobD and Dan (tromboads) have already concluded, PKTether runs under wine but fails to detect the camera.

I'm out of practice with Linux after giving up and using Windows 7 for convenience for the past few years, but I like a challenge so I'll have another go at this over the weekend.
07-16-2015, 01:46 PM   #1361
Site Supporter




Join Date: Nov 2008
Location: Waikikamukau
Photos: Albums
Posts: 969
QuoteOriginally posted by Dartmoor Dave Quote
The camera is successfully detected, but pktriggercord crashes as soon as I try to change any settings.
When you say the camera is detected are the camera settings boxes populated or does it just show "K10d connected" at the bottom of the main window..?
If the former then that is good to know..if the latter then that is all I get as well.
What is the nature of the crash..? I have the windows of pktriggercord greying out and becoming unresponsive.
Needs to be killed by closing the terminal.

What firmware is your K10d running ?

QuoteQuote:
I'll have another go at this over the weekend.
Depending on firmware version you may not get any further..
I am in contact with the developer and he has been getting debug info from me so will keep you posted.
Can you run the command line version successfully ??? that would be good to know too.

Code:
pktriggercord-cli -f -o  /home/'your-username'/Desktop/test
should put an image on your desktop called test.(whatever file used dng..jpg..)
The command takes one shot, focuses first (-f) and outputs to the selected folder (-o)

I am using Ubuntu 14.04 as well.
07-16-2015, 02:13 PM   #1362
Site Supporter
Dartmoor Dave's Avatar

Join Date: Aug 2012
Location: Dartmoor, UK
Photos: Albums
Posts: 933
I'm getting the same you're getting: "GX-10 connected" in my case but all the settings boxes unpopulated. Then the pktriggercord window freezes and I have to kill it. I haven't tried the cli version yet but I'll give it a go tomorrow or at the weekend. At least now we know that the same error applies to both the Pentax and Samsung versions of the K10D (I'm using the Samsung firmware version 1.30).
07-16-2015, 03:22 PM   #1363
Site Supporter




Join Date: Nov 2008
Location: Waikikamukau
Photos: Albums
Posts: 969
Thanks for that ! at least the errors it is throwing are consistent..

Now we need someone with firmware 1.10 or 1.11 to try...

If, as I suspect, the 1.20 firmware and up is the problem then a K10d with 1.10 should work fine.

My K10d is on firmware 1.31 which is not 'down-gradeable' otherwise I would try that myself. Unless someone knows how to (and has done it ) rollback from firmware 1.31 ?
07-16-2015, 05:56 PM   #1364
Pentaxian
tromboads's Avatar

Join Date: Apr 2012
Location: Melbs
Photos: Gallery | Albums
Posts: 1,148
would you really want to downgrade just to use the tethering program however?

My memory of using it in windows was that it was slow to clear the buffer anyway / a bit annoying / fiddly to use.

I thought I'd set it up when I was playing with flashes in my office but it was cumbersome so I just resulted in taking the SD card out manually when I wanted to review :P
07-16-2015, 07:10 PM   #1365
Site Supporter




Join Date: Nov 2008
Location: Waikikamukau
Photos: Albums
Posts: 969
QuoteOriginally posted by tromboads Quote
would you really want to downgrade just to use the tethering program however?
In a flash I would.... especially to test if it was the 1.20 firmware responsible for the errors. After that it would be a trade off of any useful (to me) upgrades vs tethering to the o/s I do pp in.
So far I think the tethering wins...
QuoteQuote:
My memory of using it in windows was that it was slow to clear the buffer anyway / a bit annoying / fiddly to use.
I would be using it in a fixed studio setting for stacked product shots.
I'm sure the buffer could clear way faster than I could change the items being photographed, or wind my stage in for stacking..
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
allen, bird, camera, cameras, clicks, comparison, da, dslr, ff, flickr, images, k10d, k5, k5iis, leica, lens, nikon, pentax, photography, pictures, post, price, prix, ray, skin tones, time, version
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
I started a K-5 Praise thread, now the Complaint thread imtheguy Pentax K-5 46 11-01-2010 09:20 AM
Suggestion Add Previous/Next Thread links at the top of each thread indytax Site Suggestions and Help 3 03-17-2009 05:40 PM
Iceemn360's K10d Photo Thread Timtast1c Post Your Photos! 50 01-10-2009 02:43 PM
Mandatory thread from new K10D owner :) Edvinas Pentax DSLR Discussion 9 12-08-2006 07:34 PM



All times are GMT -7. The time now is 06:03 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top