Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
12-17-2013, 09:39 AM   #1
New Member




Join Date: Oct 2013
Posts: 20
Issue with Pentax K20D and Sigma 18-250mm F3.5 Macro OS HSM

Hello All,

I need some guidance and assistance in regards to using AF function on the Sigma Lens with Pentax k20D.

I recently got this lens and have it mounted correctly on the Pentax K20D mount but I am unable to use Automatic Focus. I am able to turn the Zoom ring but when I press the shutter button its does not allow me to do

1)Half press to focus
2) Sharpen Focus


But takes a picture which is completely auto of focus.

I have used Pentax lense before 55-200 DA and it works fine with this camera. I am wondering if its user error or the contacts from the lens are not connecting properly or I have to fiddle with the menu to turn on autofocus.

Thanks in Advance for your help and advice

Regards

Ro

12-17-2013, 09:55 AM - 1 Like   #2
Pentaxian
normhead's Avatar

Join Date: Jun 2007
Location: Near Algonquin Park
Photos: Gallery | Albums
Posts: 23,735
It should work, there's no magic or secret handshake involved. As long as the camera and lens are both set to AF, the lens should focus. If not, get on your horse and return it, right away.
12-17-2013, 10:47 AM   #3
New Member




Join Date: Oct 2013
Posts: 20
Original Poster
QuoteOriginally posted by normhead Quote
It should work, there's no magic or secret handshake involved. As long as the camera and lens are both set to AF, the lens should focus. If not, get on your horse and return it, right away.

I do have it set to AF on both lens and K20D. I will requesting a RMA as you suggested once I work through all possible scenarios

Thanks for your feedback

Regards
12-17-2013, 10:53 AM - 1 Like   #4
Veteran Member
mrNewt's Avatar

Join Date: Nov 2011
Location: ON, RH
Posts: 2,170
Ummm... is your K20D up to date with the firmware!?
If not, try and update it maybe that will fix your issue. If it is up to date, return the lens... or at least try and test it on another camera if you can before returning it.


Last edited by mrNewt; 12-17-2013 at 11:07 AM.
12-17-2013, 11:04 AM - 1 Like   #5
Pentaxian
bdery's Avatar

Join Date: Mar 2008
Location: Quebec city, Canada
Photos: Gallery
Posts: 5,657
QuoteOriginally posted by mrNewt Quote
Ummm... is your K20D up to date with the firmware!?
If not, try and update it maybe that will fix your issue. If it is, return the lens... or at least try and see if you can test it on another camera... even at the store where you return it.
That was my hypothesis also. The K20D needs its firmware updated to work with ultrasonic lenses (SDM, HSM, etc).
12-17-2013, 11:31 AM   #6
New Member




Join Date: Oct 2013
Posts: 20
Original Poster
I just checked the camera firmware and yes it does require update as I have version 1.0. Since I am unable to extract the updated file at work due to admin restriction I will have to wait till i get home to update the firmware.

I will post and let you all know if the update helped

Thanks for the feedback

Regards,

Ro


QuoteOriginally posted by bdery Quote
That was my hypothesis also. The K20D needs its firmware updated to work with ultrasonic lenses (SDM, HSM, etc).
12-17-2013, 11:44 AM   #7
Veteran Member
sterretje's Avatar

Join Date: Dec 2008
Location: Roodepoort, South Africa
Photos: Gallery | Albums
Posts: 3,534
I'm quite sure that the K20D supported SDM out of the box. K10D was the one that needed a firmware upgrade for that.
12-17-2013, 12:55 PM - 1 Like   #8
Veteran Member
mrNewt's Avatar

Join Date: Nov 2011
Location: ON, RH
Posts: 2,170
QuoteOriginally posted by sterretje Quote
I'm quite sure that the K20D supported SDM out of the box. K10D was the one that needed a firmware upgrade for that.
I remember doing the update for the K10D because of my Sigma. I hit the same wall back then. I actually went trough the embarrassment going back to the store... they were nice though and pointed me in the right direction...

You wanna know something else that was embarassing?
That was the time I learned that you can upgrade the firmware on your camera

Maybe not all K20D came with the update... just guessing. Doing the update won't hurt before sending it back.


Last edited by mrNewt; 12-17-2013 at 01:35 PM.
12-18-2013, 09:08 AM - 1 Like   #9
New Member




Join Date: Oct 2013
Posts: 20
Original Poster
Ok So I did the update on the firmware and went from 1.0 to 1.04 and the AF was was working well after the update.

I just brought this K20D few months back almost brand new in the original box. Makes sense on why the firmware was old.

Thanks everyone for your help and advice

Regards

Ro
12-18-2013, 09:27 AM   #10
Veteran Member
mrNewt's Avatar

Join Date: Nov 2011
Location: ON, RH
Posts: 2,170
Nice... enjoy your lenses .
12-18-2013, 09:41 AM   #11
Pentaxian
normhead's Avatar

Join Date: Jun 2007
Location: Near Algonquin Park
Photos: Gallery | Albums
Posts: 23,735
QuoteOriginally posted by Roism Quote
Ok So I did the update on the firmware and went from 1.0 to 1.04 and the AF was was working well after the update.

I just brought this K20D few months back almost brand new in the original box. Makes sense on why the firmware was old.

Thanks everyone for your help and advice

Regards

Ro
Wow, now there's something I never would have thought of… I never had to do that on my K20D, but, I also updated the firmware on it a few times. When I took my camera gear in to the Pentax booth at Henry's EXPOsure last spring, they updated the firmware on 3 cameras for me, so I didn't even have to do it myself. Their sales rep, just kept grabbing cameras from my bag and updating cameras while we talked about other stuff. 2 K-5s and a K-01.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
18-250mm f3.5 macro, camera, dslr, f3.5 macro os, focus, k20d, k20d and sigma, lens, pentax, pentax k20d w sigma lens, photography, press, sigma, sigma 18-250mm f3.5
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Sigma 18-250mm f3.5-6.3 OS HSM Sample Photos Parallax Lens Sample Photo Archive 3 06-19-2012 05:59 PM
OS or IS with Sigma 18-250mm f3.5-6.3 DC OS HSM? Redundant Banker Pentax SLR Lens Discussion 4 01-11-2012 08:43 AM
Issue with Sigma 18-250mm OS HSM varian Pentax SLR Lens Discussion 6 12-13-2010 10:42 AM



All times are GMT -7. The time now is 04:35 AM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top