Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
02-03-2014, 05:03 AM   #16
Pentaxian
schnitzer79's Avatar

Join Date: Jul 2013
Photos: Albums
Posts: 1,095
Original Poster
its really difficult to see where the spring was so i can put it back so im sending it in

02-03-2014, 10:37 AM   #17
Pentaxian
schnitzer79's Avatar

Join Date: Jul 2013
Photos: Albums
Posts: 1,095
Original Poster
i mentioned in an earlier post that if i set the aperture on the ring manually (instead of the "A" setting) then the camera doesnt specify it.it just says F--. Im pretty sure that the camera used to specify it even though its been a while since I used the aperture ring.
I have set the settings in the menu for use of the ring before anyone asks. can someone verify this?
02-03-2014, 09:00 PM   #18
Veteran Member
manacho2005's Avatar

Join Date: Oct 2011
Location: Red Oak, TX
Photos: Gallery | Albums
Posts: 462
It will show F-- if the ring is set to anything other than A. That's why it's called the "crippled" Kmount; it's missing the mechanical aperture link.
02-04-2014, 09:39 AM   #19
Site Supporter
Site Supporter
stevebrot's Avatar

Join Date: Mar 2007
Location: Vancouver (USA)
Photos: Gallery | Albums
Posts: 27,698
QuoteOriginally posted by schnitzer79 Quote
i mentioned in an earlier post that if i set the aperture on the ring manually (instead of the "A" setting) then the camera doesnt specify it.it just says F--.
That is the expected behavior.


Steve

02-04-2014, 12:37 PM   #20
Pentaxian
schnitzer79's Avatar

Join Date: Jul 2013
Photos: Albums
Posts: 1,095
Original Poster
Yep ur right.i thought it was related to the fault. Just hadnt noticed before since the ring is always on "A"
03-13-2014, 12:49 AM - 1 Like   #21
Pentaxian
schnitzer79's Avatar

Join Date: Jul 2013
Photos: Albums
Posts: 1,095
Original Poster
finally my camera came back from repair.it took 5 weeks and they replaced the diaphragm control block and shutter block. that plus manual labour cost around 200 euro. thank god it was still under warranty.
i was hoping they would clean the sensor as well but they didnt. packing was pretty good though. havent tested it properly yet but took a couple of photos and it seems ok. fingers crossed!
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
aperture, battery, camera, dslr, issue, lens, lever, mirror, mirror flop, photography, samyang
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Mirror flop issue Aeonflame Pentax K-r 33 02-04-2016 03:58 PM
Mirror Flop on the K-r - Plus additional strange issue Stoogie Troubleshooting and Beginner Help 11 08-23-2013 01:19 PM
k-r mirror flop guruh Pentax K-r 2 07-03-2013 07:13 AM
Questions about mirror flop Jeff Charles Pentax K-5 11 02-05-2013 08:51 PM
The mirror flop problem revisited bwDraco Pentax DSLR Discussion 6 06-14-2012 10:27 PM



All times are GMT -7. The time now is 10:58 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top