Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
05-22-2008, 08:23 AM   #106
New Member




Join Date: Sep 2007
Location: New Jersey
Posts: 3
FWIW - I sent my K10D in for repair under warranty, with a problem description that said the focus seemed to be consistently behind what the camera was focusing on. I indicated this happened primarily with the 18-55 kit lens, and the 16-45 lens. Pentax got it back to me in less than 2 weeks, with a new revision number of 8.2 (original was 2.1), and with the following repair description:

------------------------------------------------------
* We have repaired your product(s) under terms of our new product or service warranty. Malfunctioning areas have been repaired, adjusted and cleaned including the following:

* Replacement or adjustment of electronic autofocus circuit including focus motor and encoder, CCD focus device and laser alignment of mirrors.

All repaired Pentax equipment is put through a complete function test, including cleaning, lubrication, and adjustment to bring your product(s) to factory specifications.
------------------------------------------------------

Pentax never requested that I send the lenses in. Haven't noticed any significant change in the camera's low-light autofocus abilities. Still need to check if the backfocus problem has improved at all.

05-22-2008, 08:41 AM   #107
Forum Member




Join Date: Nov 2006
Location: Vancouver Canada
Posts: 55
I sent my K10D in for service (warranty) to Pentax Canada last month.
The camera was backfocusing pretty badly,especially with the 31mm f1.8.
Got it back about 3 weeks later, it's now rev. 8.1
and the BF problem is gone. I tossed it on the chart, and the 2 lenses were absolutely bang on.

I sent my K10D/77mm/31mm to Pentax Canada. It cost me 40 bucks to send it because I bought 1500.00 insurance from Canada Post, but it was money well spent.
I had used the K10D less and less because of the problems I had, but I took it to a conservatory (after it was fixed) and shot some birds at very wide apertures, the camera performed really well.
But I never DARED go over ISO 400. The camera isn't exactly a star performer at high ISO.

Overall, Pentax Canada did a fine job.
I find the camera still hunts a bit in low light, but of the 180 or so shots i took, only 3 or 4 were mis-focused. I don't think that's too bad.
05-22-2008, 02:58 PM   #108
Inactive Account




Join Date: Mar 2008
Location: Burlington, Ontario
Photos: Gallery
Posts: 374
Well my baby has been returned to me safe and sound.

Here are the details:

Flash: Checked and found in order

K10D Body: Auto Focus Sys Adjusted, Auto Exposure Adjusted

No Charge



As expected I am at Model Revision 8.1


I have a feeling the "8" tells them it has been to back to the factory for repair.

I have a gut feeling the "1" probably will change to a "2" if I were to send it back in.
(Just a hunch)


It seems to not hunt like it used to and the focus does seem better... need to play around more with it tonight.


Oh yea.... they left the firmware at 1.3


D.
05-24-2008, 05:44 PM   #109
Pentaxian
Moderator Emeritus




Join Date: May 2007
Location: Edmonton Alberta, Canada
Photos: Gallery | Albums
Posts: 10,648
Original Poster
Mine went off to Pentax Canada yesterday along with the FA50 f1.4. With luck it'll be back in about 4 weeks. So I'm a *istD shooter for awhile. I should ue that camera more often anyway. I was out today with it and the size and weight are ideal for a day of walking.

I took several test shots before sending it off. I'll report the results when the camera returns.

05-24-2008, 06:28 PM   #110
Inactive Account




Join Date: Mar 2008
Location: Burlington, Ontario
Photos: Gallery
Posts: 374
QuoteOriginally posted by Peter Zack Quote
I took several test shots before sending it off. I'll report the results when the camera returns.
I wish I did that... especially for the exposure issue I think I was having.

D.
05-26-2008, 07:20 PM   #111
Inactive Account




Join Date: Mar 2008
Location: Burlington, Ontario
Photos: Gallery
Posts: 374
UPDATE:

Shot a full day with the camera at a car show in the morning using my Sigma 18-50 and then in the afternoon using my Macro 50mm and some 70-300mm

I have to say the camera is MUCH different now.

Focusing is much faster and it really seems to be better. No more FF or BF at all. My shots are bang on.

My exposure issue is also cured... everything is nice and bright and looks good.

I am so glad I sent it in... three week wait or not.

D.
05-27-2008, 02:25 PM   #112
Veteran Member
jgredline's Avatar

Join Date: Oct 2007
Location: LosAngeles, Ca.
Photos: Albums
Posts: 10,531
QuoteOriginally posted by Gadget_Guy Quote
UPDATE:

Shot a full day with the camera at a car show in the morning using my Sigma 18-50 and then in the afternoon using my Macro 50mm and some 70-300mm

I have to say the camera is MUCH different now.

Focusing is much faster and it really seems to be better. No more FF or BF at all. My shots are bang on.

My exposure issue is also cured... everything is nice and bright and looks good.

I am so glad I sent it in... three week wait or not.

D.
I will send mine off tomorrow to see what happens.
Thanks for the tips.
05-27-2008, 09:46 PM   #113
Forum Member
Kentax's Avatar

Join Date: Dec 2007
Location: CA
Photos: Gallery
Posts: 98
got my k10d and lenses back today. The revision indeed was changed to 8.1, but tell you the truth, i dont think i've used it long enough to notice any af speed increase. Nonetheless, happy to have it back and can't wait to put it to use again.

05-27-2008, 11:29 PM   #114
Site Supporter
LaRee's Avatar

Join Date: Nov 2006
Location: San Diego
Photos: Gallery
Posts: 2,226
I really wish

I wish I would have sent the k10d I bought in November 2007 in right away. I bought it because I knew I would want a second body for shooting my son's wedding in June and I had to send my first k10d in for service, plus that dandy $100.00 rebate at the time got me a second k10d for just under $600.00.
When I got my k10d back from repair I thought it was really spiffed up. I couldn't put my finger on exactly what had improved though. Everything seemed to work better than my new one. BUT I have some serious underexposure issues with almost all my lenses after 6,000 shots. It *seems* it's been slowly going out of right exposure wise. It still focuses more accurately than the new k10d I bought and I've become used to adjusting the exposure.

FYI
My first k10d bought in November 2006 and sent in for service in Jan 08:
manufacture date 10-24-06, model revision 8.1

The second that I bought in November 2007:
manufacture date 10-16-07, model revision 2.1

I can't send the second one in now though. I wouldn't want to chance not getting it back by my son's wedding on June 28th.

p.s. after thinking about it, maybe I should send it in. I *think* I read you can pay $40.00 for expedited handling?

Last edited by LaRee; 05-27-2008 at 11:39 PM. Reason: ps
05-28-2008, 06:30 AM   #115
Veteran Member




Join Date: Aug 2007
Location: Georgia
Posts: 376
Well this sucks... Sent it in and it still says revision 2.1. Does that mean they didn't even do anything at all to it?
05-28-2008, 06:56 AM   #116
Inactive Account




Join Date: Mar 2008
Location: Burlington, Ontario
Photos: Gallery
Posts: 374
QuoteOriginally posted by Okami Quote
Well this sucks... Sent it in and it still says revision 2.1. Does that mean they didn't even do anything at all to it?
Interesting....

It should have come with some papers telling you what they did or even if they did nothing.

D.
05-28-2008, 07:26 PM   #117
Forum Member
Kentax's Avatar

Join Date: Dec 2007
Location: CA
Photos: Gallery
Posts: 98
Question for those who's had their slr serviced: Did your camera come back out of focus on any of the lenses submitted? 1 of 3 lenses sent in seems to be front focusing. I'm pretty sure i used the focusing chart properly; the lens ff consistently (FA50). How critical is it to have the camera angled at exactly 45degrees? would it affect the focusing outcome if the angle was off a few degrees?
05-29-2008, 01:13 PM   #118
Veteran Member




Join Date: Feb 2008
Location: Chicagoland
Posts: 338
QuoteOriginally posted by Kentax Quote
How critical is it to have the camera angled at exactly 45degrees? would it affect the focusing outcome if the angle was off a few degrees?
Not very. General area is okay to check for things like that. Making sure the chart fills the right amount of the viewfinder (specifically the AF area) is much more important.
05-29-2008, 01:41 PM   #119
New Member




Join Date: Jan 2008
Location: Agios Dimitrios
Posts: 16
My K10d has also been sent to Germany to correct back focus problem. Manufacture date was end of Nov. 2006 rev. 1.1. Those who sent it for repair in Europe, how long did it take to get it back?
05-30-2008, 10:12 AM   #120
Site Supporter
Ebbe S's Avatar

Join Date: Sep 2006
Location: Copenhagen, Denmark
Photos: Gallery
Posts: 29
QuoteOriginally posted by digital_aspirin Quote
My K10d has also been sent to Germany to correct back focus problem. Manufacture date was end of Nov. 2006 rev. 1.1. Those who sent it for repair in Europe, how long did it take to get it back?
I got mine back from Germany after 3 weeks. But unfortunately they didn't do a very good job, so tomorrow it goes back to Germany, this time with my most used lenses ranging from 14 to 300 mm. I do hope that sending the lenses together with the camera this time will make a difference. Luckily I can still borrow my good old DS from my wife... I hope
Ebbe
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, canada, dslr, model, pentax, photography, revision, support
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
K10D needs some software update mseremet Ask B&H Photo! 2 05-27-2010 12:12 PM
There are some information that K10D with revision 2.1 and higher has lower noise ogl Pentax DSLR Discussion 86 04-25-2008 04:24 PM
K10D update and Model Revision 8.1 Anyone in Australia had it done? PentaxKangaroo Pentax DSLR Discussion 0 04-23-2008 02:47 AM
is k10d the right update for me?!?! florin Pentax DSLR Discussion 8 02-24-2008 10:14 AM
K10D OFFICIAL update BrendanPK Pentax News and Rumors 13 11-04-2007 02:23 AM



All times are GMT -7. The time now is 05:45 PM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top