Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
06-02-2008, 04:16 PM   #121
Forum Member
Kentax's Avatar

Join Date: Dec 2007
Location: CA
Photos: Gallery
Posts: 98
QuoteOriginally posted by Ebbe S Quote
I got mine back from Germany after 3 weeks. But unfortunately they didn't do a very good job, so tomorrow it goes back to Germany, this time with my most used lenses ranging from 14 to 300 mm. I do hope that sending the lenses together with the camera this time will make a difference. Luckily I can still borrow my good old DS from my wife... I hope
Ebbe
What was the problem for you to have to send it in a second time?

06-02-2008, 11:54 PM   #122
Site Supporter
Ebbe S's Avatar

Join Date: Sep 2006
Location: Copenhagen, Denmark
Photos: Gallery
Posts: 29
QuoteOriginally posted by Kentax Quote
What was the problem for you to have to send it in a second time?
At first it looked like the focus had improved, but then I discovered that some of my lenses actually had gotten a bit worse, but the main problem was the lack of ability to focus properly. As an example, I tried to photograph a golden dome a night with the 77 ltd. I shot 10-15 pictures, all with different setting, but the camera just wouldn't focus properly. I then got out the old DS and first take, bingo, got the picture.
Besides when I got the camera back the sensor and the viewfinder was even more dirty than before, even though Pentax Denmark had requested a cleaning. I remember when I send in my DS for service years ago, it came back like a new camera and has performed excellent ever since... and I guess that level of excellence is really what I'm asking for

Ebbe

Last edited by Ebbe S; 06-03-2008 at 08:12 AM. Reason: focus, not ficus
06-03-2008, 04:40 PM   #123
Inactive Account




Join Date: Sep 2006
Location: Southern California
Photos: Gallery
Posts: 81
Now this is strange. I sent in my K10D about 2 months ago. Just got the camera back with hardware 8.1 and it won't read SDHC memory eventhough it reads SD memory just fine. I'm sending my K10D back. Will see if it's going to be 8.2 when I get my camera back.
06-03-2008, 05:48 PM   #124
Veteran Member




Join Date: Mar 2008
Location: outer eastern melbourne, australia
Posts: 357
i downloaded the PhotoMe software, but what exactly am i looking for? camera build date is 2007-12-08. is it the exif version (2.21 on mine)? the interoperability version (version 1.0 on mine)? the software is 1.3, i know it's not that. something else perhaps?

06-04-2008, 12:53 AM   #125
Veteran Member
gkopeliadis's Avatar

Join Date: Mar 2008
Location: ATHENS, GREECE
Posts: 311
QuoteOriginally posted by Ebbe S Quote
At first it looked like the focus had improved, but then I discovered that some of my lenses actually had gotten a bit worse, but the main problem was the lack of ability to focus properly. As an example, I tried to photograph a golden dome a night with the 77 ltd. I shot 10-15 pictures, all with different setting, but the camera just wouldn't focus properly. I then got out the old DS and first take, bingo, got the picture.
Besides when I got the camera back the sensor and the viewfinder was even more dirty than before, even though Pentax Denmark had requested a cleaning. I remember when I send in my DS for service years ago, it came back like a new camera and has performed excellent ever since... and I guess that level of excellence is really what I'm asking for

Ebbe

I've just got veeeery worried! Mine just went to Germany to fix a slight FF problem with the kit lens (when focusing closer than 1 m).

Last edited by gkopeliadis; 06-04-2008 at 02:16 AM.
06-04-2008, 05:56 AM   #126
Site Supporter
Ebbe S's Avatar

Join Date: Sep 2006
Location: Copenhagen, Denmark
Photos: Gallery
Posts: 29
QuoteOriginally posted by gkopeliadis Quote
I've just got veeeery worried! Mine just went to Germany to fix a slight FF problem with the kit lens (when focusing closer than 1 m).
Don't worry... be happy...
I think some technician had a bad day and I was just plain unlucky. :ugh:
It is not my experience that Pentax Germany gives a bad service, on the contrary, and I do expect to get a perfect calibrated camera back.

Hopefully you'll get the same.

Ebbe
06-04-2008, 01:14 PM   #127
Forum Member
Kentax's Avatar

Join Date: Dec 2007
Location: CA
Photos: Gallery
Posts: 98
well my k10d is going back in a 2nd time. All lenses exhibited front focusing problems as well as AF inaccuracies.
06-04-2008, 03:58 PM   #128
Veteran Member




Join Date: Aug 2007
Location: Georgia
Posts: 376
Have you guys tried the new PhotoMe? I can't seem to find the revision field in it

06-04-2008, 04:26 PM   #129
Senior Member




Join Date: Mar 2007
Location: New York
Posts: 168
QuoteOriginally posted by Okami Quote
Have you guys tried the new PhotoMe? I can't seem to find the revision field in it
Here's a quote from the PhotoME forum in response to a query from me:


"Report this postReply with quote Re: Revision Number
by Jens Duttke on Wed May 28, 2008 11:38 am

Hello,

the Model revision got replaced by 2 new tags ("Camera has been serviced?" and "Production ID?").

"Camera has been serviced?" represent the first number in the old Model Revision tag, and "Production ID?" the second number.

It got replaced, because the old interpretation of the data wasn't correct.

The meaning of the values is still unknown - the only known thing is, that the first number of the old Model Revision tag changed to 8 (in most cases) while the camera was serviced, that's why it's now called "Camera has been serviced?"
The meaning of value 1 and 2 is still unknown, just like the meaning of the "Production ID" values.

Cu, Jens"

It's still there in Manufacturer Notes but as Jens says, nobody knows (except Pentax of course who aren't talking) what those numbers mean.

Anyway, I have two K10D bodies. The first one went in (Pentax Colorado) for autofocus that ceased to work altogether. Revision numbers remained the same - 1(?) 2 even though the camera had been serviced. The second body was sent in (Pentax Colorado) with my 21mm DA lens for backfocus issues (and a chip on the corner of the baseplate of the camera body). Everything was fixed and the Revision values changed to 8.5. Oh, they also updated the firmware and the camera now consistently underexposes, as I mentioned in a previous post. But at least there are no more backfocus problems. Go figure.

Richard
06-04-2008, 05:23 PM   #130
New Member




Join Date: Mar 2008
Location: Brighton, UK
Posts: 8
Rev 8.1

I have two K10D bodies, the first was bought off e-bay supposedly 'new' but when I checked the Exif data using Exiftool it had 10,000 clicks on it. The second was new from a shop. The first body, with revision no 8.1, has hideous back focus problems, made it unusable, nearly gave up on Pentax completely. Thought I'd try a new one so bought the second body with revision 2.1 and all is sweet. No focusing issues at all.
The first one is now used only for close up macro work with the lens at F22 and a ring flash and works great. Can't bring myself to sell it even if it is a dud. And to think, I nearly got a Pentax divorce.....
06-04-2008, 06:45 PM   #131
Veteran Member
FruitLooPs's Avatar

Join Date: Dec 2007
Location: New Zealand
Photos: Gallery | Albums
Posts: 434
QuoteOriginally posted by mambosabi Quote
I have two K10D bodies, the first was bought off e-bay supposedly 'new' but when I checked the Exif data using Exiftool it had 10,000 clicks on it. The second was new from a shop. The first body, with revision no 8.1, has hideous back focus problems, made it unusable, nearly gave up on Pentax completely. Thought I'd try a new one so bought the second body with revision 2.1 and all is sweet. No focusing issues at all.
The first one is now used only for close up macro work with the lens at F22 and a ring flash and works great. Can't bring myself to sell it even if it is a dud. And to think, I nearly got a Pentax divorce.....
I haven't read the whle thread but if you aren't too concerned about your first 'new' old K10 body you can go into the engineering menu's and try fix the focus issues yourself?

https://www.pentaxforums.com/forums/pentax-dslr-discussion/3158-k10d-service-menu-af-adjust.html At least I think, I haven't read the whole thing.
06-05-2008, 07:59 AM   #132
Forum Member
Kentax's Avatar

Join Date: Dec 2007
Location: CA
Photos: Gallery
Posts: 98
i really hope they fix the FF issues. I'm rather disappointed the camera came back in worse focusing issues then before. Only bright side was their servicing dept cleaning the viewfinder of dust.
06-12-2008, 05:58 PM   #133
Pentaxian
Moderator Emeritus




Join Date: May 2007
Location: Edmonton Alberta, Canada
Photos: Gallery | Albums
Posts: 10,648
Original Poster
Well Mine returned today and was also revision 8.1 Pentax Canada service said that the K10D has the ability for them to fine tune up to 5 lenses to the body and when that's done the AF should be fine for most lenses. They also said that the test charts we all use are wrong and the one they use is set up at a 30 degree angle since the AF sensor points are not on a flat plane. So we're getting false BF/FF readings much of the time.

I would have liked to talk to them myself but that what was relayed by the service center owner. I only sent in the body with the FA 50 and a few test shots seem very good. Over the weekend I'll try out a few other lenses and see if there are differences.
06-12-2008, 06:10 PM   #134
Veteran Member




Join Date: Jan 2007
Location: Buffalo, NY
Photos: Gallery
Posts: 324
QuoteOriginally posted by Peter Zack Quote
They also said that the test charts we all use are wrong and the one they use is set up at a 30 degree angle since the AF sensor points are not on a flat plane. So we're getting false BF/FF readings much of the time.
.

Most of us discovered our back focusing problems from REAL world use of our cameras, and only confirmed the problem with the focus chart.
06-12-2008, 06:19 PM   #135
Pentaxian
Moderator Emeritus




Join Date: May 2007
Location: Edmonton Alberta, Canada
Photos: Gallery | Albums
Posts: 10,648
Original Poster
Sorry, I'm just relaying what they said. I realize many of us could see it in our pictures with various lenses. But it's possible the Focus21 or other charts are exagerating the issue.

I've often though the BF/FF issue could be simply caused by body movements (forward and back) that naturally happen. We lock the focus with either button and before the shutter is fired, we've moved enough to cause a focus issue. Tripod shots are without question sharper in my experience.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, canada, dslr, model, pentax, photography, revision, support
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
K10D needs some software update mseremet Ask B&H Photo! 2 05-27-2010 12:12 PM
There are some information that K10D with revision 2.1 and higher has lower noise ogl Pentax DSLR Discussion 86 04-25-2008 04:24 PM
K10D update and Model Revision 8.1 Anyone in Australia had it done? PentaxKangaroo Pentax DSLR Discussion 0 04-23-2008 02:47 AM
is k10d the right update for me?!?! florin Pentax DSLR Discussion 8 02-24-2008 10:14 AM
K10D OFFICIAL update BrendanPK Pentax News and Rumors 13 11-04-2007 02:23 AM



All times are GMT -7. The time now is 04:55 AM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top