Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
04-27-2008, 07:54 PM   #1
Veteran Member
Mr Hyde's Avatar

Join Date: May 2007
Location: NJ, USA
Posts: 761
Hot pixel on K100D? Please look and help

Hi, I'm posting this for a friend with a K100D. I know the two shots below are kinda rough but they show the problem. The first is a very tight crop of what is suspected to be a hot pixel. The second is a (resized) full size image (although very grainy) but you can see the hot pixel in the center of the frame. He says this occurrs with every photo he takes. High ISO photos seem to show the issue more. Should I tell him to take his camera in for repair?


Last edited by Mr Hyde; 01-21-2013 at 08:33 PM.
04-27-2008, 08:11 PM   #2
Pentaxian
Moderator Emeritus




Join Date: May 2007
Location: Edmonton Alberta, Canada
Photos: Gallery | Albums
Posts: 10,648
I think so. Is the camera under warranty? Pentax will map out the dead pixels and eliminate them.

I've heard that you can program Lightroom and PS to automatically fix the spot each time but as I don't own those programs, I'm not sure if that's possible.
04-27-2008, 08:16 PM   #3
Veteran Member
borno's Avatar

Join Date: Nov 2006
Location: md-usa
Photos: Gallery | Albums
Posts: 2,580
I had a couple on my k100 super and one was right in the middle and it bugged me so I sent it in for remapping. If it's under warranty it won't cost anything but to mail it. I'd guess most sensors have a couple of them.
04-27-2008, 10:38 PM   #4
Veteran Member




Join Date: Apr 2008
Location: Minnesota
Photos: Gallery
Posts: 1,530
So this is a fairly common occurence? Is this a Pentax problem or a problem with digital imaging sensors in general? I just took a look at all my high ISO pictures and sure enough I have a couple purple and green pixels all in the same spots. Lower ISO shots do not show these pixels. Is this problem known for popping up in high ISO pictures only?

04-27-2008, 11:07 PM   #5
Pentaxian
Moderator Emeritus




Join Date: May 2007
Location: Edmonton Alberta, Canada
Photos: Gallery | Albums
Posts: 10,648
Yes it is and not specific to Pentax. It can be seen in LCD monitors and imaging devices from the cheapest to the most expensive. I don't know why but it seems more noticable in high ISO shots.
04-28-2008, 12:25 AM   #6
New Member




Join Date: Feb 2008
Posts: 19
I had similar with my k100d, it went back to Pentax and came back still with the dead pixel. ! furious. (sent back underwaranty via Jessops, UK)

Second time they had for 2 weeks and it came back with a new main board and new ccd sensor. and is perfect now
04-28-2008, 10:24 AM   #7
New Member




Join Date: Jan 2008
Location: United Arab Emirates
Photos: Gallery | Albums
Posts: 13
My K100D Super has a couple, but one has to zoom in to the image at 1:1 on a screen to find them, and even then, only in certain lighting.

I decided if I have to go hunting in PS for 10 minutes at pixel-level zoom to find the minuscule flaws, they're not worth caring about. Besides, Camera RAW does seem to map them out.
04-28-2008, 01:27 PM   #8
jdg
Forum Member
jdg's Avatar

Join Date: Mar 2008
Location: Cavite, Philippines
Posts: 85
I have 4 dead pixels on my new k100d super but it only shows up on high iso and when viewed 1:1. i'd probably send it to pentax when my warranty is about to expire and enjoy the camera for now.

04-28-2008, 10:43 PM   #9
Veteran Member
Mr Hyde's Avatar

Join Date: May 2007
Location: NJ, USA
Posts: 761
Original Poster
Thanks to everyone who replied. I have passed along your suggestions.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, dslr, k100d, photography, pixel
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
K20d Hot Pixel on v1.03 drndrw Pentax DSLR Discussion 3 03-10-2010 06:40 PM
Automatic Hot Pixel Elimination Sailor Digital Processing, Software, and Printing 1 12-22-2008 04:47 PM
Hot pixel mapping on ist-D rburgoss Pentax DSLR Discussion 1 08-20-2008 07:04 AM
To all concerned with K20D/Hot Pixel Issue codiac2600 Pentax DSLR Discussion 170 06-24-2008 05:28 AM
Hot pixel issue duplicated BeerCan Pentax DSLR Discussion 1 05-26-2008 05:41 AM



All times are GMT -7. The time now is 06:51 AM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top