Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
05-09-2008, 08:57 AM   #1
Veteran Member




Join Date: Nov 2006
Location: Hong Kong
Posts: 1,934
K10D Firmware 1.3 Debug Mode Unleashed!

K10D - GX10 1.30 Firmware Debug menu via usb activation.: Pentax SLR Talk Forum: Digital Photography Review

Quick quote to the full post:-

Hi all,

So it's not a fake.

I found a program made by makc on penta-club.ru forum.

This programs allows you to access the debug menu on firm 1.30 for pentax and samsung devices.
It's just an activation/deactivation via usb cable. (no downgrade)

So you can make your own af settings in case of FF/BF (with SDM of course if you have DA* lenses

I made a tutorial on the french forum here Pentax K10D - K20D - bon anniversaire Julien

Here is the link for the program : http://dednev.pisem.net/setup_gx10_dmctrl_1.1.exe
The password for installation is : penta-club.ru

Hope you will enjoy it.

Thank you for reading.

CESITEL.

05-09-2008, 11:05 AM   #2
Pentaxian




Join Date: Apr 2007
Location: Sweden
Posts: 1,954
Nice, thanks for the pointer.
05-09-2008, 12:22 PM   #3
Veteran Member




Join Date: Feb 2008
Location: Chicagoland
Posts: 338
Sweet.

However the french forum requires me to be logged in. Any chance you can copy paste the info? Or even better yet, run it through babblefish and post?
05-09-2008, 06:11 PM   #4
Veteran Member
David's Avatar

Join Date: Jul 2007
Location: Sandy Bay, Tasmania, Australia
Photos: Albums
Posts: 344
BE CAREFUL I have used the software but have ended up with a permanent "Debug Mode" listing on my camera monitor with the Debug Mode menu items at the end of the Set Up listing on a separate page. Camera works fine in all modes and the Debug Menu items all work, but I can't get rid of the Debug Mode header.

Anyone else experience this or is there any way to get rid of the header.

I have reloaded 1.3 but to no avail. Is there an English language version of the software around?

David

05-09-2008, 09:29 PM   #5
Veteran Member




Join Date: Nov 2006
Location: Hong Kong
Posts: 1,934
Original Poster
QuoteOriginally posted by David Quote
BE CAREFUL I have used the software but have ended up with a permanent "Debug Mode" listing on my camera monitor with the Debug Mode menu items at the end of the Set Up listing on a separate page. Camera works fine in all modes and the Debug Menu items all work, but I can't get rid of the Debug Mode header.

Anyone else experience this or is there any way to get rid of the header.

I have reloaded 1.3 but to no avail. Is there an English language version of the software around?

David
You could try to reload firmware 1.1, and then leave the Debug mode following the "usual" procedures, and then re-programme the 1.3 for the SDM function.

For more info on how to downgrade from 1.3 to 1.1, see:

RiceHigh's Pentax Blog: How to Get Back to an Older Version of the Firmware?

Nonetheless, some ppls have reported that they got successful with that (hack) tools and method, but of course YMMV.
05-09-2008, 09:30 PM   #6
New Member




Join Date: Mar 2007
Location: TX
Posts: 1
QuoteOriginally posted by David Quote
BE CAREFUL I have used the software but have ended up with a permanent "Debug Mode" listing on my camera monitor with the Debug Mode menu items at the end of the Set Up listing on a separate page. Camera works fine in all modes and the Debug Menu items all work, but I can't get rid of the Debug Mode header.

Anyone else experience this or is there any way to get rid of the header.

I have reloaded 1.3 but to no avail. Is there an English language version of the software around?

David
Hi David,

The program lets you turn the debug mode off. Just need to plug your camera and select the 2nd radio button.
05-09-2008, 10:27 PM   #7
Veteran Member




Join Date: Sep 2007
Location: Melbourne
Posts: 602
QuoteOriginally posted by mskad Quote
Hi David,

The program lets you turn the debug mode off. Just need to plug your camera and select the 2nd radio button.
Correct. I have attached a diagram here https://www.pentaxforums.com/forums/pentax-news-rumors/26961-k10d-gx10-1-30-f...ctivation.html
05-09-2008, 11:04 PM   #8
Pentaxian




Join Date: Sep 2006
Location: Kaunas
Posts: 1,452
QuoteOriginally posted by David Quote
I have reloaded 1.3 but to no avail. Is there an English language version of the software around?
I have translated it for myself however I don't really want to spread that version without knowledge of the author

05-10-2008, 12:50 AM   #9
Veteran Member




Join Date: Nov 2006
Location: Hong Kong
Posts: 1,934
Original Poster
QuoteOriginally posted by Edvinas Quote
I have translated it for myself however I don't really want to spread that version without knowledge of the author
"Author" or "Hacker"? ;-)
05-10-2008, 12:58 AM   #10
Pentaxian




Join Date: Sep 2006
Location: Kaunas
Posts: 1,452
QuoteOriginally posted by RiceHigh Quote
"Author" or "Hacker"? ;-)
Author.

He got Pentax DLL Camera_Control_V2.dll and implemented that GUI program which calls functions contained in that DLL. He didn't break into original Pentax DLL and didn't modify it.

Therefore he's Author.
05-10-2008, 07:27 AM   #11
Inactive Account




Join Date: May 2008
Location: Manitoba, Canada
Photos: Gallery
Posts: 12
QuoteOriginally posted by David Quote
BE CAREFUL I have used the software but have ended up with a permanent "Debug Mode" listing on my camera monitor with the Debug Mode menu items at the end of the Set Up listing on a separate page. Camera works fine in all modes and the Debug Menu items all work, but I can't get rid of the Debug Mode header.

Anyone else experience this or is there any way to get rid of the header.

I have reloaded 1.3 but to no avail. Is there an English language version of the software around?

David
Hi David,

I also tried this program and was alarmed when I could not turn off debug mode on my K10d. Then I read Mskad's response.

I thought possibly it was yet another Vista anomaly, so loaded the program on my notebook running XP Pro - No problem. It turned off debug mode (and on) very nicely.

Not sure if this is the issue, but after successfully turning debug on and off in XP, I went back to my desktop Vista installation, and it remained stuck with debug mode on. It could be a hardware problem, but I thought you might like to see my experience to recover your camera if it is stuck in debug mode.

Dick
05-10-2008, 09:13 AM   #12
Pentaxian
Lowell Goudge's Avatar

Join Date: Jan 2007
Location: Toronto
Photos: Gallery | Albums
Posts: 15,400
I have 2 questions regarding this.

first, how long do you think it will take pentax to release another version to stop people from getting into the debug menu, and second, will they incorporate any other fixes in software when they do, specifically adding perhaps a menu option for focus adjust, adding a teleconverter compensation factor for SR and Exposure, and fix the manual lens exposure problem
05-10-2008, 04:51 PM   #13
Senior Member
joefru's Avatar

Join Date: Mar 2008
Location: South Louisiana
Photos: Gallery
Posts: 210
There's something to be said for owning the same camera as everyone else. There are some talented firmware hackers out there. Unfortunately, they all have Canons.
05-10-2008, 06:35 PM   #14
Veteran Member




Join Date: Nov 2006
Location: Hong Kong
Posts: 1,934
Original Poster
QuoteOriginally posted by Lowell Goudge Quote
first, how long do you think it will take pentax to release another version to stop people from getting into the debug menu,
My bet: NEVER - since it is an old model now.

QuoteQuote:
and second, will they incorporate any other fixes in software when they do, specifically adding perhaps a menu option for focus adjust, adding a teleconverter compensation factor for SR and Exposure, and fix the manual lens exposure problem
NEVER, for sure, despite your ideas are all good and actually easier be implemented by Pentax if they are willing to do.

If you want to have the focus adjust, I think we must get the new K20D which will be the only model has this feature until new model arrives.
05-10-2008, 06:54 PM   #15
Pentaxian
Lowell Goudge's Avatar

Join Date: Jan 2007
Location: Toronto
Photos: Gallery | Albums
Posts: 15,400
QuoteOriginally posted by RiceHigh Quote
My bet: NEVER - since it is an old model now.



NEVER, for sure, despite your ideas are all good and actually easier be implemented by Pentax if they are willing to do.

If you want to have the focus adjust, I think we must get the new K20D which will be the only model has this feature until new model arrives.
Actually focus has never bothered me, metering and TC support, neither of which have been addressed on the K20D are what I am interested in mostly.

Without addressing these 2 points, I see no reason to upgrade from the K10D for the extra megapixles only.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, debug, debug mode, dslr, forum, k10d, k10d firmware, pentax, photography, program, usb
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
K10D focus adjustment with debug mode cem.kumuk Pentax DSLR Discussion 12 01-16-2016 07:11 PM
AF Area Test in K10D Debug Mode mcjm78 Pentax DSLR Discussion 11 02-07-2011 09:57 AM
Anyone use K10D at debug mode? rosier19 Pentax DSLR Discussion 25 12-18-2010 07:34 PM
K10D debug mode and 35 Limited macro treebeard Pentax DSLR Discussion 10 10-21-2009 08:47 PM
K10D doesn't trigger shutter after debug mode Marcoz Pentax DSLR Discussion 7 02-18-2009 11:27 AM



All times are GMT -7. The time now is 03:23 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top