Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
12-25-2014, 07:40 PM   #1
Site Supporter
Mapleleaf-Mick's Avatar

Join Date: Nov 2007
Location: Saskatoon, Canada
Posts: 299
Memory card problem - K3

I have started to get a message on my K3 saying "memry card error". This only applies to slot 2. I have tried swiping cards but that makes no difference. I have reset the camera but that doesn't work. The only thing that seems to work is if I can reformat the card. The problem with doing this is that it takes about 8 tries before it will let me format regardless of the card used. I keep getting the "memory card error" message and it won't allow me to format. Then if I keep trying, eventually it will reformat the card. Of course, I lose any pics on the card. As well, when I get the message, I cannot view any pictures on the card.

Any ideas what the heck is going on?

Thanks for reading my post


Michael J.

12-25-2014, 07:44 PM   #2
Senior Member
powasky's Avatar

Join Date: Dec 2014
Posts: 105
Hi Michael. Have to tried blowing out the compartment of slot 2? The first thing that comes to mind is that there may be some grit or lint in there causing the connection to be shaky.

Also, have you tried formatting a card in the computer first?
12-25-2014, 08:28 PM   #3
Site Supporter




Join Date: Apr 2011
Photos: Albums
Posts: 3,407
Or you could even try inserting a card which was formatted in slot 1.


By trying combinations you can isolate if the card is the problem or the slot.


Also, you do not need to lose the images on the card - remove the card and insert it into an SD slot on or attached to your computer. Does that read images properly.
12-25-2014, 09:48 PM   #4
Site Supporter
Mapleleaf-Mick's Avatar

Join Date: Nov 2007
Location: Saskatoon, Canada
Posts: 299
Original Poster
I have tried reversing cards and the problem only occurs in slot 2. This problem only started about 3 days ago. I will try blowing out the compartment. Thanks for the advice guys.

Michael J.

12-26-2014, 02:14 AM   #5
Forum Member




Join Date: Jan 2014
Posts: 98
Since I owned the K3 I had strange memory card issues, sometimes after removing a card and replacing it, I would get "no card in camera" re-inserting it would clear it, other times I found images on the second card that should have been on the first. This persisted until finally neither card slot recognized a card and the screen displayed "no card in camera" for both slots and effectively the camera could not store a photo. I returned the camera to Pentax in France and they confirmed that fault and said they would have to replace the main board, they had to wait for parts and it took month till I received the camera.
Keep an eye on this as a couple of niggles turned into a dead camera!
12-26-2014, 03:18 AM   #6
Forum Member
gtis's Avatar

Join Date: Mar 2011
Location: south yorkshire
Photos: Gallery
Posts: 82
QuoteOriginally posted by Mapleleaf-Mick Quote
I have started to get a message on my K3 saying "memry card error". This only applies to slot 2. I have tried swiping cards but that makes no difference. I have reset the camera but that doesn't work. The only thing that seems to work is if I can reformat the card. The problem with doing this is that it takes about 8 tries before it will let me format regardless of the card used. I keep getting the "memory card error" message and it won't allow me to format. Then if I keep trying, eventually it will reformat the card. Of course, I lose any pics on the card. As well, when I get the message, I cannot view any pictures on the card.

Any ideas what the heck is going on?



Thanks for reading my post


Michael J.
Hi
I have the same problem using PNY cards updated to latest firmware
And going to try sandisk cards to see if the problem keeps recurring
Neil
12-26-2014, 10:55 PM   #7
Site Supporter
Mapleleaf-Mick's Avatar

Join Date: Nov 2007
Location: Saskatoon, Canada
Posts: 299
Original Poster
Neil, that is what I am using PNY 32 cards. Please let me know if changing card types solves the problem.

Michael J.
12-27-2014, 02:55 AM   #8
Forum Member




Join Date: Jan 2014
Posts: 98
Now others mention it, it all started with a Pony 16Gb card, I threw it in the bin!

12-27-2014, 02:58 AM   #9
Administrator
Site Webmaster
Adam's Avatar

Join Date: Sep 2006
Location: Arizona
Photos: Gallery | Albums
Posts: 42,755
If sd 2 gives you an error, try formatting the card in sd 1 and then putting it in sd 2 to see if it will work.

Adam
PentaxForums.com Webmaster (Site Usage Guide | Site Help | My Photography)



PentaxForums.com's high server and development costs are user-supported. You can help cover those costs by donating. Or, buy your photo gear from our affiliates, Adorama, B&H Photo, or Topaz Labs, and get FREE Marketplace access - click here to see how! Trusted Pentax retailers:

12-27-2014, 03:02 AM   #10
Forum Member
gtis's Avatar

Join Date: Mar 2011
Location: south yorkshire
Photos: Gallery
Posts: 82
QuoteOriginally posted by Mapleleaf-Mick Quote
Neil, that is what I am using PNY 32 cards. Please let me know if changing card types solves the problem.

Michael J.
Hi Michael J
Mine are 16gb cards,will let you know if changing card helps
Going out all day Monday to a nature reserve will try the camera
And cards there, if we are not snowed in
Neil
12-27-2014, 05:37 AM   #11
Banned




Join Date: Feb 2013
Posts: 390
QuoteOriginally posted by Mapleleaf-Mick Quote
Neil, that is what I am using PNY 32 cards. Please let me know if changing card types solves the problem.

Michael J.

I had random memory card errors using PNY cards in my K30. Switched to SanDisk and haven't had an error since. Oddly, the PNY's worked well in my K20. Seems each model camera plays differently with certain SD Cards, SanDisk being the one brand that plays well with all models. Have not tried the PNY's in the K3.
01-01-2015, 12:21 PM   #12
Forum Member
gtis's Avatar

Join Date: Mar 2011
Location: south yorkshire
Photos: Gallery
Posts: 82
Hi Michael j
Tried a sandisk card in slot one and a micro sd card supplied
By maplins uk in slot two took 139 shots in JPEG and the
K3 never came up with memory card error
Going to get two sandisk 16 gb extreme card to try
Will let you know how they work out
Neil
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, card, dslr, format, k3, memory card, message, photography, reformat
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
k3 memory card storing quick switch? esancho Pentax K-3 23 03-08-2015 09:31 AM
Problem with the memory card Photogoof Photographic Industry and Professionals 7 06-08-2013 08:58 AM
Memory Card Problem Conan Maol Troubleshooting and Beginner Help 7 02-20-2011 10:20 AM
K20D - memory card problem crazymarc Pentax DSLR Discussion 18 11-05-2010 04:52 AM
Memory Card Problem? 8540tomg Pentax DSLR Discussion 10 08-25-2009 09:03 AM



All times are GMT -7. The time now is 08:27 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top