Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
05-28-2008, 04:41 PM   #1
Junior Member




Join Date: Nov 2007
Location: NY
Posts: 26
Memory Card Error! Pentax K10 D

Hi All,

Today when I was taking pictures, my memory card stopped working...initially I got the message (after clicking the pic) " this picture is not saved", I thought the card was full but it showed "MEMORY CARD ERROR". I tried switching off the camera and also tried connecting the sd card using the card reader in my laptop, but nothing worked out.

I have some nite pics which were taken in Niagara and I really dont wanna loose them, If anyone had same experience and was successful in retrieving the pictures please let me know.

Thank you

05-28-2008, 05:22 PM   #2
Senior Member
joefru's Avatar

Join Date: Mar 2008
Location: South Louisiana
Photos: Gallery
Posts: 210
What happens when you put it in your laptop?
05-28-2008, 05:30 PM   #3
Junior Member




Join Date: Nov 2007
Location: NY
Posts: 26
Original Poster
I tried connecting it with the camera and in-built card reader, but the sd card is not being recognized .
05-28-2008, 07:35 PM   #4
Senior Member




Join Date: Jan 2007
Location: Phoenix, AZ USA
Posts: 165
There is software available to recover deleted photos but I don't know if it will recover from a corrupted card.

I'm interstested in knowing what brand of card it is because I had a similar problem with an Ultra Products card. I threw it away but I was lucky there were no keepers on it.

05-28-2008, 09:41 PM   #5
Veteran Member
rfortson's Avatar

Join Date: Sep 2006
Location: Houston TX
Photos: Gallery
Posts: 2,129
QuoteOriginally posted by kriss15 Quote
I tried connecting it with the camera and in-built card reader, but the sd card is not being recognized .
Look for various software solutions. I think it can be saved, though if the card won't even mount, then it might be tricky.

One good thing about software is that you can usually download a trial and see whether or not it will work (within limits, usually won't actually save the files, just show you that they're there). If it works, then you can choose to pay.
05-29-2008, 12:05 AM   #6
Veteran Member
spyglass's Avatar

Join Date: Jun 2007
Location: British Columbia, Canada
Posts: 753
I just bought the sandic Ultra III 4Gb card and it came with a USB card reader and a mini cd with their recovery software. You might want to go buy the new sandisc card w/ all of it goodies, and try the software. If that won't work contact the card manufacturer and see if they have any advice. It does not sound too promising if your laptop can not see the card. Try another computer / USB. I remember my old laptop had a USB port that had trouble with USB card readers at times.
06-16-2008, 05:39 AM   #7
Senior Member
skydragoness's Avatar

Join Date: Sep 2006
Location: Delaware, USA
Photos: Gallery
Posts: 163
*bump* This just happened to me yesterday...

I was at an Italian Festival yesterday afternoon, I had my trusty Sandisk Extreme III 4GB card and was firing off some raw shots. I went to review the last pic I took (as I did before w/ the prev ones) and I suppose it may have still be writing but then I got a "image cannot be recorded." So I turned off the camera and turned it back on and hit the review button and I got "memory card error."

I had two other Sandisk cards, so I turned off the camera and went in the shade to put in my Sandisk Ultra, switched the file format to Jpg, and fired a couple of shots. Went to review them.. nothing, it was all black and when I tried again it said memory card error. I even turned off the camera and took out the battery and put it back in and it was still saying it had a card error.

As of right now, my 4gb extreme card still has the raw files I shot, but the very last one cannot be opened by photoshop. It's a relief I have something to show my professor today in class, but it's crap ( i was there for probably 5min getting a "feel" for the event).

Is my camera potentially busted? I'm going to try putting in another Sandisk Extreme card I left at home and see if it works. Ive had these cards for a year or so and never had a problem before.

Last edited by skydragoness; 06-16-2008 at 06:26 AM.
06-16-2008, 05:46 AM   #8
Senior Member
skydragoness's Avatar

Join Date: Sep 2006
Location: Delaware, USA
Photos: Gallery
Posts: 163
Okay, now I'm worried...

I put in a fresh new battery in my K10 and put a blank 2gb Extreme card I didn't use yesterday at the event. It was fine.

THEN I put in my 4gb Extreme (after turning camera off/on) and it automatically said "memory card error"
Tried the 1GB Ultra, same thing happened. So I put the 2gb Extreme back in expecting it to work and it said "memory card error" too!

Camera refuses to format them as well.

AGH! What happened!? They can't all be corrupted since the 2gb worked fine until I put the other ones in! I know my firmware was last updated last year. Is it firmware related? Could I try formating my cards on my computer? I'd like to know since my friend wants me to take photos for her later this afternoon. (I do have a Olympus E-300 with a kit lens in the house as a last resort).

edit: trying putting the 2gb in again, and the camera took a while to turn on and then the date/month/year screen came up and the camera froze. I turned it off and the screen was still ON! I finally had to take the battery out. Took the card out and turned the camera on and the camera functioned fine. It hates all my SanDisk cards now!


Last edited by skydragoness; 06-16-2008 at 06:06 AM.
06-16-2008, 08:36 PM   #9
Senior Member
skydragoness's Avatar

Join Date: Sep 2006
Location: Delaware, USA
Photos: Gallery
Posts: 163
No one can help me out? I should've made my own thread instead of doing the right thing and posting in someone else's
06-16-2008, 09:44 PM   #10
Ole
Administrator
Ole's Avatar

Join Date: Sep 2006
Location: Copenhagen, Denmark
Photos: Gallery | Albums
Posts: 3,881
Wild guess: Check the little switch on the card - the switch must be pushed all the way towards the end with the electrical contacts. Or else the camera cannot write to the card.
06-16-2008, 10:35 PM   #11
Veteran Member
Venturi's Avatar

Join Date: Mar 2008
Location: Tulsa, OK
Photos: Gallery
Posts: 2,639
QuoteOriginally posted by skydragoness Quote
No one can help me out? I should've made my own thread instead of doing the right thing and posting in someone else's
So this is happening now with multiple cards, and not just the original one you used at the event? The 2GB card and the 1GB card are also erroring in the camera?

Have you tried taking either of those "blank" cards and formatting them with your PC? Are they readable there?
If they work in the PC but not in the camera then I would posit that it is not the card that is bad but rather the camera's card slot.

As to whether the data/pics on the 4GB are salvageable I wouldn't hazard a guess as I have not had need to install the Sandisk software, or any other as yet.
06-17-2008, 03:29 PM   #12
Senior Member
skydragoness's Avatar

Join Date: Sep 2006
Location: Delaware, USA
Photos: Gallery
Posts: 163
Venturi: Yes the card that I didn't bring with me on Sunday also brings up a "memory card error" as soon as I turn the camera on.

Tried formatting all the cards on the camera, won't do it because of "errors" it states.

So I formatted all of them on my computer, and tried the 4g Extreme on my camera again. Still, "memory card error". And being that I didn't take one of them with me that day I can't believe they are all corrupt. I've had all of these cards for about a year and a half with no problems ever.

As far as the images off the 4gb, I was able to pull them up in PS on my computer but the very last file (when the error happened) was unopenable which made sense.

All I did was hit the review button too quickly (i'm spoiled by these Sandisk Extreme cards' speeds) when it was not completely done writing. I guess its all my fault and you can mess the card reader up by doing that huh?


As far as the locks, they are all where they should be. Besides, doesn't the camera say "card locked" when you do lock them?


I'm upset, I guess I'll call Pentax or something. But it feels futile.. I was hoping it was something stupid/easy that I could fix. Now its going to be super costly

Last edited by skydragoness; 06-17-2008 at 03:34 PM.
06-17-2008, 04:02 PM   #13
Veteran Member
madbrain's Avatar

Join Date: May 2008
Location: San Jose, CA
Posts: 806
QuoteOriginally posted by skydragoness Quote
Venturi: Yes the card that I didn't bring with me on Sunday also brings up a "memory card error" as soon as I turn the camera on.

Tried formatting all the cards on the camera, won't do it because of "errors" it states.

So I formatted all of them on my computer, and tried the 4g Extreme on my camera again. Still, "memory card error". And being that I didn't take one of them with me that day I can't believe they are all corrupt. I've had all of these cards for about a year and a half with no problems ever.

As far as the images off the 4gb, I was able to pull them up in PS on my computer but the very last file (when the error happened) was unopenable which made sense.

All I did was hit the review button too quickly (i'm spoiled by these Sandisk Extreme cards' speeds) when it was not completely done writing. I guess its all my fault and you can mess the card reader up by doing that huh?


As far as the locks, they are all where they should be. Besides, doesn't the camera say "card locked" when you do lock them?


I'm upset, I guess I'll call Pentax or something. But it feels futile.. I was hoping it was something stupid/easy that I could fix. Now its going to be super costly
If the cards format on the computer but don't read in the camera,, it sounds like a problem with the camera's built-in card reader. Maybe you can try cleaning the contacts ? An air blower might work.

Also make sure you do a long (not quick) format in the computer, to make sure the cards are good all the way.
06-17-2008, 04:17 PM   #14
Veteran Member
falconeye's Avatar

Join Date: Jan 2008
Location: Munich, Alps, Germany
Photos: Gallery
Posts: 6,863
QuoteOriginally posted by skydragoness Quote
All I did was hit the review button too quickly [...] I'm upset, I guess I'll call Pentax or something. But it feels futile.. I was hoping it was something stupid/easy that I could fix. Now its going to be super costly
@skydragoness, I fear your forum can't help is because your camera broke

Yes, a camera's card slot or electronics can break. Because it happened during normal operation, it won't be a mechanical defect. And it wasn't your fault of course, as you are allowed to push the review button as quickly as you like

From your join date I guess that your camera is 21 months old. So, it should still be under dealer warranty (at least, it would be in Europe, don't know for sure in the States). If not, apply for repair free of charge as this shoudn't happen.
06-17-2008, 09:08 PM   #15
Senior Member
skydragoness's Avatar

Join Date: Sep 2006
Location: Delaware, USA
Photos: Gallery
Posts: 163
Madbrain: Yeah I did the long format

Falconeye: It's out of warranty for sure. I think I bought the camera in Nov. of 2006 when it first started hitting the stores. I also bought it online (a mistake I won't make again, but there is only *one* independent camera shop in my area and they didn't get the K10 until the following year).


I can't image it being super expensive of a repair through Pentax because it's not something that has to do w/ the camera's sensor.

I'll give them a ring tommorow.

Thanks for all your help guys. Guess I'll have to get by with my boyfriend's Olympus E-300 with a kit lens... need to convince him to get a tele :ugh:
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, card, dslr, memory, memory card, photography, pictures
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Memory card error jaysee15 Pentax DSLR Discussion 5 08-18-2011 09:26 AM
Memory card error chuckdua Troubleshooting and Beginner Help 10 09-29-2010 02:15 PM
PLease help! - 'memory card error' on Pentax K100D Ophelia Pentax DSLR Discussion 2 10-01-2009 03:13 PM
Memory Card Error soundview Pentax DSLR Discussion 5 07-23-2008 09:08 AM
Memory card error skaktuss Pentax DSLR Discussion 8 04-26-2007 06:03 AM



All times are GMT -7. The time now is 11:52 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top