Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
02-22-2015, 03:57 PM   #1
Junior Member




Join Date: Nov 2014
Posts: 38
My K3 locked up with pink artifacts can't turn off/on

My K3 locked up with pink artifacts while shooting at an event. I wasted 10 mins on k3 trying to fix this problem. I was using battery grip with 2 batteries. Samsung pro SD card 90MB/S (been using this setup for over 4 months without problem). The only way to fix this problem was to remove the in body battery. The battery selected was on AUTO. After switching battery to use body only, the problem was fixed. I will post a picture when it happen again. This is the first time having this problem.

02-22-2015, 04:07 PM   #2
Administrator
Site Webmaster
Adam's Avatar

Join Date: Sep 2006
Location: Arizona
Photos: Gallery | Albums
Posts: 40,993
Was one of the two batteries running low? That can increase the likelihood of freezing up.

Adam
PentaxForums.com Webmaster (Site Usage Guide | Site Help | My Photography)



PentaxForums.com's high server and development costs are user-supported. You can help cover those costs by donating. Or, buy your photo gear from our affiliates, Adorama, B&H Photo, or Topaz Labs, and get FREE Marketplace access - click here to see how! Trusted Pentax retailers:

02-22-2015, 04:18 PM   #3
Loyal Site Supporter
Scorpio71GR's Avatar

Join Date: Nov 2014
Location: Michigan
Photos: Gallery | Albums
Posts: 3,228
I have never set the battery setting to auto. I always use grip first that way I do not have to remove the grip to take out the first dead battery. Most of the time I will switch the battery myself manually before it goes dead to avoid problems.
02-22-2015, 04:24 PM   #4
Junior Member




Join Date: Nov 2014
Posts: 38
Original Poster
QuoteOriginally posted by Adam Quote
Was one of the two batteries running low? That can increase the likelihood of freezing up.
Nope, it wasn't even half way. nothing work unless I remove grip and the body battery.

02-22-2015, 05:21 PM - 1 Like   #5
Veteran Member
JayBee451's Avatar

Join Date: Apr 2013
Location: Queensland, Australia
Posts: 379
My K3 froze up the other day also, but I did not have the grip attached at the time.
It happened as I wanted to show some friends a few images I had taken.
Battery had over half charge left, nothing worked, no response from anything I did.
Removed battery, re install and all was OK again.
This has been a one of so far.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
artifacts, battery, body, camera, dslr, k3, photography
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Turn off auto focus on K3 Shutter Button Mark K5 Troubleshooting and Beginner Help 7 03-02-2015 01:30 PM
Do you turn your K3 off between shots? sadatoni Pentax K-3 16 10-28-2014 05:20 AM
K3 Focus confirmation beep - can I turn it off? Molly Troubleshooting and Beginner Help 6 07-31-2014 09:24 AM
shake reduction can't turn on ? davidsyd Pentax K-30 & K-50 3 12-24-2012 07:32 AM
Mirror up, camera won't turn on clickinchick Troubleshooting and Beginner Help 3 01-26-2011 07:20 PM



All times are GMT -7. The time now is 05:35 AM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top