Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
03-05-2015, 09:32 PM   #1
Junior Member




Join Date: Mar 2014
Posts: 29
K20D - Slow review, Card Access Light on

When I've taken a shot and hit Review button (blue arrow bottom left) the Card access light blinks for about 3-4 seconds then stops when picture shows on LCD. On the K10D the review was virtually instant and no blinking light. Can't find it in the manual. Anyone know what's going on?

03-05-2015, 10:56 PM   #2
Ole
Administrator
Ole's Avatar

Join Date: Sep 2006
Location: Copenhagen, Denmark
Photos: Gallery | Albums
Posts: 3,881
A couple of questions/suggestions:

Shooting RAW with the K20D vs. JPG with the K10D?

Slow shutter speed noise reduction?

Has the card been formatted recently - it could be fragmented?
03-05-2015, 11:05 PM   #3
Administrator
Site Webmaster
Adam's Avatar

Join Date: Sep 2006
Location: Arizona
Photos: Gallery | Albums
Posts: 43,118
QuoteOriginally posted by Mike Gallagher Quote
When I've taken a shot and hit Review button (blue arrow bottom left) the Card access light blinks for about 3-4 seconds then stops when picture shows on LCD. On the K10D the review was virtually instant and no blinking light. Can't find it in the manual. Anyone know what's going on?
Are you using a slow card- i.e. class 2, 4, or 6? You should be using a class 10 card for best results.

Adam
PentaxForums.com Webmaster (Site Usage Guide | Site Help | My Photography)



PentaxForums.com's high server and development costs are user-supported. You can help cover those costs by donating. Or, buy your photo gear from our affiliates, Adorama, B&H Photo, or Topaz Labs, and get FREE Marketplace access - click here to see how! Trusted Pentax retailers:

03-06-2015, 01:14 AM   #4
Veteran Member
sterretje's Avatar

Join Date: Dec 2008
Location: Roodepoort, South Africa
Photos: Gallery | Albums
Posts: 3,534
QuoteOriginally posted by Ole Quote
A couple of questions/suggestions:

Shooting RAW with the K20D vs. JPG with the K10D?

Slow shutter speed noise reduction?

Has the card been formatted recently - it could be fragmented?
Mike is not talking about instant review, so I doubt the first two points apply. Unless he has disabled instant review (possible?) and presses the play (blue) button immediately after taking the shot.

03-06-2015, 08:14 PM   #5
Junior Member




Join Date: Mar 2014
Posts: 29
Original Poster
Ole, Adam & sterretje - SOLVED
Thanks for leaping in. Not sure what happened but it works now. I don't have the K10D as I think the techies are using it for a door stopper or something now. They sent me the new K20D. So I couldn't do a comparison. Never mind.
In order to answer your questions I'm using an 8Gb Sandisk C10 card. I shot photos on JPEG 14.6Mpixels and RawDNG without any change. Then I shot on Raw+ and it worked properly - review showed very quicly and the card light stayed on for about 4-5 seconds. (I can only suspect what that's about for now - any info?) Then I shot on JPEG High 3 star & 4 star and those settings all worked fine too. On checking then I found the Instant Review was set to Histogram which caused a mild annoyance but that was easy to change and Review time was on 5 secs so that shouldn't have caused the "fault."
It'd be interesting to know what that Card Access light means and is for. I can't find any reference to it except in the Camera Parts diagram.
Thanks again. You at least made me explore the right places.
Mike.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
access, camera, card, dslr, light, photography, review
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Slow memory card for a K-5. BlakeShellman Pentax DSLR Discussion 6 11-24-2014 03:40 AM
Slow Computer...More RAM? CPU? Video Card? cali92rs Digital Processing, Software, and Printing 17 05-23-2014 06:09 AM
Wifi card slow transfer rate lotech Troubleshooting and Beginner Help 2 03-09-2014 07:45 AM
Slow reading card. Pontax Pentax K-5 7 01-07-2014 11:42 AM
AF-360FGZ on K20D Slow Shutter Speed in Av Mode Peter71 Pentax Camera and Field Accessories 3 09-11-2008 07:37 PM



All times are GMT -7. The time now is 04:41 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top