Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
03-16-2015, 06:50 AM   #1
Senior Member
igabc's Avatar

Join Date: Feb 2015
Photos: Gallery | Albums
Posts: 126
SR not enabled on K3

Why the shake reduction function no my K3 is always greyed out with vintage lenses?
Thanks

03-16-2015, 07:03 AM   #2
Pentaxian
pete-tarmigan's Avatar

Join Date: Apr 2009
Location: Conception Bay South, New-fun-land
Photos: Gallery
Posts: 941
QuoteOriginally posted by igabc Quote
Why the shake reduction function no my K3 is always greyed out with vintage lenses?
Thanks
See the K-3 Operating Manual, p. 82.
03-16-2015, 08:58 AM   #3
Veteran Member




Join Date: Sep 2006
Location: WV
Posts: 1,484
The SR function can only operate if the camera knows the focal length of the lens. Since vintage lenses cannot communicate with the camera body, you must manually input the focal length.
03-16-2015, 09:04 AM   #4
Senior Member
igabc's Avatar

Join Date: Feb 2015
Photos: Gallery | Albums
Posts: 126
Original Poster
That's what I always do. No success

03-16-2015, 09:19 AM   #5
Senior Member




Join Date: Mar 2014
Posts: 225
Are you shooting with the 2s or 10s timer? If this is the case the SR will be forced off no matter what lens is mounted in the camera.
03-16-2015, 09:32 AM   #6
Senior Member
igabc's Avatar

Join Date: Feb 2015
Photos: Gallery | Albums
Posts: 126
Original Poster
No it's not on timer
03-16-2015, 10:24 AM   #7
Site Supporter
jatrax's Avatar

Join Date: May 2010
Location: Oregon
Photos: Gallery | Albums
Posts: 10,284
Are you using the remote setting in the drive mode? That also turns off SR.

To test, change the lens to a modern one with contacts and see if it works there. Once it works with that lens then you know it is the lens and not the camera settings.

One other possibility is if the manual lens has a non-conductive mount. The camera cannot detect the lens. Do you get a prompt to select focal length on startup or are you selecting it manually? If you don't get the prompt it is an indication that the camera cannot see the lens and even if you input the focal length the camera still thinks there is no lens attached.
03-16-2015, 11:44 AM   #8
Veteran Member




Join Date: Sep 2006
Location: WV
Posts: 1,484
Do you have "Using Aperture Ring" set to "Enable"? ( Menu C4 item 27, page 83 in the manual).

If you are using lenses with an aperture ring with no "A" setting (or set in a position other than "A") then you have to enable use of the aperture ring.

03-16-2015, 06:17 PM   #9
Senior Member
igabc's Avatar

Join Date: Feb 2015
Photos: Gallery | Albums
Posts: 126
Original Poster
1. No remote
2. Using a lens with A auto lens. I actually tried with 3 vintage A lenses and none was working.

Now it's all good again. Can't figure out what was wrong.
I'll post if I'll spot the problem.


thank you
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, dslr, k3, photography
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
K3 sr tennjed Pentax K-3 8 03-02-2015 06:53 PM
Pentax k3 live-view noise jerk normal? Tested SR on and off... NW_Legacy Pentax DSLR Discussion 2 02-12-2015 10:28 PM
Sigma EF-610 Super not firing on K3 iikamrii Troubleshooting and Beginner Help 3 06-13-2014 06:52 PM
New model sigma 18-250 lens not focussing correctly on k3 David&karen Pentax SLR Lens Discussion 2 05-16-2014 08:02 AM
digital SR in k3 paranoia23 Video and Pentax HDSLRs 14 12-01-2013 06:31 AM



All times are GMT -7. The time now is 10:33 PM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top