Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
06-05-2008, 11:26 AM   #1
Forum Member
ariahspam's Avatar

Join Date: May 2008
Location: Lima, Peru
Posts: 69
K20D problem

Hi, I've got a problem with the camera. It has happened 4 times. The problem is:

When I shot and then press the 'play' button to see the picture, nothing appears and the buttons stop working. When I turn the camera off, the number of remaining pictures is displayed on the top lcd. If the camera is then turned on, the buttons still don't work, if turned off, the remaining pics still displayed. I have to manually take off the battery and insert it again to fix this. I'm using a 1-month old transcend 8gb class 6. I tend to format the card on-camera instead of deleting the pictures via PC.

Any comments? Has this happened to any of you?

06-05-2008, 11:52 AM   #2
Pentaxian
Wheatfield's Avatar

Join Date: Apr 2008
Location: The wheatfields of Canada
Posts: 10,043
Are you making certain the write light is off before you start pushing buttons? I just bought a few Patriot 8gb class 6 cards (probably the same as your Transcends with different labels) and find they are very slow to write to.
06-05-2008, 01:38 PM   #3
Veteran Member
ftpaddict's Avatar

Join Date: Jan 2008
Location: Yurp
Photos: Gallery
Posts: 4,669
QuoteOriginally posted by ariahspam Quote
When I turn the camera off, the number of remaining pictures is displayed on the top lcd...
That's actually supposed to happen.
06-05-2008, 07:39 PM   #4
Forum Member
ariahspam's Avatar

Join Date: May 2008
Location: Lima, Peru
Posts: 69
Original Poster
QuoteOriginally posted by ftpaddict Quote
That's actually supposed to happen.
Sorry, forgot to mention the fact that the shot taken is lost.

06-05-2008, 11:13 PM   #5
Forum Member
Jaleel's Avatar

Join Date: May 2008
Location: Moscow, Russia
Photos: Gallery
Posts: 74
Maybe a SD card problem
Try another card to see if this a camera problem or card
06-06-2008, 12:23 AM   #6
Veteran Member
ftpaddict's Avatar

Join Date: Jan 2008
Location: Yurp
Photos: Gallery
Posts: 4,669
It's a K20D, so I'm sure it's still under warranty. If swapping SDs doesn't work, it's off to get it serviced.
06-06-2008, 12:10 PM   #7
Forum Member
ariahspam's Avatar

Join Date: May 2008
Location: Lima, Peru
Posts: 69
Original Poster
Well, unfortunately it is nearly impossible to send equipment for the warranty as I live in south america and, memory cards here are very expensive so I'll just have to wait to buy another one. Thanks anyway
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
buttons, camera, dslr, photography, pictures
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
k20d problem Neto Pentax DSLR Discussion 2 09-24-2009 02:59 AM
K20D Problem photoTaz Pentax DSLR Discussion 2 06-21-2009 09:25 PM
Just got my K20D... problem already - need help! dimak Troubleshooting and Beginner Help 6 05-01-2009 04:21 AM
Card read problem K20d. Have you had this problem? rsi1986 Pentax DSLR Discussion 8 12-27-2008 05:25 AM
Problem with K20D eadnams Pentax DSLR Discussion 7 06-28-2008 07:21 AM



All times are GMT -7. The time now is 12:26 PM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top