Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
04-13-2015, 12:14 PM   #1
Forum Member




Join Date: Dec 2007
Location: Riga, Latvia
Posts: 82
No Shake Reduction with Samyang

Hello!

I have encountered a strange behavior of my K500....The Shake Reduction is permanently off with a mounted samyang lens. I input the focal length and everything should be ok, but the shake reduction is inactive...
Am I missing something or what? I have always been able to get SR with M42 lenses - what is different?

A huge thanks in advance!

04-13-2015, 12:20 PM   #2
Site Supporter




Join Date: Jan 2011
Photos: Albums
Posts: 2,235
Which shooting mode are you using?
04-13-2015, 12:30 PM   #3
Forum Member




Join Date: Dec 2007
Location: Riga, Latvia
Posts: 82
Original Poster
I have tried every mode. I have tried setting samyang to A and using Av mode and I have also used M mode and other - no changes. Everything works, meters ok but no SR. Yes - when setting the aperture manually the body obviously looses the F-number.
04-13-2015, 12:32 PM   #4
Pentaxian




Join Date: Oct 2011
Location: Savannah, GA
Posts: 4,989
But what drive mode? If set to remote or delay it will be off...

04-13-2015, 12:39 PM   #5
Forum Member




Join Date: Dec 2007
Location: Riga, Latvia
Posts: 82
Original Poster
I use single shot obviously! The usual...
04-13-2015, 01:40 PM   #6
Pentaxian




Join Date: Oct 2011
Location: Savannah, GA
Posts: 4,989
What lens is this? And what body (some of them wouldn't ask for focal length unless SR was turned on and ready to go) ? So you see the little hand icon and it is crossed out or what?
04-13-2015, 04:09 PM   #7
Pentaxian
Aaron28's Avatar

Join Date: Jan 2015
Location: Huntsville, Al
Posts: 1,070
odd...would not think any lens would effect SR....sometimes I do not highlight on or off correctly...as sometimes I think I turned it on but have not and vice versa
04-13-2015, 05:21 PM   #8
Site Supporter
dakight's Avatar

Join Date: Sep 2014
Location: Phoenix, AZ
Photos: Albums
Posts: 1,137
Check your user manual for the SR instructions. It specifies certain modes in which SR is unavailable for selection. If all else fails, reset the camera to clear it out.

04-13-2015, 06:14 PM   #9
Pentaxian
Aaron28's Avatar

Join Date: Jan 2015
Location: Huntsville, Al
Posts: 1,070
ah..true dat
04-14-2015, 12:42 PM   #10
Forum Member




Join Date: Dec 2007
Location: Riga, Latvia
Posts: 82
Original Poster
Thank you all for your input!
I can inform you that I ended up updating the firmware...I had 1.00 originally. There are no mention of such issue in the description of the firmware updates - so I don't know how or what - but it helped. Maybe resetting would have helped also but sorry - didn't check.
My guess is that this half-baked aperture communication by samyang probably somehow mystically caused this - but who knows. I just know that this fixed this but what caused it - no clue!
04-14-2015, 04:39 PM   #11
Site Supporter
dakight's Avatar

Join Date: Sep 2014
Location: Phoenix, AZ
Photos: Albums
Posts: 1,137
All's well that ends well.
04-15-2015, 11:24 AM   #12
Pentaxian
ScooterMaxi Jim's Avatar

Join Date: Jul 2009
Location: Minnesota
Posts: 1,464
QuoteOriginally posted by madphys Quote
Thank you all for your input!
I can inform you that I ended up updating the firmware...I had 1.00 originally. There are no mention of such issue in the description of the firmware updates - so I don't know how or what - but it helped. Maybe resetting would have helped also but sorry - didn't check.
My guess is that this half-baked aperture communication by samyang probably somehow mystically caused this - but who knows. I just know that this fixed this but what caused it - no clue!
Highly unlikely. Many folks shooting various Samyang (Rokinon, Bower, Vivitar, etc.) lenses and this problem has never been reported previously. Possibly a bad contact, or some programming malfunction on the body side, but very unlikely that the lens caused the problem given that the FW update cleared the symptom.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, dslr, photography, reduction, samyang, shake, shake reduction
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Shake reduction or not with tripod ! ! ! devouges Troubleshooting and Beginner Help 16 06-19-2014 07:40 PM
shake reduction with full frame lenses Hiroshi Troubleshooting and Beginner Help 7 05-01-2014 03:39 PM
no shake reduction in video mode skipdc Pentax Q 2 02-24-2013 02:58 PM
NO Shake Reduction w/ Wireless Flash? HermanLee Pentax DSLR Discussion 9 03-04-2009 05:52 AM
No shake reduction with M42? dbuffington Pentax SLR Lens Discussion 8 02-05-2009 06:24 AM



All times are GMT -7. The time now is 08:19 AM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top