Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
04-15-2015, 01:10 PM   #1
Forum Member




Join Date: Jan 2008
Photos: Gallery | Albums
Posts: 85
K3 new firmware update problem

I've just updated my K3 and have noticed the rear LCD turns on as soon as I touch the shutter release just to focus. I'm sure this didn't happen before the firmware update and think there could be an issue with the battery draining quicker if the LCD keeps turning itself on.
Can someone with the pre 1.20 firmware please check if their K3s rear LCD screen turns on if you just touch the shutter release button to focus the lens, the LCD just lightens slightly (nothing displayed) but it must be using power and is a bit distracting when you hold the camera to your eye and the LCD turns on.

04-15-2015, 01:19 PM   #2
Administrator
Site Webmaster
Adam's Avatar

Join Date: Sep 2006
Location: Arizona
Photos: Gallery | Albums
Posts: 42,840
QuoteOriginally posted by mille19 Quote
I've just updated my K3 and have noticed the rear LCD turns on as soon as I touch the shutter release just to focus. I'm sure this didn't happen before the firmware update and think there could be an issue with the battery draining quicker if the LCD keeps turning itself on.
Can someone with the pre 1.20 firmware please check if their K3s rear LCD screen turns on if you just touch the shutter release button to focus the lens, the LCD just lightens slightly (nothing displayed) but it must be using power and is a bit distracting when you hold the camera to your eye and the LCD turns on.
Someone else posted this in the comments on the homepage, so it sounds like it's a bug in the firmware update.

Adam
PentaxForums.com Webmaster (Site Usage Guide | Site Help | My Photography)



PentaxForums.com's high server and development costs are user-supported. You can help cover those costs by donating. Or, buy your photo gear from our affiliates, Adorama, B&H Photo, or Topaz Labs, and get FREE Marketplace access - click here to see how! Trusted Pentax retailers:

04-15-2015, 01:27 PM   #3
Site Supporter
stevebrot's Avatar

Join Date: Mar 2007
Location: Vancouver (USA)
Photos: Gallery | Albums
Posts: 27,291
QuoteOriginally posted by Adam Quote
so it sounds like it's a bug in the firmware update.
So, is it safe to say that recommendation on the update is a qualified "thumbs down"?


Steve
04-15-2015, 01:30 PM   #4
Site Supporter
savoche's Avatar

Join Date: Jun 2011
Location: Lowlands of Norway
Posts: 8,501
QuoteOriginally posted by stevebrot Quote
So, is it safe to say that recommendation on the update is a qualified "thumbs down"?
Yes, seems to be confirmed by several (all?) of those who have upgraded. I'll wait.

04-15-2015, 01:31 PM   #5
Forum Member




Join Date: Jan 2008
Photos: Gallery | Albums
Posts: 85
Original Poster
QuoteOriginally posted by stevebrot Quote
So, is it safe to say that recommendation on the update is a qualified "thumbs down"?


Steve
Yep, definitely a thumbs down.

I've just gone back to 1.11 and everythings OK.
Not good by Pentax though releasing a firmware update with a bug, do they not test before they release. It took me about 10 seconds to notice the bug.
04-15-2015, 01:32 PM   #6
Pentaxian
Paul the Sunman's Avatar

Join Date: Aug 2011
Location: Melbourne
Photos: Gallery
Posts: 1,254
I have made this point in these fora before: Ricoh/Pentax does not seem to have a user test/validation program with new hardware or firmware. Within a couple of hours of the release of v1.20, multiple PF members have reported this bug. If it had gone out to a select group of beta-testers before hand, the issue could have been defused before hitting the public domain. Isn't that a more professional way of operating?
04-15-2015, 01:49 PM - 2 Likes   #7
Administrator
Site Webmaster
Adam's Avatar

Join Date: Sep 2006
Location: Arizona
Photos: Gallery | Albums
Posts: 42,840
I've updated our homepage post with a warning and e-mailed a Japanese Ricoh Imaging rep directly so that they're guaranteed to pick up on the issue.

QuoteOriginally posted by Paul the Sunman Quote
Isn't that a more professional way of operating?
These sorts of things happen all the time in software development, unfortunately, but they certainly could have done a better job with something as obvious as this.

Adam
PentaxForums.com Webmaster (Site Usage Guide | Site Help | My Photography)



PentaxForums.com's high server and development costs are user-supported. You can help cover those costs by donating. Or, buy your photo gear from our affiliates, Adorama, B&H Photo, or Topaz Labs, and get FREE Marketplace access - click here to see how! Trusted Pentax retailers:

04-15-2015, 02:47 PM   #8
Site Supporter
PALADIN85020's Avatar

Join Date: Sep 2010
Location: Arizona
Photos: Gallery | Albums
Posts: 397
I just had the same problem. SECOND problem - I tried to download v. 1.11 from Pentax/Ricoh, and it CHOKED - couldn't download it. Is there an alternate site so I can download it without problems?

John

Highly pissed off.

Update: here is an alternate v. 1.11 download source:

http://www.userdrivers.com/Digital-Camera/Pentax-K-3-Camera-Firmware-Update-1-11/download/

I'm immediately going back to 1.11. This really sucks.


Last edited by PALADIN85020; 04-15-2015 at 03:00 PM.
04-15-2015, 03:03 PM   #9
Senior Member




Join Date: Oct 2013
Photos: Albums
Posts: 292
Donīt be stressed,itīs a problemless little bug and no defective malfunction
Everything is fine,only the little light is on the wrong way :-)
Best regards
04-15-2015, 03:05 PM   #10
Loyal Site Supporter
imtheguy's Avatar

Join Date: Mar 2009
Location: Virginia Beach
Photos: Gallery | Albums
Posts: 2,950
QuoteOriginally posted by mille19 Quote
I've just updated my K3 and have noticed the rear LCD turns on as soon as I touch the shutter release just to focus. I'm sure this didn't happen before the firmware update and think there could be an issue with the battery draining quicker if the LCD keeps turning itself on.
Can someone with the pre 1.20 firmware please check if their K3s rear LCD screen turns on if you just touch the shutter release button to focus the lens, the LCD just lightens slightly (nothing displayed) but it must be using power and is a bit distracting when you hold the camera to your eye and the LCD turns on.


Interesting...after the 1.20 update my k-3 LCD turns OFF when I touch the shutter to focus, just like my k-5's do.
If I missed something here pls kick me.


LCD comes on with power on.
LCD goes/stays off while touching the shutter
LCD goes off with Auto Power Off timer then back on if shutter touched and released.

Last edited by imtheguy; 04-15-2015 at 03:19 PM.
04-15-2015, 03:18 PM   #11
Site Supporter
PALADIN85020's Avatar

Join Date: Sep 2010
Location: Arizona
Photos: Gallery | Albums
Posts: 397
QuoteOriginally posted by imtheguy Quote
Interesting...after the 1.20 update my k-3 LCD turns OFF when I touch the shutter to focus, just like my k-5's do.
If I missed something here pls kick me.


LCD comes on with power on.
LCD goes/stays off when touching the shutter
LCD goes off with Auto Power Off timer then back on if shutter touched and released.
With mine, at power on, the LCD is dormant. When I press the shutter button halfway to focus, it comes on - a very dull "blue screen." This uses power. NOT good.

Please pardon my previous outburst. I hate having to do things twice to leave me right where I was in the first place. Now I assume they'll do a fix on 1.20 - then I'll have to do it again. I'm keeping a copy of 1.11.exe on my hard drive just in case.

John

Last edited by PALADIN85020; 04-27-2015 at 11:32 AM.
04-15-2015, 03:26 PM - 1 Like   #12
Site Supporter
LaurenOE's Avatar

Join Date: Sep 2009
Location: San Francisco Bay Area
Photos: Albums
Posts: 3,482
QuoteOriginally posted by Adam Quote
I've updated our homepage post with a warning and e-mailed a Japanese Ricoh Imaging rep directly so that they're guaranteed to pick up on the issue.

These sorts of things happen all the time in software development, unfortunately, but they certainly could have done a better job with something as obvious as this.
Yep. Happens all the time in software development.
We call them "Undocumented Features".

04-15-2015, 03:54 PM   #13
Site Supporter
stevebrot's Avatar

Join Date: Mar 2007
Location: Vancouver (USA)
Photos: Gallery | Albums
Posts: 27,291
QuoteOriginally posted by PALADIN85020 Quote
I'm immediately going back to 1.11. This really sucks.
Good luck. I have never tried it, but it is my understanding that the process goes up only...no turning back to older versions.


Steve
04-15-2015, 04:21 PM   #14
Pentaxian




Join Date: Feb 2012
Posts: 362
QuoteOriginally posted by stevebrot Quote
Good luck. I have never tried it, but it is my understanding that the process goes up only...no turning back to older versions.


Steve
Someone did it with success (reported in the firmware announcement thread).
04-15-2015, 05:13 PM   #15
Site Supporter
honey bo bo's Avatar

Join Date: Apr 2014
Location: NORTHWESTERN ONTARIO
Photos: Gallery | Albums
Posts: 382
QuoteOriginally posted by imtheguy Quote
Interesting...after the 1.20 update my k-3 LCD turns OFF when I touch the shutter to focus, just like my k-5's do.
If I missed something here pls kick me.


LCD comes on with power on.
LCD goes/stays off while touching the shutter
LCD goes off with Auto Power Off timer then back on if shutter touched and released.

I just upgraded my K3 as well it does the same thing as above and I believe this is what it was doing for the most part with 1.11


I got file off Ricoh Canada Support
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, dslr, firmware, focus, k3, k3 new firmware, lcd, photography, release, shutter, touch
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
K3 Firmware update 1.10 kev.pride Troubleshooting and Beginner Help 8 05-30-2015 11:00 PM
Firmware Update K3 robrob41 Troubleshooting and Beginner Help 9 07-31-2014 11:31 AM
Problem With K30 Firmware 1.06 Update Biro Pentax K-30 & K-50 34 05-02-2014 09:43 AM
K5II V1.05 Firmware Update Problem moparjer Troubleshooting and Beginner Help 7 09-18-2013 01:11 AM
Firmware Update Problem Den Troubleshooting and Beginner Help 4 09-15-2013 12:31 PM



All times are GMT -7. The time now is 09:47 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top