Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
04-16-2015, 09:12 PM   #1
Veteran Member




Join Date: Nov 2013
Posts: 385
FIXED: K-3 bricked after firmware update attempt

I have updated formware quite a few times before but today it seems the update went wrong. These are the steps I took:

- Checked battery. Showed all bars.
- Put firmware on SD card.
- Turned on camera with menu button pressed
- Got a message similar "Battery level low. Can't update date firmware".
- Replaced battery
- Turned camera on
- Top LCD shows battery level for moment then goes blank

It seems the camera is bricked. Is there a way to "hard reset" the camera like you can do with some computers to get everything back to the original state?


Last edited by maxxxx; 04-17-2015 at 06:29 AM.
04-16-2015, 09:29 PM   #2
Administrator
Site Webmaster
Adam's Avatar

Join Date: Sep 2006
Location: Arizona
Photos: Gallery | Albums
Posts: 43,128
Not that I know of- I think you'd have to send it in. What the battery low when you initiated the update?

Adam
PentaxForums.com Webmaster (Site Usage Guide | Site Help | My Photography)



PentaxForums.com's high server and development costs are user-supported. You can help cover those costs by donating. Or, buy your photo gear from our affiliates, Adorama, B&H Photo, or Topaz Labs, and get FREE Marketplace access - click here to see how! Trusted Pentax retailers:

04-16-2015, 09:35 PM   #3
Veteran Member




Join Date: Nov 2013
Posts: 385
Original Poster
QuoteOriginally posted by Adam Quote
Not that I know of- I think you'd have to send it in. What the battery low when you initiated the update?
No, the battery indicator showed all bars.
04-16-2015, 09:45 PM   #4
Site Supporter
Sandy Hancock's Avatar

Join Date: Feb 2012
Location: Adelaide Hills, South Australia
Photos: Gallery | Albums
Posts: 5,719
OEM battery?

04-16-2015, 10:35 PM   #5
Site Supporter
davidreilly3207's Avatar

Join Date: Sep 2009
Location: South Jersey
Photos: Gallery | Albums
Posts: 587
I'd say firmware update did not take place and I would charge original battery overnight and try it. Second battery may be bad. Battery level indicators can read good with bad batteries as the measuring circuit places no load on the battery.
04-16-2015, 10:37 PM   #6
Loyal Site Supporter
ivanvernon's Avatar

Join Date: Oct 2012
Location: Medina, OH
Photos: Albums
Posts: 2,092
Bricked

Exact same thing happened to me with my K-5ii. The repair quotation by C.R.I.S. was $175, but Pentax agreed to cover the labor but not the part,, reducing cost from $175 to $80. Then C.R.I.S. shipped the failed camera to the new warranty shop, which finally fixed the camera and returned it to me for no charge. This whole process took about four months. I will never update firmware again unless it is done by repair facility as part of CLA or other service where I am not personally exposed to the risk of damage.
04-16-2015, 11:04 PM   #7
Veteran Member
crewl1's Avatar

Join Date: Jul 2010
Location: Los Angeles, CA
Photos: Gallery | Albums
Posts: 9,797
Is the card door closed when you are trying to restart it?

QuoteOriginally posted by maxxxx Quote
- Top LCD shows battery level for moment then goes blank
04-16-2015, 11:15 PM   #8
Senior Member




Join Date: Jul 2010
Posts: 271
I'd restart your camera again and again couple of times or/and upgrade again, if not I'd try to switch-on into service-menu (some play with SD-cards door open, pls check other threads).
You may play with card-slots (Slot 1, Slot 2, other slot empty ) in a FW upgrade.
Think about external power unit (genuine Pentax? OEM/third party?) to power-supply your camera, which is cheaper than shipping your camera to the service center.

-----
QuoteOriginally posted by maxxxx Quote
- Checked battery. Showed all bars.
- Put firmware on SD card.
- Turned on camera with menu button pressed
- Got a message similar "Battery level low. Can't update date firmware".
- Replaced battery
- Turned camera on
- Top LCD shows battery level for moment then goes blank


04-16-2015, 11:46 PM - 1 Like   #9
Pentaxian




Join Date: Feb 2015
Photos: Albums
Posts: 3,527
The problem is that the battery indicator is not accurate at all. For example, if a battery is full discharged and you charge it for 30 minutes, and insert it again in the camera, battery indicator indicates "battery full". It may not be enough to see the battery indicator. It is safer to charge the battery until the green led switches off.
04-17-2015, 01:44 AM   #10
Site Supporter
Sandy Hancock's Avatar

Join Date: Feb 2012
Location: Adelaide Hills, South Australia
Photos: Gallery | Albums
Posts: 5,719
QuoteOriginally posted by biz-engineer Quote
The problem is that the battery indicator is not accurate at all. For example, if a battery is full discharged and you charge it for 30 minutes, and insert it again in the camera, battery indicator indicates "battery full". It may not be enough to see the battery indicator. It is safer to charge the battery until the green led switches off.
+1 to that. I don't rely on the camera's battery charge icon; I remove the battery and charge it until the charger says it is full before doing a firmware update.

Whether it would have avoided this event is, however, moot.
04-17-2015, 03:53 AM   #11
Banned




Join Date: Feb 2013
Posts: 390
Seems to me since the update never started, the problem lies in either the batteries or the camera circuitry itself. Try another battery / power source, if still no response, you may have a warranty claim.
04-17-2015, 05:14 AM   #12
Veteran Member
sterretje's Avatar

Join Date: Dec 2008
Location: Roodepoort, South Africa
Photos: Gallery | Albums
Posts: 3,534
QuoteOriginally posted by mdave13 Quote
I'd say firmware update did not take place
QuoteOriginally posted by Al_Kahollick Quote
Seems to me since the update never started
Agree with those.
04-17-2015, 06:23 AM   #13
New Member




Join Date: Mar 2015
Posts: 21
thanks for info.
04-17-2015, 06:25 AM   #14
Senior Member
screwdriver222's Avatar

Join Date: Oct 2011
Location: Plymouth
Photos: Gallery | Albums
Posts: 134
I think you have to put the card in a specific card. As been said before the update hasn't occurred
04-17-2015, 06:28 AM   #15
Veteran Member




Join Date: Nov 2013
Posts: 385
Original Poster
Good news! I took the battery out of the camera and into the charger overnight. This morning I put the SD card with the 1.20 update into the camera and when I turned the camera on it offered to update the firmware. After a minute of "Now Loading" (and me being very nervous) the update completed and the camera works again.

Not sure what did the trick. Was it charging the battery (although I had tried that last night) or taking the battery out of the camera for 10 hours? In any case, I am a happy camper again.

---------- Post added 04-17-15 at 06:30 AM ----------

QuoteOriginally posted by Sandy Hancock Quote
OEM battery?
No. The original Pentax one. I had heard about problems with OEM batteries before.

---------- Post added 04-17-15 at 06:54 AM ----------

QuoteOriginally posted by Sandy Hancock Quote
+1 to that. I don't rely on the camera's battery charge icon; I remove the battery and charge it until the charger says it is full before doing a firmware update.

Whether it would have avoided this event is, however, moot.
In the future I'll definitely charge for 12 hours to make sure it's full.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
batteries, battery, camera, charge, charger, correction, dslr, equipment, firmware, firmware update, hours, level, manufacturer, oem, pentax, photography, post, thanks, third-party, update
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
K-3 Firmware Update JG49 Pentax K-3 6 11-15-2014 03:12 PM
K-3 Firmware Update 1.10 Released sab Pentax News and Rumors 49 09-11-2014 07:31 PM
K-3 firmware update coming next month DSims Pentax News and Rumors 7 06-25-2014 08:06 AM
Pentax K-5 II Problem after Firmware Update Deedee Pentax K-5 13 08-12-2013 04:58 PM
K-x bricked after 1.01 update raver1414 Pentax DSLR Discussion 23 12-09-2009 11:37 AM



All times are GMT -7. The time now is 12:47 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top