Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
06-08-2008, 04:40 PM   #1
New Member




Join Date: Apr 2008
Location: Boston
Posts: 8
Pentax *istD not recording aperture and not taking photos.

Well, I got that memory card problem solved (a CF card wasn't necessary but the camera doesn't work with any capacity larger than 1 Gig as Photo Tramp had suggested).

Now the new problem is the camera doesn't detect the lens aperture. (I'm assuming that's what F-- in the viewfinder means). I'm also guessing that the camera isn't detecting the lens at all. Needless to say the camera doesn't even take photos. (I tried 2 other lenses and got the same results.)

Any idea what is causing the new problem ?
Thanks.

06-08-2008, 09:06 PM   #2
Veteran Member
jeffkrol's Avatar

Join Date: Sep 2006
Location: Wisconsin USA
Photos: Gallery
Posts: 8,435
QuoteOriginally posted by wolf Quote
Well, I got that memory card problem solved (a CF card wasn't necessary but the camera doesn't work with any capacity larger than 1 Gig as Photo Tramp had suggested).

Now the new problem is the camera doesn't detect the lens aperture. (I'm assuming that's what F-- in the viewfinder means). I'm also guessing that the camera isn't detecting the lens at all. Needless to say the camera doesn't even take photos. (I tried 2 other lenses and got the same results.)

Any idea what is causing the new problem ?
Thanks.
download the manual.
Custom function... f stop other than A... on
What lenses?
06-09-2008, 03:28 AM   #3
Site Supporter
Pentaxke's Avatar

Join Date: Oct 2006
Location: Belgium
Photos: Gallery | Albums
Posts: 409
Press [Menu](left top button next to LCD screen)
[Custom Function]
Scroll down until you get 'f-stop other than A'
That should be set to 'On'

That's all. Pretty sure, the thing will work now.

Also, you are not saying what lens you are using, but if the lens has an A setting, better set it to A, then you can use all modes, without any hassle...

Also: download the latest firmware for the ist D here... The latest firmware is 1.12, although with 1.10 and 1.11 you are also in the safe zone... This latest firmware will make able to use CF cards that are more than 1 GB. I use 2 and 4 GB without any problem...

Have fun with the ist D. It's one of the best camera's made... Ever!
06-09-2008, 03:53 AM   #4
Veteran Member
ftpaddict's Avatar

Join Date: Jan 2008
Location: Yurp
Photos: Gallery
Posts: 4,669
You didn't specify what kind of lens you use.

06-09-2008, 05:05 AM   #5
Pentaxian
Lowell Goudge's Avatar

Join Date: Jan 2007
Location: Toronto
Photos: Gallery | Albums
Posts: 15,400
QuoteOriginally posted by wolf Quote
Well, I got that memory card problem solved (a CF card wasn't necessary but the camera doesn't work with any capacity larger than 1 Gig as Photo Tramp had suggested).
this is incorrect. I use a 4GB all the time in my *istD. the last software update made this possible. check the pentax web site for the last update and functionality
QuoteQuote:
Now the new problem is the camera doesn't detect the lens aperture. (I'm assuming that's what F-- in the viewfinder means). I'm also guessing that the camera isn't detecting the lens at all. Needless to say the camera doesn't even take photos. (I tried 2 other lenses and got the same results.)

Any idea what is causing the new problem ?
Thanks.
what lenses are you using? and are they in A mode.

Also you need to (for non A lenses) set the function for use apature ring
06-09-2008, 11:20 PM   #6
New Member




Join Date: Apr 2008
Location: Boston
Posts: 8
Original Poster
Yes, I'd say the "problem" was not having it on the "A" setting. Thanks to all of you for the information. To answer all of your questions, I am using a 50mm Macro lens. I also tried 2 other lenses (20 mm wide angle and 70-300 mm zoom and those didn't work either).
Thanks again.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
aperture, camera, card, dslr, lens, pentax *istd, photography
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Landscape Taking photos while driving pdxbmw Post Your Photos! 7 03-19-2011 11:56 PM
Taking photos for money fractal Photographic Technique 8 06-09-2010 11:10 PM
K200D Stopped Taking Photos itrs Troubleshooting and Beginner Help 4 10-18-2009 04:23 AM
keep taking photos on an angle :( Keebler Photographic Technique 21 04-15-2009 06:58 AM
Pentax *istD not detecting aperture setting and not taking photos. wolf Pentax DSLR Discussion 2 06-08-2008 07:12 PM



All times are GMT -7. The time now is 06:35 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top