Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
08-05-2015, 10:54 PM   #1
New Member




Join Date: Nov 2014
Posts: 7
Help on Pentax K-3 AE-L button please.

When metering is not active (ie. No light displays in viewfinder), pressing (incl. press & hold) AE-L button does NOTHING. So, to perform AE-lock, I have to press shutter lightly first to turn metering on.

When metering is on, AE-L button works OK.

But on K-50, pressing AF/AE-L button (configured for AE lock) turns on metering + lock AE , even when metering is NOT active.

Is this normal? Thank you in advance for any response.

08-05-2015, 10:56 PM   #2
Administrator
Site Webmaster
Adam's Avatar

Join Date: Sep 2006
Location: Arizona
Photos: Gallery | Albums
Posts: 43,739
There's a menu setting to extend the meter operating time...perhaps you have that enabled on your K-50?

Adam
PentaxForums.com Webmaster (Site Usage Guide | Site Help | My Photography)



PentaxForums.com server and development costs are user-supported. You can help cover these costs by donating. Or, buy your photo gear from our affiliates, Adorama, B&H Photo, or Topaz Labs, and get FREE Marketplace access - click here to see how! Trusted Pentax retailers:

08-05-2015, 11:10 PM   #3
New Member




Join Date: Nov 2014
Posts: 7
Original Poster
No, the metering time (10s: default) are same in both K3 AND K50.

Issue is that metering is NOT active: viewfinder is blank, nothing displayed. Pressing K50 AE-L will turn on metering in viewfinder AND lock exposure. But K3 AE-L button does nothing!

Thanks for comments...

---------- Post added 08-06-15 at 01:13 PM ----------

...I mean WHEN metering in viewfinder is not active... ie. turn camera on and let it sit for 30sec+...
08-06-2015, 12:38 AM   #4
Pentaxian
redcat's Avatar

Join Date: Jul 2014
Location: Paris
Photos: Gallery
Posts: 1,828
I think the K3 is in sleep mode (viewfinder is blank), sometimes I have to half press the shutter button to wake the camera up and then everything works

08-06-2015, 01:41 AM   #5
Pentaxian
Fogel70's Avatar

Join Date: Sep 2009
Location: Stockholm, Sweden
Photos: Albums
Posts: 1,748
QuoteOriginally posted by Poompat Quote
When metering is not active (ie. No light displays in viewfinder), pressing (incl. press & hold) AE-L button does NOTHING. So, to perform AE-lock, I have to press shutter lightly first to turn metering on.

When metering is on, AE-L button works OK.

But on K-50, pressing AF/AE-L button (configured for AE lock) turns on metering + lock AE , even when metering is NOT active.

Is this normal? Thank you in advance for any response.
Yes I believe this is normal, on K-3 and older advanced models you need a exposure reading to be able to lock exposure.
Manual mode with green button auto exposure is often more useful than AE-L in auto exposure modes IMO.

Pentax AE-L is a bit limited as it resets after each shot, and after AE meter times out.

I would have been nice with more options on both AE-L, and AE meter.
FI an option of AE meter never timing out, and that AE-L never unlocks unless you press AE-L button again.
08-06-2015, 05:55 AM   #6
New Member




Join Date: Nov 2014
Posts: 7
Original Poster
Thank you very much... Surprisingly, the K3 manual is less detailed than K50 manual...
08-06-2015, 06:42 AM   #7
Veteran Member
lavascript's Avatar

Join Date: Jul 2009
Location: Baton Rouge
Posts: 390
I don't use AE-L, but another minor annoyance of mine is the same behavior with the AF button. I've set my AF button(s) to Mode 2, effectively disabling half-press AF... but the AF buttons don't wake the camera from sleep. I'm so used to leaving my camera on while I'm out, then popping it up to my face, half-press, then full press. I can't follow the same procedure with the AF button.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
ae, ae-l, button, camera, dslr, k-3 ae-l button, k3, k50, pentax k-3 ae-l, photography, press, viewfinder
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Back button AE-L and AF Zerv Pentax K-30 & K-50 24 03-31-2016 02:12 AM
Move AE-L function to another button? Samoht Pentax K-3 3 05-30-2015 03:14 AM
Green button and AE-L button voyager13 Troubleshooting and Beginner Help 7 06-28-2012 12:26 PM
Pentax K-x Broken AF/AE-L Button 0rangepeel Pentax DSLR Discussion 5 10-17-2010 02:56 AM
K-x AF/AE-L button operation in Manual focus mode Karellen Pentax DSLR Discussion 8 02-22-2010 08:39 AM



All times are GMT -7. The time now is 07:21 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top