Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
06-16-2008, 11:57 PM   #1
Senior Member
jms698's Avatar

Join Date: Jul 2007
Location: Wellington, New Zealand
Posts: 133
Don't update to the 1.01 firmware! It breaks autofocus

I just updated my Pentax K20d to the 1.01 firmware. However, now my 16-50mm f/2.8 lens no longer focuses. It makes a loud noise whirring noise and hunts to either end of the focus range. It sounds like it is trying to even force the lens to focus past the extremes of the focus range with the motor grinding when it reaches the end of the focus range. After hunting like this for a few seconds it gives up, failing to focus properly. This occurs in all lighting conditions. Previous to installing the new firmware there was no problem and the lens focused perfectly.

I wonder if there is a way to downgrade back to the 1.0 firmware?

In any case, I would suggest everyone hold off upgrading to the new firmware. It obviously hasn't been tested properly.

06-17-2008, 12:17 AM   #2
Site Supporter




Join Date: Mar 2007
Location: Honolulu, Hawaii
Photos: Gallery
Posts: 92
I just checked my K20D and DA 16-50 after your post and it's operating properly. Camera was upgraded to ver. 1.01 earlier today.

No idea why your lens is acting like that. I hope you get it resolved .

Terry
06-17-2008, 03:21 AM   #3
Site Supporter




Join Date: Mar 2008
Location: Glendale, CA
Photos: Gallery | Albums
Posts: 61
QuoteOriginally posted by jms698 Quote
I just updated my Pentax K20d to the 1.01 firmware. However, now my 16-50mm f/2.8 lens no longer focuses. It makes a loud noise whirring noise and hunts to either end of the focus range. It sounds like it is trying to even force the lens to focus past the extremes of the focus range with the motor grinding when it reaches the end of the focus range. After hunting like this for a few seconds it gives up, failing to focus properly. This occurs in all lighting conditions. Previous to installing the new firmware there was no problem and the lens focused perfectly.

I wonder if there is a way to downgrade back to the 1.0 firmware?

In any case, I would suggest everyone hold off upgrading to the new firmware. It obviously hasn't been tested properly.
I just my K20D and DA*16-50 also after seeing this post. AF worked fine. I upgraded early yesterday morning.
06-17-2008, 03:59 AM   #4
Veteran Member




Join Date: Nov 2006
Location: Hong Kong
Posts: 1,934
Have you contacted Pentax UK to see if they can help? n/t

There is no text, why force me to enter some characters?

QuoteOriginally posted by jms698 Quote
I just updated my Pentax K20d to the 1.01 firmware. However, now my 16-50mm f/2.8 lens no longer focuses. It makes a loud noise whirring noise and hunts to either end of the focus range. It sounds like it is trying to even force the lens to focus past the extremes of the focus range with the motor grinding when it reaches the end of the focus range. After hunting like this for a few seconds it gives up, failing to focus properly. This occurs in all lighting conditions. Previous to installing the new firmware there was no problem and the lens focused perfectly.

I wonder if there is a way to downgrade back to the 1.0 firmware?

In any case, I would suggest everyone hold off upgrading to the new firmware. It obviously hasn't been tested properly.


06-17-2008, 04:36 AM   #5
Veteran Member
benjikan's Avatar

Join Date: Jan 2007
Location: Paris, France
Photos: Gallery
Posts: 4,309
QuoteOriginally posted by jms698 Quote
I just updated my Pentax K20d to the 1.01 firmware. However, now my 16-50mm f/2.8 lens no longer focuses. It makes a loud noise whirring noise and hunts to either end of the focus range. It sounds like it is trying to even force the lens to focus past the extremes of the focus range with the motor grinding when it reaches the end of the focus range. After hunting like this for a few seconds it gives up, failing to focus properly. This occurs in all lighting conditions. Previous to installing the new firmware there was no problem and the lens focused perfectly.

I wonder if there is a way to downgrade back to the 1.0 firmware?

In any case, I would suggest everyone hold off upgrading to the new firmware. It obviously hasn't been tested properly.
Just tested firmware V 1.01 on my three K20D bodies. The 16-50 works as it should. Perfectly.

Ben
06-17-2008, 04:42 AM   #6
Veteran Member




Join Date: Nov 2006
Location: Hong Kong
Posts: 1,934
QuoteOriginally posted by benjikan Quote
Just tested firmware V 1.01 on my three K20D bodies. The 16-50 works as it should. Perfectly.

Ben
How many 16-50 lenses have you tested then? If it is also 3, then there are 9 combinations!

p.s. Just admire you so much for having so many K20D bodies and that must be Great!
06-17-2008, 04:49 AM   #7
Veteran Member
benjikan's Avatar

Join Date: Jan 2007
Location: Paris, France
Photos: Gallery
Posts: 4,309
QuoteOriginally posted by RiceHigh Quote
How many 16-50 lenses have you tested then? If it is also 3, then there are 9 combinations!

p.s. Just admire you so much for having so many K20D bodies and that must be Great!
It is OK...Having six bodies takes up quite a bit of room though. That is 3 K10D's and 3 K20D's. I think I might get seven more to make it a "Bakers Dozen"
06-17-2008, 04:57 AM   #8
Veteran Member




Join Date: Feb 2007
Location: Ontario
Posts: 433
I don't have the 16-50 so can't comment but my lenses work fine. Have you tried cleaning the mount contacts on the lens and the body and then reseating the lens? 1.01 does appear to "break" Bibble. Dave


QuoteOriginally posted by jms698 Quote
I just updated my Pentax K20d to the 1.01 firmware. However, now my 16-50mm f/2.8 lens no longer focuses. It makes a loud noise whirring noise and hunts to either end of the focus range. It sounds like it is trying to even force the lens to focus past the extremes of the focus range with the motor grinding when it reaches the end of the focus range. After hunting like this for a few seconds it gives up, failing to focus properly. This occurs in all lighting conditions. Previous to installing the new firmware there was no problem and the lens focused perfectly.

I wonder if there is a way to downgrade back to the 1.0 firmware?

In any case, I would suggest everyone hold off upgrading to the new firmware. It obviously hasn't been tested properly.


06-17-2008, 06:01 AM   #9
Pentaxian
Lowell Goudge's Avatar

Join Date: Jan 2007
Location: Toronto
Photos: Gallery | Albums
Posts: 15,312
QuoteOriginally posted by jms698 Quote
I just updated my Pentax K20d to the 1.01 firmware. However, now my 16-50mm f/2.8 lens no longer focuses. It makes a loud noise whirring noise and hunts to either end of the focus range. It sounds like it is trying to even force the lens to focus past the extremes of the focus range with the motor grinding when it reaches the end of the focus range. After hunting like this for a few seconds it gives up, failing to focus properly. This occurs in all lighting conditions. Previous to installing the new firmware there was no problem and the lens focused perfectly.

I wonder if there is a way to downgrade back to the 1.0 firmware?

In any case, I would suggest everyone hold off upgrading to the new firmware. It obviously hasn't been tested properly.
is it possible that you have a bad contact between camera and lens? If it is hunting like this it suggests that the data for focusing distance is not being fed back to the body as it should.

check and clean the furthest contact away from the lens locking pin, use a pink or gum erasor, not abrasive.
06-17-2008, 06:12 AM   #10
Veteran Member




Join Date: Nov 2006
Location: Hong Kong
Posts: 1,934
QuoteOriginally posted by Lowell Goudge Quote
is it possible that you have a bad contact between camera and lens? If it is hunting like this it suggests that the data for focusing distance is not being fed back to the body as it should.

check and clean the furthest contact away from the lens locking pin, use a pink or gum erasor, not abrasive.
Maybe, but unlikely, I guess. It might be that the new firmware is not fully compatible with some different versions of the hardware including the body and/or lens.

My advice is if problem persists, just contact the Pentax UK's for servicing or technical support. I think his lens and body are both under warranty.

Sometimes those firmware upgrades could create new problems, so if it is not really needed, don't do the upgrades.
06-17-2008, 07:15 AM   #11
Pentaxian




Join Date: Sep 2006
Location: Kaunas
Posts: 1,452
You're making rush conclusions

QuoteOriginally posted by jms698 Quote
I just updated my Pentax K20d to the 1.01 firmware. However, now my 16-50mm f/2.8 lens no longer focuses. It makes a loud noise whirring noise and hunts to either end of the focus range. It sounds like it is trying to even force the lens to focus past the extremes of the focus range with the motor grinding when it reaches the end of the focus range. After hunting like this for a few seconds it gives up, failing to focus properly. This occurs in all lighting conditions. Previous to installing the new firmware there was no problem and the lens focused perfectly.

I wonder if there is a way to downgrade back to the 1.0 firmware?

In any case, I would suggest everyone hold off upgrading to the new firmware. It obviously hasn't been tested properly.
Have you tried to put your lens on another Pentax body with SDM support? Did it work?

Have you tried to put another Pentax SDM lens on your K20D? Did it work?

I am 99% convinced that this is just coincidence.
06-17-2008, 07:38 AM   #12
Site Supporter
ChipB's Avatar

Join Date: Nov 2007
Location: Austin, TX area
Photos: Gallery | Albums
Posts: 1,511
There's a chance the firmware got corrupted while doing the upgrade - I'd suggest re-doing it.
06-17-2008, 08:05 AM   #13
Veteran Member
vievetrick's Avatar

Join Date: Sep 2006
Location: Easthampton - Massachusetts - USA
Photos: Gallery
Posts: 5,175
QuoteOriginally posted by RiceHigh Quote
Maybe, but unlikely, I guess. It might be that the new firmware is not fully compatible with some different versions of the hardware including the body and/or lens.

My advice is if problem persists, just contact the Pentax UK's for servicing or technical support. I think his lens and body are both under warranty.

Sometimes those firmware upgrades could create new problems, so if it is not really needed, don't do the upgrades.
I am going to say this as nice as possible,

Come on Rice the chances are way more likely that it is the contact and not the firmware.
06-17-2008, 08:23 AM   #14
Veteran Member
jeffkrol's Avatar

Join Date: Sep 2006
Location: Wisconsin USA
Photos: Gallery
Posts: 8,434
QuoteOriginally posted by vievetrick Quote
I am going to say this as nice as possible,

Come on Rice the chances are way more likely that it is the contact and not the firmware.
sad thing he does... no matter how many facts there are. Problems not so much him but the fact that a true problem can get ignored because of the normal reaction to just blow off his babble (yes I'm guilty).
And no matter the cause it's always Pentax's fault.
I updated the firmware on two bodies last night, and just tried my lenses.
They all seem to work fine. My 16-50 2.8 is focusing without any issues.
elliot
06-17-2008, 08:46 AM   #15
Senior Member




Join Date: Aug 2007
Location: Perth, Australia
Posts: 268
Just spring out of my room to test my 16-50 and 50-135.... all is good...
Was kinda worried when I read the post.

Anyway, hope you have a chance to check the contacts and let us know your progress.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, dslr, firmware, focus, lens, noise, photography, properly, range
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
KX firmware update kparkypark Troubleshooting and Beginner Help 10 04-28-2010 08:38 AM
Aperture RAW update Breaks Pentax K-7 DNG support as4ronin Digital Processing, Software, and Printing 7 03-06-2010 03:06 AM
Help with k-x firmware update kiwislice Pentax DSLR Discussion 7 02-25-2010 12:57 PM
Sigma 50mm f1.4 autofocus breaks after few days? jmc Pentax SLR Lens Discussion 18 08-18-2009 11:21 AM
Firmware update vievetrick Pentax News and Rumors 0 09-07-2006 12:20 PM



All times are GMT -7. The time now is 01:48 AM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top