Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
10-30-2015, 06:04 PM   #1
New Member




Join Date: Jun 2012
Posts: 4
Autofocus difficulties - K-x

Dear all,

I would be grateful for some advice re getting my auto focus to work -


I have a Pentax K-x. Both camera body and lens (various) have been set to AF. I am able to focus if I change camera body and lens to MF, but the auto focus does not work - ie the lens will not rotate to focus. The camera beeps when the button is pressed halfway - but only when I manually focus, not when I am trying to autofocus

Despite this, the initial screen display (which lists ISO, F stop level, exposure etc) comes up as 'MF' in the top right corner of the screen (adjacent to the AE metering and battery level icons).

On the camera menu (2), I have set AF mode to AF-C; however 'AF Mode' is coloured in grey, not white like the other options such as multi exposure, HDR capture etc - not sure whether this is relevant?

On the control panel (1) 'AE-L with AF locked' is set on 'Off' and 'Link AE to AF Point' is set as 'Off'; On the control panel (2) 'AF/AE-L Button' is set on 'Enable AF1'. Again, not sure whether any of these options are important?

Would resetting to factory settings help? Again not very clear in the K-x manual how this is done.

Appreciative of any suggestions offered.

Andrew Martin
NZ

10-30-2015, 06:58 PM   #2
Administrator
Site Webmaster
Adam's Avatar

Join Date: Sep 2006
Location: Arizona
Photos: Gallery | Albums
Posts: 43,691
It sounds like your camera is not recognizing your lens as an AF lens. Try re-mounting the lens and cleaning the electrical contacts. Hopefully that will allow the combo to go back in to AF mode

Adam
PentaxForums.com Webmaster (Site Usage Guide | Site Help | My Photography)



PentaxForums.com's high server and development costs are user-supported. You can help cover those costs by donating. Or, buy your photo gear from our affiliates, Adorama, B&H Photo, or Topaz Labs, and get FREE Marketplace access - click here to see how! Trusted Pentax retailers:

10-30-2015, 07:12 PM   #3
New Member




Join Date: Jun 2012
Posts: 4
Original Poster
Hi Adam,

I disconnected the lens. The AF gear was seen to project above the mount when switching between MF and AF. Strangely enough the autofocus started working again - and now the screen says 'AF-C' not 'MF'. Not sure my technique of blowing would be recommended. I read a post recommending use of isopropyl alcohol? Would you think this is a good idea?

Andrew
10-30-2015, 08:13 PM   #4
Site Supporter
Site Supporter
jatrax's Avatar

Join Date: May 2010
Location: Oregon
Photos: Gallery | Albums
Posts: 10,828
QuoteOriginally posted by andrewmartin Quote
I read a post recommending use of isopropyl alcohol? Would you think this is a good idea?
Only in extreme cases. Best to just use a clean microfiber cloth and buff the contacts on both the lens and the camera. It sounds as if the camera does not recognize the lens which is an indication that the contacts are either dirty, or misaligned. If it is a Pentax lens misalignment should not be an issue however some third party lenses have enough slop in the mount to allow the contacts to be off just enough.

Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
af, camera, control, dslr, focus, k-x, lens, mode, options, panel, photography
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
K-X autofocus not working cyprus Troubleshooting and Beginner Help 17 02-28-2015 12:36 PM
Pentax K-X and DA 35mm F2.4 Autofocus Problem AJ_Pentax Troubleshooting and Beginner Help 3 04-26-2014 01:34 AM
K-5ii video difficulties gbeaton Pentax DSLR Discussion 3 09-15-2013 04:26 PM
K100d autofocus vs K-x K-r EscoF350 Pentax DSLR Discussion 7 10-10-2012 10:59 PM
Does this lens autofocus on K-7 and K-x pakuchn Troubleshooting and Beginner Help 20 12-20-2009 04:22 PM



All times are GMT -7. The time now is 11:34 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top