Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
12-23-2015, 12:56 PM   #1
New Member
art_oliver's Avatar

Join Date: Mar 2014
Location: Lisboa - Portugal
Photos: Gallery
Posts: 20
Pentax K-m LCD problem

Hello,

Two days ago my km lcd stops working. Any time I power on the camera the lcd remains black, and if a lens is mounted on the camera and
The body was in autofocus mode the camera start focus automatically without any action from me, a bit like if I'm pressing the shutter button
halfway. I can change and choose diferent program modes and the viewfinder show the modifications made on theshutter speed or aperture correctly.

When power on the camera if press menu button lcd works and show me the current firmware version. Also I already downgrade and upgrade the firmware several times, playing with versions 1.10 and 1.11.

Here in the forum and in other web sources I can find very similar problems like mine not only with km but also with the sister machine kx, but in anyone are a conclusive end saying the cause for the problem and if it worth a repair.

I also try connect the machine to a tv set to try if I can reach the menu, but no luck ... The onlyboutput is the one related to the firmware ...

The machine have only 15000 shots and are in very good condition and I' in trouble to accept that is it end ...

Any ideas ?

Thanks a lot in advance.

Merry Xmas


Last edited by art_oliver; 12-23-2015 at 01:03 PM.
07-05-2017, 01:40 AM   #2
New Member
art_oliver's Avatar

Join Date: Mar 2014
Location: Lisboa - Portugal
Photos: Gallery
Posts: 20
Original Poster
Hello,

It seems I ressurect my K-m to life.

I found this blog :

RiceHigh's Pentax Blog: K-m Debug Mode Unleashed! (For AF Correction)

I put the machine in debug mode and and I'm able to reach the menu and make a full reset to default settings.

In my case and after the initial problem with the lcd also the autofocus seems to be in a permanent lock...

So after the full reset I make some adjustments in the Menu that I believe that are better for machine operation:

1 - "AF Button Function" is now "Enable AF2" - This end with the permanent autofocus issue.

2 - "Display status" is now "Off" - It seems the auto switch from photo review mode to shooting mode or when leaving "Menu" or "Fn Button Menu", or when shoot the review mode have some relation with the LCD starts to do not display things properly. With this setting I minimize the auto display function.

3 - Even so from time to time the LCD stops working. I found power off and power on a second time or with "Menu" button pressed (giving firmware version) bring me back the LCD to normal operation.

4 - Another more drastic possibility is to keep "Debug Mode" active all the time but the LCD never shutdown and the battery life will be shorter.

So the problem stills there but I can surpass it and continuing shooting with my beloved K-m.

PS => I also check autofocus accurency but the default setting is working good.

Cheers
07-05-2017, 02:54 AM   #3
Moderator
Site Supporter
MarkJerling's Avatar

Join Date: May 2012
Location: Wairarapa, New Zealand
Photos: Gallery | Albums
Posts: 6,552
Good to hear you got it sorted!
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
button, camera, dslr, firmware, km, lcd, machine, pentax k-m lcd, photography, power
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
K-m lcd problem fix Troubleshooting and Beginner Help 12 07-05-2017 03:01 AM
Problem with K-3 LCD display nukeglus Troubleshooting and Beginner Help 13 11-06-2014 04:09 PM
K-r LCD Problem Ray Hines Troubleshooting and Beginner Help 2 01-09-2013 12:13 PM
Pentax K-5 LCD problem? GrzegorzR Troubleshooting and Beginner Help 7 11-14-2012 03:44 AM
K-R LCD problem fastfrag1981 Troubleshooting and Beginner Help 5 01-07-2012 06:42 PM



All times are GMT -7. The time now is 03:55 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top