Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
01-14-2016, 05:01 AM   #1
New Member




Join Date: Nov 2013
Posts: 8
Pentax K10D Focusing Problems caused be firmware upgrade to 1.31

Hi All,

I recently picked up a Pentax K10D with a very low shutter count < 1000. It had the original 1.0 firmware and everything seemed to work fine.

It came with 18-55 and 55-200 DA lenses and everything seemed great until I updated the firmware to 1.31.

The camera focus goes back and forth several times before it settles on a focus spot, or in some cases not.

I found the articles about how to down grade the firmware to 1.10, but I am still having problems.

Any recommendations on how to proceed? Debug mode? Other suggestions?

Is it possible that the firmware upgrade wiped out some focus adjustments that the previous owner had set?

Thanks,

Chris

01-14-2016, 10:09 PM   #2
Pentaxian




Join Date: Jan 2010
Location: Vancouver, BC
Posts: 1,421
Nope, never heard of such thing happening before. My K10D has had the latest firmware (v. 1.31) for a long time and it focuses fine most of the time (mine has been converted to IR and AF is somewhat quirky at times - I almost never shoot with AF lens with this camera anyway). The K10D doesn't have a user adjustable focus setting and no Liveview. I am afraid you are going to have to search elsewhere for your AF problems.
01-14-2016, 10:58 PM   #3
Senior Member




Join Date: Oct 2015
Posts: 100
I have/had the same problem. I believe that the firmware causes you to use the DA type lens. If you were to use a Pentax lens there shouldn't be any problem, but some older K lenses from other brands do not seem to work as well as they use to. Some outside brands from use on a film K mount will be difficult on a DSLR, except Pentax lens. That's my findings.
01-15-2016, 01:40 AM   #4
Pentaxian




Join Date: Jan 2010
Location: Vancouver, BC
Posts: 1,421
The OP is having problems with the kit lenses DA 18-55 and 55-200. The only AF I've used with my K10D IR was Tamron 17-50/2.8, and I've tried just now with a Sigma 18-125 and no problem there either. I'll see if my few film era AF lenses can duplicate your findings sometime during the day.

01-15-2016, 12:30 PM   #5
Senior Member




Join Date: Oct 2015
Posts: 100
If there was a way to 'flash' the firmware, I would go backwards and use a prior firmware, or original. I've spoken to Pentax and this couldn't be done supposedly, but if there is some geek that could do it, it would be welcome.
01-16-2016, 10:40 AM   #6
osv
Pentaxian




Join Date: Mar 2007
Location: So Cal
Photos: Gallery
Posts: 2,080
QuoteOriginally posted by merzcm Quote
It came with 18-55 and 55-200 DA lenses and everything seemed great until I updated the firmware to 1.31.

The camera focus goes back and forth several times before it settles on a focus spot, or in some cases not.
debug mode with an older firmware will let you trim the af points(microadjust), but i don't think that will address the back and forth af behavior.

i don't know how the 1.31 firmware works, i updated to a hacked version of the firmware on my k10d, but the camera never really had accurate af performance with either version.

QuoteOriginally posted by merzcm Quote
I found the articles about how to down grade the firmware to 1.10, but I am still having problems.
so did you actually do the downgrade?
01-16-2016, 06:59 PM   #7
New Member




Join Date: Nov 2013
Posts: 8
Original Poster
QuoteOriginally posted by osv Quote
debug mode with an older firmware will let you trim the af points(microadjust), but i don't think that will address the back and forth af behavior.

i don't know how the 1.31 firmware works, i updated to a hacked version of the firmware on my k10d, but the camera never really had accurate af performance with either version.



so did you actually do the downgrade?
Yes I was able to downgrade the firmware to 1.10, but it didn't solve the back and forth AF issue.

Maybe the camera had the issue before the firmware flash and I just didn't use it enough to notice. I only took about 10 pictures before I flashed the firmware.

Right now it is on the 1.20 firmware version and I am going to try the backfocus adjustment in the following article:

Photography Rulez: K10D Focus Error Adjustment
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, dslr, firmware, focus, k10d, pentax, pentax k10d, photography
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
K10d : downgrade from 1.31 to 1.10 ? clover Pentax DSLR Discussion 14 03-17-2013 10:24 PM
Question Regarding K10D software version 1.31 Meter Problems crashmars Troubleshooting and Beginner Help 2 11-27-2011 03:10 PM
K7 Firmware Upgrade to ver 1.1 Problem David Lee Visitors' Center 2 10-19-2011 09:21 PM
Shutter lag and firmware update? (K10D & 1.31) frattofoto Pentax DSLR Discussion 3 05-02-2010 01:46 PM
Any K20D Aperture users upgrade to firmware 1.03? yetidesign Pentax DSLR Discussion 6 04-17-2009 06:01 PM



All times are GMT -7. The time now is 01:54 PM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top