Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
01-29-2016, 03:53 PM   #1
Site Supporter
Dewman's Avatar

Join Date: May 2012
Location: Idaho
Photos: Albums
Posts: 3,237
K-7 memory card question

I just received a K-7 in the mail. After charging the battery, giving the camera a good cleaning and blowing off the mirror, I inserted the fresh battery and a Sandisk SDHC 8 GB card. Camera lights up, auto focus works, shutter clicks, but.... BUT, a memorandum appears on the LED screen.... "No card in the camera." I tried two other cards.... same brand, same markings.... and same results.


Any clues?

01-29-2016, 04:31 PM   #2
Administrator
Site Webmaster
Adam's Avatar

Join Date: Sep 2006
Location: Arizona
Photos: Gallery | Albums
Posts: 43,182
Try formatting the cards in camera, or on a PC.

Adam
PentaxForums.com Webmaster (Site Usage Guide | Site Help | My Photography)



PentaxForums.com's high server and development costs are user-supported. You can help cover those costs by donating. Or, buy your photo gear from our affiliates, Adorama, B&H Photo, or Topaz Labs, and get FREE Marketplace access - click here to see how! Trusted Pentax retailers:

01-29-2016, 04:53 PM   #3
Site Supporter
Dewman's Avatar

Join Date: May 2012
Location: Idaho
Photos: Albums
Posts: 3,237
Original Poster
I figured it out, Adam. The card must be pushed in HARD before the door is closed. I don't know if you've been following this thread about the camera for the 16-year-old or not, but it was mentioned before I bought the cameras that BOTH the *istD L and the K-7 had a "scratch" across the image after it had been downloaded. I don't have the proper SD card for the *istD L, but the K-7 does indeed have a scratch across the top of the image. I tried different SD cards and different lenses. Same, either way. So.... I'm assuming it must be a scratch on the sensor. Does this make sense? Below is an example of the scratch.

Last edited by Dewman; 03-30-2016 at 02:54 PM.
01-29-2016, 05:04 PM   #4
Pentaxian
bertwert's Avatar

Join Date: Jun 2015
Location: Golden, BC
Photos: Albums
Posts: 5,481
QuoteOriginally posted by Dewman Quote
I figured it out, Adam. The card must be pushed in HARD before the door is closed. I don't know if you've been following this thread about the camera for the 16-year-old or not, but it was mentioned before I bought the cameras that BOTH the *istD L and the K-7 had a "scratch" across the image after it had been downloaded. I don't have the proper SD card for the *istD L, but the K-7 does indeed have a scratch across the top of the image. I tried different SD cards and different lenses. Same, either way. So.... I'm assuming it must be a scratch on the sensor. Does this make sense? Below is an example of the scratch.
Weird, the seller who you bought them from must be bad at cleaning sensors?

01-29-2016, 07:41 PM   #5
Site Supporter
Dewman's Avatar

Join Date: May 2012
Location: Idaho
Photos: Albums
Posts: 3,237
Original Poster
QuoteOriginally posted by bertwert Quote
Weird, the seller who you bought them from must be bad at cleaning sensors?

Man oh man.... ain't it so! What a shame. The camera is really clean, with less than 4,600 SA's. It came in the original box, with owners manual, two batteries, charger, Pentax neck strap that had never been opened and the software bundle that came with it.


Also, there was a *istD L, but I don't have a SD card that will work with it. I've been give instructions on how to update the firmware, but I'm such a numbskull, I'll have to give it a great deal of thought before I attempt it. I'd like to get at least the little one up and running so the girl will have something to use all those lenses with that I sent her.


The K-7 has other issues besides the scratch on the sensor. Dust removal won't work, among other things. But, it came cheap, so it wasn't like I was expecting too much.


Just a side note, the woman I bought them from had taken them with her to the Democratic Republic of the Congo while doing some Peace Corps work.... so, who knows how the scratch got there! She now lives in Lebanon.

Last edited by Dewman; 01-29-2016 at 07:49 PM.
01-29-2016, 11:06 PM   #6
Loyal Site Supporter
UncleVanya's Avatar

Join Date: Jul 2014
Photos: Gallery | Albums
Posts: 9,843
Post processing may not be too bad at healing that line. Weird.
01-29-2016, 11:31 PM   #7
Site Supporter
K(s)evin's Avatar

Join Date: Sep 2010
Location: Colorado
Posts: 269
It almost looks like the sensor might be cracked.
Just a thought.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
battery, camera, card, dslr, k-7, k-7 memory card, photography
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Memory Card Question monoloco Pentax Camera and Field Accessories 2 03-04-2014 05:34 PM
K-7 giving memory card full error Rosz Visitors' Center 4 02-24-2014 03:58 PM
What memory card for a K-7? GregX999 Troubleshooting and Beginner Help 20 07-30-2012 05:34 AM
K-7 Memory Card MB/S PentaxRev Pentax DSLR Discussion 6 06-17-2011 08:01 AM
tight K-7 memory card slot, SOLVED !!! Pentaxor Pentax DSLR Discussion 3 09-28-2009 10:41 PM



All times are GMT -7. The time now is 05:55 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top