Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
07-25-2016, 07:03 AM   #1
Forum Member




Join Date: Jun 2016
Posts: 90
New K-3 ii LV failure on a new K-3 ii ?

Hi. Today morning I was waiting for a sunrise to shoot some photos and something unpleasant happened to my camera. I rarely used LV with my 3 weeks old K-3 ii, but I did most of the shooting with LV today, and after about 20th shot the LV display just froze. I turned the camera off, to reset the camera, but the froze display didn't turn off. After a few try, I finally took the battery out and the screen shut off. Is this something I should ask for a replacement from Amazon? I only shot about 900 photos and this kind of early malfunctioning just kinda freaks me out. I still have 1 week till replacement due date. Any advise?


Last edited by talkskiwon; 07-25-2016 at 08:23 AM.
07-25-2016, 07:17 AM   #2
Site Supporter




Join Date: Jul 2013
Location: Cumming, GA
Posts: 522
Not if it is not consistently happening. ALso there may be a FW upgrade that oyu may need if it is not upto date already.
07-25-2016, 07:21 AM   #3
Junior Member




Join Date: Jul 2016
Posts: 34
My advice would be twofold: 1) look around here and DPR to see if anyone else is getting the same problem; 2) try to recreate the fault as closely as possible at least 10 times and see what happens - if you can repeat the error then yes, send it back for a replacement.

I should also say, if you are really worried, then there's nothing lost in getting a replacement from Amazon except a few days without the camera. I'm pretty sure you don't even need to pay shipping.

QuoteOriginally posted by shardulm Quote
ALso there may be a FW upgrade that oyu may need if it is not upto date already.
My understanding is that there are no firmware updates for the K-3ii yet.
07-25-2016, 07:41 AM   #4
Pentaxian




Join Date: Sep 2012
Location: NY
Photos: Gallery
Posts: 2,263
There are no firmware updates tor the K-3II at present.

07-25-2016, 11:05 AM   #5
Site Supporter




Join Date: Aug 2015
Photos: Gallery
Posts: 56
I do have the K3-II; never happened to me; use LV regularly.
07-25-2016, 11:30 AM   #6
Administrator
Site Webmaster
Adam's Avatar

Join Date: Sep 2006
Location: Arizona
Photos: Gallery | Albums
Posts: 41,847
This is a relatively normal occurrence as long as it doesn't happen often. Freezes are often related to low battery voltage, so if you battery is running low and you're using a lot of power (i.e. live view + a lot of AF, or AF-C plus burst mode), freezes may be more likely.

Adam
PentaxForums.com Webmaster (Site Usage Guide | Site Help | My Photography)



PentaxForums.com's high server and development costs are user-supported. You can help cover those costs by donating. Or, buy your photo gear from our affiliates, Adorama, B&H Photo, or Topaz Labs, and get FREE Marketplace access - click here to see how! Trusted Pentax retailers:

07-25-2016, 02:37 PM   #7
Forum Member




Join Date: Jun 2016
Posts: 90
Original Poster
QuoteOriginally posted by Adam Quote
This is a relatively normal occurrence as long as it doesn't happen often. Freezes are often related to low battery voltage, so if you battery is running low and you're using a lot of power (i.e. live view + a lot of AF, or AF-C plus burst mode), freezes may be more likely.
I had two thirds of the battery life when it happened and the battery was Pentax original version. Asked for the replacement and they say wait for confirmation.
07-25-2016, 04:41 PM   #8
Forum Member




Join Date: Jun 2016
Posts: 90
Original Poster
QuoteOriginally posted by mnaah Quote
My advice would be twofold: 1) look around here and DPR to see if anyone else is getting the same problem; 2) try to recreate the fault as closely as possible at least 10 times and see what happens - if you can repeat the error then yes, send it back for a replacement.

I should also say, if you are really worried, then there's nothing lost in getting a replacement from Amazon except a few days without the camera. I'm pretty sure you don't even need to pay shipping.



My understanding is that there are no firmware updates for the K-3ii yet.
I tried to find about the exact same screen malfunctioning, but there was no such problem listed on forums. The camera actually worked fine for about 30 shots after the incident, but I didn't want to take a chance, so asked for a replacement and it just went through. Thanks for the advices.

Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, dslr, failure, froze, ii, ii lv failure, k-3, k-3 ii lv, lv, photography, replacement, shots
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
First things to do when a new K-3 ii arrives? talkskiwon Pentax K-3 7 07-05-2016 04:13 PM
Used K-3 II with 3200 counts vs New K-70 talkskiwon Troubleshooting and Beginner Help 26 06-24-2016 05:37 AM
Unable to install firmware with new K-3 II Namajam Pentax K-3 3 08-10-2015 08:35 PM
The New PENTAX K-3 II Builds on the Performance Standard Set by Its Predecessor Furth Adam Homepage & Official Pentax News 5 05-17-2015 07:12 AM
Greetings from Tokyo.. New K-3 II cdurfor Pentax News and Rumors 10 04-27-2015 09:58 AM



All times are GMT -7. The time now is 09:49 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top