Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
07-26-2008, 06:43 PM   #1
Igilligan
Guest




Help?... So long my dear K100d

Hard to believe it has almost been a year.... But what a fun year it was!

So my 1 year warranty is almost up and I am sending my K100d in for service on monday...

I have 5 stuck pixels that show up bright at ISO 200 in any crop and at ISO 400 and up, there are about 12 more that creep in. They are definately stuck because they are always in the same spots on the sensor... The four that are really bright always bug me because my eyes look for them immediately on any good shot and two are fairly near the center so they tend to be there all the time.


What I need help with is... So other than pixel mapping, is there anything else I should be asking them to do on this service?

Do they go thru the camera and do basic service, clean the sensor / mirror / view finder above and beyond what you sent the camera in for?

Surely some of you have sent your cameras back for pixel mapping and or other service. Did they do other stuff to it? How long was your baby away?

It will be a long few weeks without a camera... Maybe I should get a K20 as a backup


Last edited by Igilligan; 07-27-2008 at 02:25 AM.
07-27-2008, 05:14 AM   #2
Veteran Member




Join Date: Jan 2008
Location: Ste-Anne des Plaines, Qc., Canada
Posts: 2,014
I sent my K10D to be fixed due to the AE-L switch acting up. It came back better than new. AF was improved somewhat, and all the dust in the viewfinder had been taken care of. Turnaround was eight days. But that was Pentax Canada, not Pentax U.S.A. Hope you won't be left out of your baby too long. The K20D seems like a good idea!
07-27-2008, 05:44 AM   #3
Pentaxian
danielchtong's Avatar

Join Date: Jul 2007
Location: Toronto
Posts: 848
QuoteOriginally posted by flyer Quote
I sent my K10D to be fixed due to the AE-L switch acting up. It came back better than new. AF was improved somewhat, and all the dust in the viewfinder had been taken care of. Turnaround was eight days. But that was Pentax Canada, not Pentax U.S.A. Hope you won't be left out of your baby too long. The K20D seems like a good idea!
We are paying around at least 10% premium over the price in the US. It used to be almost 20-30% though. And instead we have one more yr of Pentax warranty. With 10% premium I would still go with local Henry because of the add warranty.

Does it go with more comprehensive medical benefit and that GD tax as well?



Daniel
07-27-2008, 08:44 AM   #4
Veteran Member
wlachan's Avatar

Join Date: Sep 2006
Location: Canada
Photos: Albums
Posts: 2,626
Just shoot RAW and forget about it. Stuck pixels are norm for Pentax DSLRs. If you must have the CCD replaced, don't expect it came back perfect.

07-27-2008, 10:26 AM   #5
Veteran Member




Join Date: Sep 2006
Photos: Gallery
Posts: 5,713
It might be a good time to get re-acquainted with film while your waiting Gus

I hope that you get your camera back soon, and in perfect shape.
07-27-2008, 10:31 AM   #6
Veteran Member




Join Date: Jan 2008
Location: Southern California, USA
Photos: Gallery
Posts: 730
Gus, I'm in the same boat with you.
It's been 2.5 week since I departed with my K100D.
It has an annoying stripe dead pixels. Not just dots, but stripe across the upper 1/3 of th sensor.
So I sent it back to Pentax USA for repair before my warranty expires this October.

Well, from my experience sending my lens to Pentax last time,
actually you don't really need to ask for cleaning since they do that as part of the service.
My lens came back cleaner than when it was sent.

The annoying thing is we will be starring at these lenses with no body to use it
They said it will take 4-6 weeks to service, not including the shipping.

So, you're right, I think this is the time to get second body
07-27-2008, 01:11 PM   #7
Igilligan
Guest




QuoteOriginally posted by flyer Quote
I sent my K10D to be fixed due to the AE-L switch acting up. It came back better than new. AF was improved somewhat, and all the dust in the viewfinder had been taken care of. Turnaround was eight days. But that was Pentax Canada, not Pentax U.S.A. Hope you won't be left out of your baby too long. The K20D seems like a good idea!
That is good to hear... Hope colorado does as well with mine...

QuoteOriginally posted by wlachan Quote
Just shoot RAW and forget about it. Stuck pixels are norm for Pentax DSLRs. If you must have the CCD replaced, don't expect it came back perfect.
I seldom shoot raw... I know, I know it's the only way to go. But I just dont do it very often.

QuoteOriginally posted by little laker Quote
It might be a good time to get re-acquainted with film while your waiting Gus

I hope that you get your camera back soon, and in perfect shape.
Oh Stu... that would be a whole other service call since I tried my old ME super a while back and there were a few things that needed attention. Maybe I will pull out a K1000 that I got with some lenses, although it looked worse than my old ME.

QuoteOriginally posted by HermanLee Quote
Gus, I'm in the same boat with you.
It's been 2.5 week since I departed with my K100D.
It has an annoying stripe dead pixels. Not just dots, but stripe across the upper 1/3 of th sensor.
So I sent it back to Pentax USA for repair before my warranty expires this October.

Well, from my experience sending my lens to Pentax last time,
actually you don't really need to ask for cleaning since they do that as part of the service.
My lens came back cleaner than when it was sent.

The annoying thing is we will be starring at these lenses with no body to use it
They said it will take 4-6 weeks to service, not including the shipping.

So, you're right, I think this is the time to get second body
Herman, good luck with your repair... sounds like they will need to replace your sensor which should be a good thing. I think all mine needs is a simple pixel remap, that feature comes with the K20 now as a user option. If they had only done it with the K100d.....

Wish me luck....
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, dslr, iso, k100d, photography, pixel, service
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Misc Oh dear, oh dear, oh deer... Rense Post Your Photos! 5 11-05-2010 07:41 PM
K100D "long" cable switch scott_a Pentax Camera and Field Accessories 2 04-18-2009 07:14 PM
Dear Everybody wlfinch Welcomes and Introductions 5 01-25-2009 12:30 PM
My Dear, Dear Friends: Don't Do This. Mike Cash Pentax SLR Lens Discussion 54 12-07-2007 11:08 PM
Oh dear! Tom Lusk Post Your Photos! 10 12-06-2006 03:24 PM



All times are GMT -7. The time now is 07:31 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top