Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
02-20-2007, 09:09 PM   #1
Inactive Account




Join Date: Oct 2006
Posts: 4
DS auto focus problems

I use a DS model with a 50-500mm sigma and other smaller lenses. My problem is that the auto focus function of the camera has stopped working. The motor is whinging but not engaging the lens, both focus select switchs are in the correct position. With my other lens that don't have the a switch on the lens i get no af fuction either. Manual focus still functions perfectly.

Any Thoughts, Cheers

02-20-2007, 10:09 PM   #2
Veteran Member
Alvin's Avatar

Join Date: Dec 2006
Location: Mississauga, Ontario, Canada
Photos: Gallery
Posts: 2,530
Hi Rangitata,

I think you could have worn parts that need servicing. Even though you hear the motor whine, the focus screw itself may not be engaging the lens properly, or the screw may not be rotating even though it is engaged.
02-20-2007, 10:29 PM   #3
Veteran Member
FotoPete's Avatar

Join Date: Feb 2007
Location: Toronto
Photos: Gallery
Posts: 1,710
Yea that might be it. Take the lens off and then switch the camera into AF mode. Check to see if the AF screw head actially extends above the K Mount plate surface. It might be still turning but not extending enough to actually turn the receptor on the lens.

You should get it checked out at the store perhaps.
02-21-2007, 12:53 AM   #4
Veteran Member




Join Date: Nov 2006
Location: Hong Kong
Posts: 1,934
QuoteOriginally posted by rangitata Quote
I use a DS model with a 50-500mm sigma and other smaller lenses. My problem is that the auto focus function of the camera has stopped working. The motor is whinging but not engaging the lens, both focus select switchs are in the correct position. With my other lens that don't have the a switch on the lens i get no af fuction either. Manual focus still functions perfectly.

Any Thoughts, Cheers
Sound like the body's AF coupler does not engage properly to the lens's coupler, owing to the inaccuracy and large play of the lens mount. Try turning the lens clockwise and anti-clockwise to see if those couplers can in touch and comes into the place!

Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
auto, camera, ds, dslr, focus, lens, photography
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Problems auto focus assist in manual tonybolo Pentax SLR Lens Discussion 5 06-11-2011 06:20 PM
k-7 auto focus problems garyk Pentax DSLR Discussion 5 10-21-2010 11:50 PM
Auto focus problems??? Moorby Troubleshooting and Beginner Help 8 12-24-2009 02:24 AM
K20D battery grip auto focus problems. i83N Pentax Camera and Field Accessories 3 12-08-2009 07:32 AM
Focus problems for both manual and auto?! dkittle Pentax DSLR Discussion 32 08-20-2008 01:54 PM



All times are GMT -7. The time now is 10:50 AM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top