Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
08-28-2008, 09:54 PM   #1
Inactive Account




Join Date: Aug 2008
Location: Melbourne
Posts: 6
How to access Debug Mode of Pentax K200

Does anybody know how to access Service Menu in Debug Mode of Pentax K200?

08-29-2008, 10:46 PM   #2
Senior Member




Join Date: May 2008
Location: Irvine, So. Cal
Posts: 104
I don't think that you can access the K200D's debug menu at this point. K10D's debug menu is accessible with software version 1.10. My guess is that the dubug menu accessibility was added to the 1.10 version. It has been about five month since the release of K200D. I do not think that we are going to see the new software upgrade. K200D's engine is similar to K10D and the bugs were already taken care of. I found service manual for Samsung version of K10D on the web. There was no instruction for accessing the debug menu. So even if a K200D's service manual leakes out to the web, most probably, we will not be able to find the way to the debug menu.
09-01-2009, 08:02 AM   #3
Veteran Member
LensScribe's Avatar

Join Date: Jan 2009
Location: Johannesburg, South Africa
Photos: Gallery
Posts: 316
Hmm, looks like there might be debug access for K200D here at last.
09-01-2009, 08:11 AM   #4
Inactive Account




Join Date: Jan 2008
Location: NC
Posts: 787
yes, add the modset file and presto! AF adjust on k200.
k2000, km as well.

09-01-2009, 08:23 AM   #5
Loyal Site Supporter
dcmsox2004's Avatar

Join Date: Apr 2008
Location: rhode island
Photos: Gallery | Albums
Posts: 7,331
sorry to sound like a dolt... but what are we talking about here...i have a k200d and should i be doing something to the body to upgrade the software??
i have not had any problems with focus to date, either with genuine pentax glass or 3rd party lenses...
regards and thanks, dave m
09-01-2009, 10:08 AM   #6
Pentaxian
Marc Sabatella's Avatar

Join Date: Sep 2006
Location: Denver, CO
Photos: Gallery
Posts: 10,686
FWIW, I was able to access the debug menu using the instructions from the site referenced above. Actually doing anything with the debug menu is another matter entirely, though. You thought the *regular* Pentax menus were cryptic? The debug menu is far worse. But as far as I can tell, it lacks the direct control over AF fine tuning that is present in some of the other cameras. It appears to have a command to bulk-load tuning data from a file, but of course, without documentation on the format of that file, this doesn't help. Maybe by now someone has worked that out?

Anyhow, if you don't have a problem, then you don't need any of this. I don't have any AF problems (aside from the usual user-induced ones), so i looked into this only out of curiosity.
09-01-2009, 02:02 PM   #7
Veteran Member
wasser's Avatar

Join Date: Jan 2009
Location: northern ca
Photos: Gallery
Posts: 427
Marc, I'm guessing the AF adjustment method is different between the k200d and K-m/k2000. I've haven't tried it, but the way it's detailed (for the k-m/K2000) at Ricehigh's blog seems pretty easy to use.

RiceHigh's Pentax Blog: K-m Debug Mode Unleashed! (For AF Correction)
09-01-2009, 03:13 PM   #8
Pentaxian
Marc Sabatella's Avatar

Join Date: Sep 2006
Location: Denver, CO
Photos: Gallery
Posts: 10,686
QuoteOriginally posted by wasser Quote
Marc, I'm guessing the AF adjustment method is different between the k200d and K-m/k2000. I've haven't tried it, but the way it's detailed (for the k-m/K2000) at Ricehigh's blog seems pretty easy to use.

RiceHigh's Pentax Blog: K-m Debug Mode Unleashed! (For AF Correction)
That's a nice article by RH! Unfortunately, yes, it is different on the K200D. That control just doesn't exist that I can find on the K200D debug menu. But I admit that all I did was look at the "main" debug menu that comes up when you start the camera - I didn't scroll the other menus to see if there were new options in them or "between" them. Well, maybe at point I'll get curious enough to try again.

09-02-2009, 01:07 AM   #9
Veteran Member
LensScribe's Avatar

Join Date: Jan 2009
Location: Johannesburg, South Africa
Photos: Gallery
Posts: 316
QuoteOriginally posted by Marc Sabatella Quote
Actually doing anything with the debug menu is another matter entirely, though.
Yes, quite. Following the instructions I had no problem getting my K200D to go into debug mode, but what to do there remains a mystery. Good to know it works though, with any luck someone will work out useful applications in due course. I was just hoping it might have something allowing for tethered shooting, and that there might be a GUI for AF adjustments.
03-23-2010, 10:57 PM   #10
Inactive Account




Join Date: Nov 2008
Location: Melbourne
Photos: Gallery
Posts: 3,549
Thought i'd bring this up again.

Is anyone else having trouble getting into the debug mode on their K200D? After following the steps precisely, all I get is "VER:1.00" and then it shuts off. Turn it on again and the "AF TEST" is not present in the menu system.

This is all I could find on PF as far as troubleshooting goes:

MEMSET works on K200D with v1.00.00.03 firmware, as I have dumps of this firmware done using MODSET.445.
If you have AUTORUN.445 in same card, MODSET won't work

Do I have to have v1.00.00.03 for this to work? Or is it just trial and error with possible file names to enter into debug menu?
03-25-2010, 05:17 PM   #11
Inactive Account




Join Date: Nov 2008
Location: Melbourne
Photos: Gallery
Posts: 3,549
Anyone have any ideas?
03-26-2010, 09:31 AM   #12
Pentaxian
Marc Sabatella's Avatar

Join Date: Sep 2006
Location: Denver, CO
Photos: Gallery
Posts: 10,686
Been a while since I tried it, but all I can say is that my experience was as described above. No trouble getting into debug mdoe when I followed the instructions carefully; but I never did find the af adjustment. I didn't actually need it though, so I didn't try too hard.
03-26-2010, 04:46 PM   #13
Inactive Account




Join Date: Nov 2008
Location: Melbourne
Photos: Gallery
Posts: 3,549
Do you have v1.00.00.03? I think that's why i'm having the problem, as I only have v1.00.
03-27-2010, 08:58 AM   #14
Pentaxian
Marc Sabatella's Avatar

Join Date: Sep 2006
Location: Denver, CO
Photos: Gallery
Posts: 10,686
I wasn't aware there were any firmware updates available for the K200D, so I have the version the camera came with. If I turn the camera on while holding the Menu button, it reports 1.00.
03-29-2010, 08:10 PM   #15
Pentaxian




Join Date: Mar 2010
Location: Frankfurt am Main
Posts: 1,094
Focus adjustment in debug mode

I own the K200D and it also shows Version 1.00. The Pentax site never offered an update for the K200D.
The menu extensions in debug mode are not at the same locations for the different Pentax models. With my K200D, 3 additional entries are added at the very end of the "set up" menu (after the last entry of the normal mode).

If there is still someone having difficulties initializing the debug mode:

1) Store a plain text file named MODSET.445 on your SD card. As a starter, it should only content 2 lines:

[DEBUG_MODE EN]
[OPEN_DEBUG_MENU]

Mind the kind of brackets and don't swap underscores and spaces !!

2) Just leave the memory card door open during switching on. When the camera is switched on, you may close the door.

3) With these preparations, the debug mode is already switched on, and the pointer of the first menu will be in the correct position and show
DEBUG MODE <EN>
Confirm it with the OK key.

4) You are now in debug mode forever, even switching the camera off and on does not change this. It seems, you can perform everything just as in "normal" mode. However, whenever the display screen would be dark, it now shows "DEBUG MODE", so it will use up a bit more of energy.

5) To leave debug mode permanently, switch the camera off, and leave the memory card door open while switching it on. Now in the first menu, instead of confirming the "DEBUG MODE <EN>", change it to "DEBUG MODE <DIS>" (use the left/right cursor keys).

Last edited by RKKS08; 03-29-2010 at 08:33 PM. Reason: Information added
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
access, camera, debug, dslr, k200, mode, pentax, photography
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
k-7 debug mode - how to enter Nass Pentax DSLR Discussion 17 01-17-2015 04:56 PM
Anyone use K10D at debug mode? rosier19 Pentax DSLR Discussion 25 12-18-2010 07:34 PM
K10D Firmware 1.3 Debug Mode Unleashed! RiceHigh Pentax DSLR Discussion 148 10-01-2010 01:48 PM
Debug menu access for the K100DS? Nachodog Pentax DSLR Discussion 3 04-14-2010 02:27 PM
Debug mode on K-x. ilya80 Pentax DSLR Discussion 2 11-04-2009 05:12 AM



All times are GMT -7. The time now is 06:26 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top