Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
06-02-2018, 05:53 AM   #1
Senior Member
rodaballo's Avatar

Join Date: Apr 2013
Posts: 133
Pentax K10D shaking sensor

Dear firends, I recently got a K10D with a shaking sensor issue. The sensor dances like crazy at shutter speeds longer than 1/3. It seems that it is the SR system failing and insists on moving erratically, which renders the camera unusable at lower speeds. I made a video of the sensor's performance so that you can see what I am talking about. Yes, it is that bad.

I have found little information about this issue on this forum. Some users did experience it on their K10D, but also it seems that it occurred also in some K7 and some K5. There is no apparent solution for this problem, apart from sending it to repair. I am not considering a professional repair since cost would long exceed what I paid for the camera. I was wondering if any of you is so clever to modify the K10D's firmware and completely deactivate the SR system of the camera. Maybe this could help to, at least, have a static sensor. The shaking sensor issue, by the way, occurs in my camera when SR is on or off, indistinctly. I would very much appreciate your help.

06-02-2018, 06:00 AM   #2
Loyal Site Supporter
Loyal Site Supporter
UncleVanya's Avatar

Join Date: Jul 2014
Photos: Gallery | Albums
Posts: 16,256
Can't you turn off Sr in the menus?
06-02-2018, 06:07 AM   #3
Senior Member
rodaballo's Avatar

Join Date: Apr 2013
Posts: 133
Original Poster
QuoteOriginally posted by UncleVanya Quote
Can't you turn off Sr in the menus?
Thanks for your reply. I cannot see the option in the menu of the K10D, not even on the DEBUG mode, or at least I cannot find it. The K10D has an external SR activation lever. Turning it off does not change anything.
06-02-2018, 06:17 AM   #4
Loyal Site Supporter
Loyal Site Supporter
UncleVanya's Avatar

Join Date: Jul 2014
Photos: Gallery | Albums
Posts: 16,256
QuoteOriginally posted by rodaballo Quote
Thanks for your reply. I cannot see the option in the menu of the K10D, not even on the DEBUG mode, or at least I cannot find it. The K10D has an external SR activation lever. Turning it off does not change anything.
Gotcha. It's been a while since I used that camera. Does two second self timer make any difference?

06-02-2018, 06:26 AM   #5
Senior Member
rodaballo's Avatar

Join Date: Apr 2013
Posts: 133
Original Poster
I have just tested it. No differences. The funny thing is that the sensor begins the rain dance just after I click the shutter button. So, during the 2 seconds delay you can hear/feel the shake. And it goes on when shooting.
06-02-2018, 06:36 AM   #6
Loyal Site Supporter
Loyal Site Supporter
UncleVanya's Avatar

Join Date: Jul 2014
Photos: Gallery | Albums
Posts: 16,256
QuoteOriginally posted by rodaballo Quote
I have just tested it. No differences. The funny thing is that the sensor begins the rain dance just after I click the shutter button. So, during the 2 seconds delay you can hear/feel the shake. And it goes on when shooting.

I can't recall if the 2 second timer turns off SR on that body. I suggested it to eliminate the mechanical switch from the equation but if have to dig up a manual to confirm it disables SR on that model. The only other idea I have is that if it isn't using the very latest firmware you could try updating firmware.
06-02-2018, 06:43 AM   #7
Senior Member
rodaballo's Avatar

Join Date: Apr 2013
Posts: 133
Original Poster
Technically, the current firmware is 1.31.00.19
Thanks for your help
06-02-2018, 07:13 AM   #8
Moderator
Not a Number's Avatar

Join Date: Mar 2012
Location: Venice, CA
Posts: 6,692
Just turn off SR with the switch on the back of the camera below the 4 way selector..

Edit: Saw the later post that it doesn't seem to change things. Sounds like the only solution is to have the camera serviced, probably just less expensive to replace the camera. Precision doesn't even list the K10D any longer on their service list. No parts.


Last edited by Not a Number; 06-02-2018 at 07:22 AM.
06-02-2018, 08:17 AM - 3 Likes   #9
Loyal Site Supporter
Loyal Site Supporter
twilhelm's Avatar

Join Date: Feb 2009
Location: Florida
Photos: Gallery | Albums
Posts: 2,342
The K10D will have a sensor shake issue when the batteries are going bad, or the contacts get a “film” on them. Start be cleaning the battery contacts on the camera and the battery with a pencil erasure. Then check the voltage of the batteries you have.

I have (had) 3 batteries for my K10D. I had this happen to me, and the battery in question completely died 2 days later. It has never happened with either of my other batteries. Someone else had the issue, (can’t remember who) and it was a bad battery for them also.

CCD sensors, such as the K10D use, have greater power requirements than the CMOS sensors in newer cameras. At longer exposure times, the shake issue will appear when the battery starts to go bad due to the shake reduction system not getting enough voltage.

Last edited by twilhelm; 06-02-2018 at 08:22 AM.
06-02-2018, 09:48 AM   #10
Forum Member
Robot camera's Avatar

Join Date: Mar 2013
Location: Milton Keynes, Buckinghamshire
Posts: 86
I have a sensor shake issue with my K20D, when in live view mode. It only happens with the 16-50mm f/2.8, if I remember correctly. The same lens is fine on my K3. The live view isn't great on the K20D, so with the sensor
shake, I don't use it much.
06-02-2018, 11:43 AM   #11
Pentaxian
E-man's Avatar

Join Date: Aug 2012
Posts: 586
Sad to say, but repair costs and parts availability--or lack thereof--have moved the K10D into the 'end-of-life' category. Although it's a still a great camera, it's more cost effective to replace and upgrade than to repair, so the best thing to do is just use it until you can't use it anymore. I picked one up a couple of years ago for $78 in great condition with a fairly low shutter count of around 5,000. It works great and I still use it on occasion, but I find my K200D, which has the same sensor, to be a little more user friendly and better suited for my needs.
06-03-2018, 01:37 AM   #12
Forum Member




Join Date: Jan 2011
Location: Bergen, Norway
Posts: 60
Five years ago + + many threads in this forums refered to the K10d Service manual. A useful pdf with a lot of technical information. Also about the SR system. You will still find it at the1st link here. From page 60 and further on you'll get a lot of information abut the SR system.

How to test the SR by a special software. In case of error / error code refer tables. And finally some tables for adjustments (by the same software). The download link for Samsung GX10 (same camera) service software doesn't work any more but perhaps you'll find it somewhere else...

I have never done this by myself but it looks like you have nothing to loose. Good luck!

Last edited by Dabola; 06-03-2018 at 04:38 AM.
06-03-2018, 05:28 AM   #13
Pentaxian




Join Date: Apr 2007
Location: Sweden
Posts: 2,104
When there is no hope left, open it up and glue the sensor in place and cut the lines to the SR coils.
06-03-2018, 08:30 AM   #14
Senior Member
rodaballo's Avatar

Join Date: Apr 2013
Posts: 133
Original Poster
Dear friends, many thanks for your input. After reading your observations I come to the conclusion that I should take the risk and buy a new battery for my K10D. I will test the camera with a new fresh battery and see what happens. I will keep you updated. Thank you for this valuable information.
06-05-2018, 03:48 PM   #15
Senior Member
rodaballo's Avatar

Join Date: Apr 2013
Posts: 133
Original Poster
Dear friends. Today I got a new battery for my dancing K10D. Unfortunately the sensor still shakes with a fresh new battery. I am afraid that this camera has reached its final destination. Thanks for your help anyway.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, dslr, issue, k10d, pentax k10d, photography, repair, sensor, speeds, sr, system
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Bizarre SR problem: Sensor shaking by itself bwDraco Pentax K-5 25 09-25-2017 05:33 PM
K-50 Sensor Shaking a lot in Live View Schick Troubleshooting and Beginner Help 3 05-29-2015 11:29 AM
[K20D] sensor shaking in bulb mode Magilla Troubleshooting and Beginner Help 6 02-06-2013 03:18 PM
Pentax K-7 unwanted sensor shaking nassestrasse Troubleshooting and Beginner Help 3 05-15-2012 09:17 AM
k10d sensor shaking like mad occhicone98 Pentax SLR Lens Discussion 2 12-28-2008 08:58 AM



All times are GMT -7. The time now is 06:07 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top