Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
08-31-2018, 06:02 PM   #1
Pentaxian




Join Date: Jun 2012
Location: Tokyo
Photos: Gallery
Posts: 1,018
My K3 seems to auto reset its time and date.

My K3 seems to automatically and randomly reset its own time and date back to default. It happens 3 times already.
The latest one is just now when I try to test my problematic DA*55 before got to get a replacement in store today.
The second time was last week and I was using my problematic DA*55 too.
The first time, was a few days after I update the firmware to V1.40. I was not using DA*55

Here are what I am thinking:
1. K3 firmware 1.40 - the problem starts after I update to the latest Firmware, V1.40 (from V1.30). I updated the firmware, do some test, no problem. Then a week later I went out for night shooting, and during I switch lens, the camera resets its time.

2. My "problematic" DA*55 - It happens 2 times while I was using this lens, and today, I test lenses. it was no problem so far but after I put my DA*55 on, the camera resets its clock. by the way "I don't really think the problem comes from this lens."
I keep mention "problematic" DA*55. This lens has a problem as I posted here. Some forum members speculate that the lens might have been dropped.

3. Somehow I accidentally push wrong buttons, but I am not really sure what buttons can reset the time! Anyone know what button or menu I can go to reset the time?

Does anyone have a similar problem?
I will go back to V1.30 and see what happen next.

08-31-2018, 06:40 PM   #2
Loyal Site Supporter
Loyal Site Supporter
kcjonez's Avatar

Join Date: Jul 2015
Location: Mount Desert, Maine, USA
Photos: Gallery | Albums
Posts: 156
I thought I'd seen this discussion before;

K-3 Prompts for Date/Time when changing battery - PentaxForums.com

Haven't had any issues with mine yet, knock on wood.
08-31-2018, 06:49 PM   #3
Site Supporter
Site Supporter
LightBug's Avatar

Join Date: Nov 2007
Location: OC, CA, USA
Posts: 495
Could be the DA 55 is shorting circuits somewhere?
08-31-2018, 08:24 PM   #4
Loyal Site Supporter
Loyal Site Supporter
UncleVanya's Avatar

Join Date: Jul 2014
Photos: Gallery | Albums
Posts: 14,742
QuoteOriginally posted by LightBug Quote
Could be the DA 55 is shorting circuits somewhere?
Hard to imagine - the main contacts are meant to be shorted. The data contact doesn't provide much actual current. The powerzoom/SDM contacts could be doing something but I'd bet the CPU power is voltage stabilized and not very likely to dip and sag unless those components are damaged. The main culprit is likely the backup battery which may have died.

08-31-2018, 08:29 PM   #5
Otis Memorial Pentaxian
Loyal Site Supporter
stevebrot's Avatar

Join Date: Mar 2007
Location: Vancouver (USA)
Photos: Gallery | Albums
Posts: 31,451
It is unlikely that the lens or update are at fault. The internal clock is maintained from a capacitor on the main board that may be going bad. Replacement is reportedly not complicated, but requires a partial disassembly.


Steve
09-01-2018, 04:48 AM   #6
Pentaxian
Not a Number's Avatar

Join Date: Mar 2012
Location: Venice, CA
Posts: 5,692
Seems unusual, others would have reported similar problems if it was firmware related. Do you have another lens you can try it with?

Trouble shooting:
Try a different lens
problem still exists - reload older firmware - problem still exists - camera is most likely at fault; have it serviced
problem goes away - lens is probably at fault; service or replace the lens
09-01-2018, 03:36 PM - 1 Like   #7
Pentaxian




Join Date: Jun 2012
Location: Tokyo
Photos: Gallery
Posts: 1,018
Original Poster
Thank you all for the troubleshooting.

@kcjonez
Thank you a lot for the link. Interesting to read it. It is very similar to mine. A few minor differences in small details. No one mentions how much to get it to fix. I guess if my K3 capacitor turns out to have the same problem, I will find it out then. Hope it won't be too expensive.

@LightBug @UncleVanya @stevebrot @Not a NumberAn
At first, I thought it was the 55 but when I check at the photo the day it happens the first time, I was using DA21, and it was a few days before I get the 55. Anyway, I get a 55 replacement yesterday. I also back to the firmware 1.30 yesterday too. I will go out to shoot today and will see if it happen again.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
buttons, camera, da*55, dslr, firmware, k3, lens, photography, reset, reset its time, resets, test, time
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Losing Date, Camera Reset?? NYNOIR Pentax Q 24 03-15-2018 04:43 PM
Pentax K3 Firmware update to v1.30 and Date and time settings Stag beetle Pentax K-3 6 08-08-2017 04:44 PM
Date and Time Settings Always Reset (Help) Ron_Man Pentax Q 14 08-02-2015 04:30 PM
Date and time reset at battery change TJWest Pentax K-30 & K-50 2 08-06-2012 02:29 AM
Optio E80 clock reset and won't honor [Date Adjustment] changes stoub Troubleshooting and Beginner Help 2 01-08-2012 11:27 AM



All times are GMT -7. The time now is 10:18 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top