Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
09-30-2008, 09:55 PM   #1
Inactive Account




Join Date: Sep 2008
Location: CA
Posts: 14
Anyone use K10D at debug mode?

I opened a hidden menu to enter debug mode using a program....
Then I adjusted K10D focus.

Now I have a question!
Do I have to close this debug mode?
It is very convenient.
For example, when I change my lens, I re-adjust my camera focus to the lens.
I do not want to downgrade my firmware just only for the debug mode!

10-01-2008, 01:36 AM   #2
New Member
pentaxon's Avatar

Join Date: Sep 2008
Location: Slovenia
Photos: Gallery
Posts: 4
You wrote down, that it is very convenient.
So, there is no need to "turn off" the debug mode.
I also use my K10D in debug mode all the time (firmware ver. 1.30)
10-01-2008, 01:37 AM   #3
Senior Member
Spex's Avatar

Join Date: Aug 2008
Location: Dubrovnik, Croatia
Posts: 216
Debug mode in ver 1.30? Are you sure?
I know there is debug mode in 1.10, but 1.30?
10-01-2008, 02:40 AM   #4
New Member
pentaxon's Avatar

Join Date: Sep 2008
Location: Slovenia
Photos: Gallery
Posts: 4
I'm sure, why not?
You can activate debug mode in ver. 1.30 using special SW (made by Russian hacker). You can find SW HERE

10-01-2008, 03:11 AM   #5
Senior Member
bentax's Avatar

Join Date: Jan 2008
Location: West Australia
Posts: 190
:0 I didnt realize they got that focus adjust debug workin in ver1.3
10-01-2008, 03:24 AM   #6
Veteran Member
Zebooka's Avatar

Join Date: May 2008
Location: Russia, Siberia, Novosibirsk
Posts: 323
Yepp you are right
Program written by makc on penta-club.ru
(
here it is Index of /
http://dednev.pisem.net/setup_gx10_dmctrl_1.1u_eng.exe
)

But there is a need to switch off debug mode, cause it depletes batteries by always turned-on LCD, and heating cameras sensor with warm LCD.
10-01-2008, 07:32 AM   #7
Inactive Account




Join Date: Sep 2008
Location: CA
Posts: 14
Original Poster
heating sensor?
ummmmmm I didn't think about that.
10-01-2008, 07:46 AM   #8
Forum Member




Join Date: Dec 2007
Location: Winnipeg, MB
Posts: 51
QuoteOriginally posted by Zebooka Quote
]But there is a need to switch off debug mode, cause it depletes batteries by always turned-on LCD, and heating cameras sensor with warm LCD.
Are you certain about the heat issues objection? LCDs tend to produce essentially no heat, with the backlight being the only possible source - and even then, in well designed displays this is severely limited by the use of cold cathode fluorescent lamps.

10-01-2008, 08:14 AM   #9
Veteran Member




Join Date: Nov 2006
Location: Hong Kong
Posts: 1,934
Yes, otherwise the LCD will not be turned off!

And it shows all the debug data or menu all the time!

QuoteOriginally posted by rosier19 Quote
I opened a hidden menu to enter debug mode using a program....
Then I adjusted K10D focus.

Now I have a question!
Do I have to close this debug mode?
It is very convenient.
For example, when I change my lens, I re-adjust my camera focus to the lens.
I do not want to downgrade my firmware just only for the debug mode!
10-02-2008, 01:15 AM   #10
New Member
pentaxon's Avatar

Join Date: Sep 2008
Location: Slovenia
Photos: Gallery
Posts: 4
QuoteOriginally posted by RiceHigh Quote
And it shows all the debug data or menu all the time!
It's true, but only on K100D(s), not on K10d. If you leave K10D in debug mode, only "debug mode" notice is displayed all the time in "stand-by mode".

Does anybody know, how to set up AF for more than one lens in K10D debug mode using this Russian SW? When I enter AF Test option, I can see two different options inthere: AF area test (values from zero to 3) and Focus Corr (in um unit). How can I use AF area test parameter?

Thanks.
10-03-2008, 05:09 PM   #11
Veteran Member
iced's Avatar

Join Date: Aug 2008
Location: Southwest Ga.
Photos: Gallery
Posts: 309
I experienced back-focus and the easiest fix I found is:

If your K10D have problem with focus, you can adjust it yourself.
Someone in Korea figured it out himself.
He is not a employee of Pentax or related company.
He just found out by trial-and-error with key-set.
Of course, You yourself is responsible for doing something scribed below.
Here's How-to-adjust-focus.

1. Your K10D' firmware version must be 1.10.

2. Test shot for focus trouble.

3. Turn the camera OFF.
While pressing [PLAY]+[OK], Turn the camera ON.
You can see firmware version on LCD screen.

4. Firmware version is appeared,
then press [Fn]->[Fn]->[INFO]->[MENU] within 5 seconds.
You get service menu!!!

5. by pressing [right key]
,Make DEBUG MODE to DEBUG MODE .
then press [OK].
(save and LCD will be black out)

6. Press [MENU] and go to SETUP tab.
then, Press [Up key], you can see TEST MODE.

7. Select AF TEST menu. now you have AF correction menu.
If you have Front-focusing, reduce the value.
If you have back-focusing, increase the value.
after adjust some value, press [OK] and quit out of setup menu.

8. TEST for focus, find out that focus is correct.
(repeat this from 6 for correct focus.)

9. Go to service menu(step 3,4).
Make DEBUG MODE to DEBUG MODE .
then press [OK].(save and LCD black out)
10-27-2008, 02:29 AM   #12
New Member




Join Date: Jul 2008
Posts: 24
Is there any chance to turn of the k100d super display in debug mode? I can't find any info about it.

Unfortunately I didn't menage to set AF properly for all of my lenses and I want to use debug mode all the time.
10-27-2008, 02:03 PM   #13
Senior Member
Indianadinos's Avatar

Join Date: Jul 2008
Location: France
Posts: 128
Hello,

Yes, i do have it on all the time, since i turned it on (fw 1.30) thanks to makc ;-) ...
Up to now, i found no particular issue, except that, when turned on, the rear screen will stay on until the camera goes in sleep mode, which could lead to a little lower battery duration (but, frankly, i don't think this is a real issue).

Best regards
10-28-2008, 06:45 AM   #14
New Member




Join Date: Jul 2008
Posts: 24
What's annoying, the letters and dials of debug mode are visible for me even when I'm looking through the viewfinder. It can be a problem when shooting at night.
11-11-2008, 03:26 PM   #15
Inactive Account




Join Date: Nov 2008
Location: spain
Posts: 3
PLEASE tell me about this debug mode-is it to do with AF correction (that is what I need) Thanks
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, debug, dslr, focus, k10d, lens, mode, photography
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
K10D focus adjustment with debug mode cem.kumuk Pentax DSLR Discussion 12 01-16-2016 07:11 PM
AF Area Test in K10D Debug Mode mcjm78 Pentax DSLR Discussion 11 02-07-2011 09:57 AM
K10D Firmware 1.3 Debug Mode Unleashed! RiceHigh Pentax DSLR Discussion 148 10-01-2010 01:48 PM
K10D debug mode and 35 Limited macro treebeard Pentax DSLR Discussion 10 10-21-2009 08:47 PM
K10D doesn't trigger shutter after debug mode Marcoz Pentax DSLR Discussion 7 02-18-2009 11:27 AM



All times are GMT -7. The time now is 04:58 PM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top