Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
10-02-2008, 03:59 PM   #1
Pentaxian




Join Date: Apr 2007
Location: Oklahoma USA
Posts: 1,502
sensor dust(?), again

I have an interesting problem with my K100d (1+yr old, only 4500 exposures.) I get lots of junk on the sensor, probably because I'm always changing lenses in less than pristine environments.

Until this month, just blowing, or using a sensor brush, has solved my sensor cleaning problems. But now I have a spot that doesn't look like the usual dust. Generally even with my wide angle lens at f16+, dust shows up as somewhat of a fuzzy "blob" (much less fuzzy than at f4 or whatever, of course.) But this new spot is much sharper - more like a dark colored group of slightly fuzzy pixels (maybe 10 or so pixels in size.) Still not sharp, just sharper than all the other dust spots. It looks, at f4, like regular dust looks at f16.

So I resorted to the usual tool with a pad attached, and cleaning fluid. I started out gently, with little fluid and pressure, but eventually wound up wiping the sensor pretty enthusiastically with a soaking wet pad. And of course I checked after every attempt. I moved all kinds of other junk around on the sensor, but nothing I did had any effect on this one spot at all.

Any other suggestions? Obviously I can, generally, work around it in post-processing, but it's pretty ugly at small apertures (and in the sky area, of course.)

Ironically, I have an annoying spot in the viewfinder (the only one) in almost exactly the same place as the sensor spot, which I guess is convenient in that it reminds me where the spot will be. At least it's "what you see is what you get."

Paul

10-02-2008, 04:12 PM   #2
Veteran Member
Gooshin's Avatar

Join Date: Sep 2007
Location: Toronto, the one in Canada.
Posts: 5,611
i had those on my k100d

keep scrubbing, i felt like i was going to break my sensor, but i didnt, camera still works perfectly.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, dslr, dust, f16, f4, fluid, junk, pad, photography, pixels, sensor, spot
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Sensor dust Pablom Troubleshooting and Beginner Help 24 04-10-2010 05:57 AM
dust on sensor or dust on lens 41ants Troubleshooting and Beginner Help 10 10-08-2009 10:28 AM
Sensor Dust or what??? NT-Tim Pentax DSLR Discussion 10 03-25-2009 08:01 PM
dust on sensor Christl Troubleshooting and Beginner Help 4 03-14-2009 03:06 PM
dust behind sensor? jsundin Pentax DSLR Discussion 3 11-24-2006 09:51 AM



All times are GMT -7. The time now is 03:02 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top