Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
03-03-2007, 07:34 AM   #1
Inactive Account




Join Date: Mar 2007
Location: Frederick, MD USA
Posts: 5
K100D won't accept new Sigma lens?!

Help! My new Pentax K100D doesn't appear to accept a new Sigma 18-200mm (F3.5-5.6) lens that is designed specifically for digital cameras. The lens attaches to the camera without a problem but I get a flashing "Av" aperture priority signal. The same thing happens with my Pentax ist DL camera. The screen on top of the camera flashes "Av" constantly. Nothing I do seems to remove this Av indicator. Does anyone know why this happens?

03-03-2007, 07:44 AM   #2
Veteran Member
-=JoN=-'s Avatar

Join Date: Nov 2006
Location: NYC
Posts: 1,000
could be a faulty lens. I had issues when I purchased a sigma before, it didnt give the body the correct aperture reading, and was not AF-ing

you might have to return it or send it to sigma

anything else it's not doing?

if it's doing it on 2 bodies, the more than likely it's the lens. i tried mine on film and the k10, both problems. give them a call, their service reps are pretty nice..
03-03-2007, 09:14 AM   #3
Veteran Member
FotoPete's Avatar

Join Date: Feb 2007
Location: Toronto
Photos: Gallery
Posts: 1,710
"DC" means the lens forms an image circle to fit APS sensors only. (Plus some coatings to prevent reflection on the back element.)

Sigma does not have access to proper mount design. Companies don't like to give their mount workings away or else others will make lenses and sales of the original brand lenses would drop hurting the company. Canon is most notorious for this.

Third party manufacturers have to usually buy the brand name lens and dissect/reverse engineer to get at how the mount + electronics work. Usually its a hit and miss and everytime something new alters slightly for that mount, those Sigma lenses need to be sent back to Sigma to be "rechipped".

Maybe thats the case with your lens. Take it back to the place you bought it and explain the problem.

Wait, does your Sigma lens have an aperture ring? If it does, then keep the ring on "A" position and change the aperture on the camera via the back dial. cuz that might be the problem.
03-03-2007, 09:40 AM   #4
Veteran Member
*isteve's Avatar

Join Date: Nov 2006
Location: London, England
Posts: 1,187
Is aperture ring set to "A"?

QuoteOriginally posted by jdpenk100d Quote
Help! My new Pentax K100D doesn't appear to accept a new Sigma 18-200mm (F3.5-5.6) lens that is designed specifically for digital cameras. The lens attaches to the camera without a problem but I get a flashing "Av" aperture priority signal. The same thing happens with my Pentax ist DL camera. The screen on top of the camera flashes "Av" constantly. Nothing I do seems to remove this Av indicator. Does anyone know why this happens?
Assuming it has one of course.

03-03-2007, 10:08 AM   #5
Loyal Site Supporter




Join Date: Sep 2006
Location: Bronx NY
Photos: Gallery | Albums
Posts: 5,611
isteve beat me to it

QuoteOriginally posted by jdpenk100d Quote
Help! My new Pentax K100D doesn't appear to accept a new Sigma 18-200mm (F3.5-5.6) lens that is designed specifically for digital cameras. The lens attaches to the camera without a problem but I get a flashing "Av" aperture priority signal. The same thing happens with my Pentax ist DL camera. The screen on top of the camera flashes "Av" constantly. Nothing I do seems to remove this Av indicator. Does anyone know why this happens?
First thing I thought was "I'll bet the lens aperture ring isn't set to "A". It's happened to me a couple of times, I'll put the lens on the camera and get the Av flashing, look at the lens and sure enough the lens is off of the "A" setting.

NaCl(check the simple stuff first)H2O
03-03-2007, 06:47 PM   #6
Inactive Account




Join Date: Mar 2007
Location: Frederick, MD USA
Posts: 5
Original Poster
is it a grey market lens?

Thanks for your replies everyone. I bought this lens from Broadway Photo and I'm now suspicious it's a grey market Sigma lens that's incompatible with the new Pentax digital SLR's even though it's advertized as a "digital camera lens". Makes me mad because Broadway didn't advertise it as grey market and I thought the problem was with my old SLR. Now I have an expensive new lens I can't return and I can't use.
03-03-2007, 06:55 PM   #7
Veteran Member
-=JoN=-'s Avatar

Join Date: Nov 2006
Location: NYC
Posts: 1,000
are you 100% sure it's grey?
and regardless of market, it should work, i have lenses back from 1998 from sigma that works fine with the k10. it's a faulty lens, period, even if you put that on an older film body i doubt it will work.

and why cannot you return it to broadway photo?

the digital designation is just an small tweak, it's optimized for digital use, but not specifically made, unlike the DA's
03-03-2007, 08:13 PM   #8
Veteran Member




Join Date: Dec 2006
Location: UK
Posts: 643
"Thanks for your replies everyone. I bought this lens from Broadway Photo and I'm now suspicious it's a grey market Sigma lens that's incompatible with the new Pentax digital SLR's even though it's advertized as a "digital camera lens"

i think u are way off with that one.. i have older sigma film lenses that work perfectly with my k100..

trog

03-04-2007, 01:24 AM   #9
Inactive Account




Join Date: Feb 2007
Location: Adelaide, South Australia, Australia
Photos: Gallery
Posts: 364
If it is a DC Lens it has no aperture ring

What is happening is the electrical contacts are not connecting properly, what you need to do is clean both the lens and body mount.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, dslr, k100d, lens, pentax, photography, sigma
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Pentax K100D Super with Sigma 28-200mm lens - Not working? JSM Graphics Troubleshooting and Beginner Help 3 04-08-2011 09:35 AM
Hello FRIENDS..!! Please accept me in this Pentax FAMILY. Ta. alexthomascv Welcomes and Introductions 3 04-04-2011 10:15 PM
can K-X accept M mount 50mm F1.2? surfmanjoe Pentax DSLR Discussion 8 07-21-2010 03:04 PM
K10D won't accept Pentax-M 135mm prime lens jdpenk100d Troubleshooting and Beginner Help 11 02-19-2009 05:42 PM
lens for pentax K100D Sigma 50mm 2.8 ex macro fevbusch Pentax DSLR Discussion 7 02-04-2007 11:32 AM



All times are GMT -7. The time now is 03:48 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top