Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
10-31-2008, 11:52 AM   #1
New Member




Join Date: Oct 2008
Posts: 2
E-DIAL wheel on PENTAX IST DS help please

hello there
I have the pentax ist ds and having some trouble recently
1. it hapened only once after took shot,
there was no prewiev, and camera froze on display only ---, then after taking bateries out back to normal
BUT the main problem is following
at prewiev when i zoom in it only zooms once and then thats it
also the edial wheel, doesnt let me go to + numbers, it only goes to - and hardly go back to zero.
[B]
So obviosly the wheel e dial (pulse switch) is broken I guess, or anyone has any idea whats wrong?what can b done to repair it? if the whole part needs to b changed?
or anyone has similar trouble?
thank you very much
Martin

10-31-2008, 01:27 PM   #2
Site Supporter
ChipB's Avatar

Join Date: Nov 2007
Location: Austin, TX area
Photos: Gallery | Albums
Posts: 1,641
Might be dirty electrical contacts - get a good quality electrical contact cleaner (one that leaves no residue) and, with the camera off, spray into the wheel area and work the wheel. If the problem was dirty contacts you should be good to go. A LOT less expensive than replacing the switch assembly!!
11-04-2008, 02:21 PM   #3
Site Supporter
Mallee Boy's Avatar

Join Date: Sep 2006
Location: Hindmarsh Isl. Sth Australia
Photos: Gallery | Albums
Posts: 3,490
Ditto to Chip's advice. It works (for awhile), but the problem will come back down the track.
03-25-2009, 03:34 AM   #4
Forum Member




Join Date: Dec 2008
Posts: 92
Hi all,

Sorry for dig up this thread,

My *istDS dial wheel also got sick

I can only dial in one way, mostly to the "zoom out" or minus the parameters, I can not zoom in (in review mode) nor adjust to "Add" the parameters

anybody has the same problem?

Thanks

03-25-2009, 05:53 AM   #5
Forum Member
shiestmiester's Avatar

Join Date: Jul 2008
Location: Buffalo, NY
Posts: 97
Im not sure if this works on istDS, but with my K200 you can use the (it's 2 of these 3 can't remember exactly which) AE lock, green button, EV comp, to zoom in and out in palyback menu.

Not a solution, but a temporary work-around if it's compatible with your body.

Hope the contact cleaner works,

Travis
02-19-2010, 02:08 AM   #6
Veteran Member




Join Date: Jun 2007
Photos: Gallery
Posts: 597
with my K100D, the rear dial is also acting chippy. Instead of adjusting, it jumps around in aperture mode going from f5.6 to f22, then f16 to 2.8 randomly. All this while turning the wheel to the right. If turning to the left, it's worse. I can never shoot now at 2.8 since now that it's stuck at f22, it jumps from f8 to f22 randomly. Any ideas?
02-19-2010, 05:58 AM   #7
Inactive Account




Join Date: Nov 2008
Location: USA
Posts: 924
Use contact cleaner as they said above. The small contact fingers get dirty, due to the camera not being sealed.
07-03-2010, 01:34 AM   #8
Forum Member




Join Date: Jul 2010
Location: Rosenheim, Germany
Posts: 54
K-x e-dial wheel broken

I have just received new K-x. Already on first day I have noticed that e-dial is only changing values to + values. Luckily I can reset to 0 by green button but there is not way how to get to - values.

I am quite surprised that brand new k-x has this kind of problem. If it would be few years old I would say it is dirty, but now?
I have also notice two small paint particles in the camera through view finder. These are in the camera, not in view finder, and luckily not affecting the pictures.

I will contact Pentax to replace the e-dial and clean the camera inside. I have it for two weeks now so I suppose they should repair it in warranty.

07-03-2010, 11:35 AM   #9
Veteran Member




Join Date: May 2009
Location: Twin Cities, MN
Posts: 2,869
QuoteOriginally posted by hramat Quote
I have just received new K-x. Already on first day I have noticed that e-dial is only changing values to + values. Luckily I can reset to 0 by green button but there is not way how to get to - values.

I am quite surprised that brand new k-x has this kind of problem. If it would be few years old I would say it is dirty, but now?
I have also notice two small paint particles in the camera through view finder. These are in the camera, not in view finder, and luckily not affecting the pictures.

I will contact Pentax to replace the e-dial and clean the camera inside. I have it for two weeks now so I suppose they should repair it in warranty.
First day, send it back for a replacement - if you bought out of the country which would make an exchange expensive, get it serviced under warranty - with the *istDS this was a known issue that cropped up only after several years of use. Your K-x is defective, plain and simple!
07-03-2010, 02:42 PM   #10
Forum Member




Join Date: Jul 2010
Location: Rosenheim, Germany
Posts: 54
k-x broken e-dial footage

Here is the footage of the e-dial.


On Monday I will contact Pentax for advice how to proceed
07-04-2010, 01:25 AM   #11
Veteran Member




Join Date: Dec 2007
Posts: 923
From the above video, it Looks like its definitely faulty.
The rear e-dial on my K-7 when awry after about 7 months.
There is a bit of electronic circuitry attached to the E-dial, and that was what had gone faulty, and they replaced it under warranty. The E-dials on the weather-sealed cameras are pretty resistant against dust and moisture, so they are much less likely to get gued up with dirt.

For non-WR cameras, the likelihood of dirt being trapped in there on older cameras is quite high - but contact cleaners are pretty effective at cleaning that up.
07-30-2010, 02:02 AM   #12
Forum Member




Join Date: Jul 2010
Location: Rosenheim, Germany
Posts: 54
QuoteOriginally posted by hramat Quote
On Monday I will contact Pentax for advice how to proceed
E-dial was repaired within one day, most probably only cleaned, without costs. The dial was not replaced. Now it is working well.
12-02-2011, 02:10 AM   #13
Inactive Account




Join Date: Oct 2010
Location: Hanoi
Photos: Gallery
Posts: 2
my Pentax K7 has same to, now i can't change aperture value how to fix it?
12-20-2011, 12:47 PM   #14
New Member




Join Date: Aug 2008
Location: Vancouver-Canada
Photos: Gallery
Posts: 13
I had the same trouble with my 100D and after using the contact cleaner (from suggestions here) it worked for awhile but then reverted back to the problem - cleaned it again and it has been fine for the last 6 months.
12-20-2011, 12:53 PM   #15
New Member




Join Date: Aug 2008
Location: Vancouver-Canada
Photos: Gallery
Posts: 13
Suggestion for Pentax - I have a Blackberry Bold work phone that has a trackpad rather than a wheel or trackball (older versions of BB had these). I think that little track pad would work way better than the edial
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, ds, dslr, pentax, pentax ist ds, photography, trouble, wheel
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Pentax *ist Selection Dial problem unixrevolution Pentax Film SLR Discussion 5 08-10-2010 06:00 AM
Problem with E-dial (or "Jog wheel") on DS: Solved! Syb Pentax DSLR Discussion 10 04-06-2010 07:07 AM
E DIAL on Pentax ist ds broken? help grgo12 Photographic Technique 0 10-31-2008 11:58 AM
*ist D Question - Rear Scroll Wheel carpents Pentax DSLR Discussion 6 06-29-2007 05:54 AM
Pentax ist*DS - Bad rotary dial awjweb Pentax DSLR Discussion 13 03-20-2007 08:42 AM



All times are GMT -7. The time now is 01:35 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top