Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
11-07-2008, 02:10 AM   #1
New Member
breethagh's Avatar

Join Date: Nov 2008
Location: Poland
Photos: Gallery
Posts: 19
K20D Hangs up after shot

Hello.
Im owner of k20d for week now.
I have a problem w/my k20d, and didnt find the answer.
Problem is that camera just hangs up sometimes.
Usualy its just after a power on and make a shot.
If its hang up i get the nr of shots left is on upper lcd, if i shot , pictures are white w/some noise on it.
Only way to resolve the problem is taking battery of the body.
If You heard or had this issue please write a solution.
(i just dont want to strangle with service)
Cheers.
(sorry for bad english)

Adam

--------- edit -------------------------
Im using 2 crappy sd cards but its probably not the problem.
Yes its hangs up in daylight shots but in shadow maybe i didnt remember exactly where.
When k20d hangs up ill try to take next picture and shutter opens for 2 secs
After that i turned k20d off and got pict left counter only when i power it on i got battery metter only.
Nothing work until i eject battery and put battry again.


Last edited by breethagh; 11-07-2008 at 03:52 PM.
11-07-2008, 04:22 AM   #2
Inactive Account




Join Date: Mar 2007
Photos: Gallery
Posts: 3,675
You have a dud!
Send it back!

Good luck.
11-07-2008, 04:38 AM   #3
Pentaxian
Moderator Emeritus




Join Date: May 2007
Location: Edmonton Alberta, Canada
Photos: Gallery | Albums
Posts: 10,648
Haven't heard of this. The shot is at "normal" daylight shutter speeds (faster than 1 second). If these are slow time exposures, the noise reduction will make the camera appear to hang.
Other thing to try is the SD card. Is it possible that the card is defective and causing an issue with the camera trying to write to the card. Do you have a second card to try (good quality brand name card)?

If it's a normal daytime shot, then you should return the camera for a new one.
11-07-2008, 11:26 AM   #4
Veteran Member
jeffkrol's Avatar

Join Date: Sep 2006
Location: Wisconsin USA
Photos: Gallery
Posts: 8,435
QuoteOriginally posted by breethagh Quote
Hello.
Im owner of k20d for week now.
I have a problem w/my k20d, and didnt find the answer.
Problem is that camera just hangs up sometimes.
Usualy its just after a power on and make a shot.
If its hang up i get the nr of shots left is on upper lcd, if i shot , pictures are white w/some noise on it.
Only way to resolve the problem is taking battery of the body.
If You heard or had this issue please write a solution.
(i just dont want to strangle with service)
Cheers.
(sorry for bad english)

Adam
Just to be sure, did you try a different memory card to see if that is the problem?
May just be a write problem to your card.

11-07-2008, 02:13 PM   #5
Site Supporter
Mallee Boy's Avatar

Join Date: Sep 2006
Location: Hindmarsh Isl. Sth Australia
Photos: Gallery | Albums
Posts: 3,490
QuoteOriginally posted by breethagh Quote
Hello.
Im owner of k20d for week now.
I have a problem w/my k20d, and didnt find the answer.
Problem is that camera just hangs up sometimes.
Usualy its just after a power on and make a shot.
If its hang up i get the nr of shots left is on upper lcd, if i shot , pictures are white w/some noise on it.
Only way to resolve the problem is taking battery of the body.
If You heard or had this issue please write a solution.
(i just dont want to strangle with service)
Cheers.
(sorry for bad english)

Adam
Hi Adam,
My K20D had a power on issue which had to be returned and something was replaced.

But I did not have any image issues in the process, as the power on thing started at the beginning of an overseas trip I was able to get around it by just popping the battery door.....and I took over a 1000 shots on that trip.

So if you are having image issues I would be trying another reputable brand card.

Cheers.
11-07-2008, 04:57 PM   #6
New Member
breethagh's Avatar

Join Date: Nov 2008
Location: Poland
Photos: Gallery
Posts: 19
Original Poster
Im using 2 crappy sd cards but its probably not the problem.
Yes its hangs up in daylight shots but in shadow maybe. I didnt remember exactly where.
When k20d hangs up ill try to take next picture and shutter opens for 2 secs
After that i turned k20d off and got pict left counter only when i power it on i got battery metter only.
Nothing work until i eject battery and put battry again.
11-07-2008, 05:25 PM   #7
Site Supporter
Mallee Boy's Avatar

Join Date: Sep 2006
Location: Hindmarsh Isl. Sth Australia
Photos: Gallery | Albums
Posts: 3,490
More issues have been reported that relate to SD cards than anything else. So that is what I would eliminate first.

Having said that what you are saying sounds more an more like the issue I had. Think I would be returning it pronto.
11-07-2008, 06:33 PM   #8
Inactive Account




Join Date: Dec 2006
Location: Winter Springs, FL
Photos: Gallery
Posts: 141
I have noticed that on my K20, if the preview is set to "digital", and if I turn the power switch on aggressively and move it to the "preview" position momentarily, the camera will seem to hang up when I shoot the first pic. I power it off and it takes a few seconds to turn off. I now have the preview mode set to optical, ie, you have to look into the viewfinder to check depth of field.
Maybe you did something like that by accident??

Walt

11-07-2008, 07:06 PM   #9
New Member
breethagh's Avatar

Join Date: Nov 2008
Location: Poland
Photos: Gallery
Posts: 19
Original Poster
I bought this dslr 30.10 mornig aftrernoon i was in egipt, so there was no way for fast reclamation.
In a way to airport it start hanging.
It hangs sometimes , but now this happend few times in a row,
and this is happen in night home light but i turned off iso noise reduction.

This is picture from another user with same problemK20d/SanDisk Extreme III 4GB SDHC.
Almost same thing is with 2g exIII


Im going to buy a card tommorow and do some tests. If i get still this bug i will go to the serivice.

Thanks for help.
Attached Images
   

Last edited by breethagh; 11-07-2008 at 07:16 PM.
11-08-2008, 07:01 PM   #10
Site Supporter
SA Photo's Avatar

Join Date: Mar 2008
Location: Virgina
Posts: 122
QuoteOriginally posted by breethagh Quote
I bought this dslr 30.10 mornig aftrernoon i was in egipt, so there was no way for fast reclamation.
In a way to airport it start hanging.
It hangs sometimes , but now this happend few times in a row,
and this is happen in night home light but i turned off iso noise reduction.

This is picture from another user with same problemK20d/SanDisk Extreme III 4GB SDHC.
Almost same thing is with 2g exIII


I'm going to buy a card tommorow and do some tests. If i get still this bug i will go to the serivice.

Thanks for help.
My K20d has the exact same problem as you are having. Lots of post here on the forum about this. I called Pentax and they were not aware of the problem or would not admit to it. I tried different batteries and cards with the same results. I have never had a problem with my K10D but this issue seems pretty common with the K20. I'm sending it back after the holidays.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
battery, camera, didnt, dslr, im, k20d, photography, power, shot, shots
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Rolling Shot: K20D + Pentax DA 18-250mm F3.5-6.3 choiboi Post Your Photos! 11 05-27-2013 01:10 AM
Nature First shot on my K20D NicK10D Post Your Photos! 9 06-06-2010 01:50 PM
Problem: K20D all-green shot slyfox Pentax DSLR Discussion 11 05-25-2010 10:23 AM
Κ7 And K20D Test Shot. SpartanWarrior Pentax DSLR Discussion 6 08-29-2009 01:01 PM
First K20D shot - Wells Cathedral, UK simonkit Post Your Photos! 1 07-09-2009 04:50 PM



All times are GMT -7. The time now is 12:31 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top