Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
11-13-2008, 06:27 PM   #1
Senior Member
trd300gt's Avatar

Join Date: Jun 2008
Location: Tustin, CA
Posts: 206
Strange *ist ds behavior

I got an interesting story about my *ist ds. So yesterday, I had my Sigma 28mm on, and wanted to switch to my telephoto (Tamron adaptall-2 80-210mm). So I switched lenses, and then turned the camera back on, and the shutter wouldn't fire. The little green viewfinder displays wouldn't light up, but all the menus and stuff worked (also, the command dial wouldn't work). Also, whenever I pushed any buttons, the camera would make a faint click/shuddering sound.

I put the Sigma back on, and switched between auto and manual focus, and took the batteries out and everything, but alas, nothing happened.

I remembered reading somewhere about other people's cameras behaving similarly, and in general it involved low batteries. I charged up my batteries and put them in, and same problem.

Finally, I was ready to reflash the camera's firmware, but decided to just stick on my Pentax F 50mm. All of a sudden, the camera started working fine. I put the Sigma back on, and it was working fine.

I guess my *ist ds missed it's Pentax brethren.

Anyways, I just wanted to share my story and see if anyone else had similar issues.

11-14-2008, 04:53 AM   #2
Veteran Member
palmor's Avatar

Join Date: Dec 2006
Location: North of Boston, MA
Posts: 798
Maybe you had a little dirt or something on the contacts and it just happened that putting the 50mm on cleared what ever was there? Other then that maybe camera gremlins


John
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
*ist, *ist ds, batteries, camera, ds, dslr, fine, pentax, photography, sigma, story
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Strange behavior from Tele-Takumar 300mm straightshooter Pentax SLR Lens Discussion 6 06-06-2010 05:56 AM
Odd behavior THAN THE SWORD Pentax DSLR Discussion 2 09-10-2009 05:36 AM
Matrix metering strange behavior... dlacouture Pentax DSLR Discussion 20 01-22-2009 08:20 AM
Strange K10D + Pentax 18-250 behavior henzo Pentax DSLR Discussion 1 06-03-2008 05:54 PM
K100d built in flash: strange behavior Rafael Pentax DSLR Discussion 5 12-17-2007 03:02 PM



All times are GMT -7. The time now is 09:58 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top