Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
12-14-2008, 10:00 AM   #1
New Member




Join Date: Dec 2008
Location: Southampton, UK
Posts: 2
K110D unable to take photos!

Hi there,

I am in need of help with my K110D, which will no longer take photos. All that happens when the camera is turned on, no matter which lens I use, is the LCD display flashes 'Av --' continuously. I have tried resetting the camera back to factory settings and have changed the lens over but to no effect.

Does anybody know what the problem is? Any help would be much appreciated as this camera provides me with my main source of income in the summer as a watersports photographer.

Many Thanks,

Nick Tayler

12-14-2008, 02:01 PM   #2
Ole
Administrator
Ole's Avatar

Join Date: Sep 2006
Location: Copenhagen, Denmark
Photos: Gallery | Albums
Posts: 3,793
If you use lenses with an aperture ring make sure that you set the ring to the "A" position.

If the aperture ring has no "A" position then you must change a setting in the custom menu to allow the use of an aperture ring.
12-14-2008, 03:35 PM   #3
New Member




Join Date: Dec 2008
Location: Southampton, UK
Posts: 2
Original Poster
Thanks for the tip, but it doesn't seem to help at all. Another problem I've recently noticed is that the mode wheel no longer does anything either, I'm beginning to think it may be time for a new body...
12-14-2008, 03:40 PM   #4
Site Supporter
ChipB's Avatar

Join Date: Nov 2007
Location: Austin, TX area
Photos: Gallery | Albums
Posts: 1,521
Nick, try changing the batteries and the memory card - they each can cause strange problems. Good Luck!

12-14-2008, 03:40 PM   #5
Loyal Site Supporter
Canada_Rockies's Avatar

Join Date: Nov 2007
Location: Sparwood, BC, Canada
Photos: Gallery | Albums
Posts: 9,148
QuoteOriginally posted by nicktayler Quote
Thanks for the tip, but it doesn't seem to help at all. Another problem I've recently noticed is that the mode wheel no longer does anything either, I'm beginning to think it may be time for a new body...
First, take out the batteries and leave the camera over night. I got weird effects on my k10d recently, and following tips from others on this forum, I left the batteries out overnight, and the camera was magically "fixed".
03-15-2009, 02:57 PM   #6
New Member




Join Date: Mar 2009
Location: New Hampshire
Posts: 1
K110D problem: any solutions?

I'm having the same problem, and I've tried the batteries out thing,and it still doesn't work. Sometimes the camera will take pictures, but most of the time it doesn't. Any more suggestions? I got this camera because my last pentax broke on me in New Zealand and they said they had fixed it under the warranty, but when i got it back it was still broken.

Also, sometimes, if the camera will take pictures, the shutter will stay open and then i have to take the batteries out of it to get it to close the shutter, and it won't save any pictures if that happens during a burst mode set.


thanks for any help,
alex
03-16-2009, 11:40 AM   #7
Pentaxian
Marc Sabatella's Avatar

Join Date: Sep 2006
Location: Denver, CO
Photos: Gallery
Posts: 10,686
Assuming you've also verified your aperture ring (if present) is on the "A" position, next step would be to try cleaning the contacts between the lens and camera.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, dslr, help, k110d, lens, photography
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Unable to control aperture heasley Pentax SLR Lens Discussion 16 05-30-2010 01:55 AM
Unable to fire azngirlLH Troubleshooting and Beginner Help 8 03-03-2010 05:16 PM
Error Unable to submit lens review Mechan1k Site Suggestions and Help 10 11-29-2009 01:42 PM
Error Unable to create new threads deadwolfbones Site Suggestions and Help 8 11-24-2009 11:36 AM
Error Unable to view feedback Kguru Site Suggestions and Help 3 05-05-2008 04:18 PM



All times are GMT -7. The time now is 01:45 PM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top