Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
01-05-2009, 08:55 AM   #1
Inactive Account




Join Date: Nov 2008
Location: Vietnam
Photos: Gallery
Posts: 13
*ist D and M42

I open this thread because can not get the right solution for my *ist D and M42.

I am using *ist D and has 3 M42 with non-flange M42-K mount. The lens fix on body without any problem accept the body can not focus indicating. I have try with many way
- Set CF with "F Stop other than A" on
- Tape the pin on body in full, only 2 rest.
- Change M42 lens. Small not cover the pins, bigger cover the pins...
and the body still no focus indicating... Any body have the advice on this issue?

01-05-2009, 12:37 PM   #2
Veteran Member
Mike Cash's Avatar

Join Date: Jan 2007
Location: Japan
Photos: Gallery
Posts: 6,952
Is there a menu setting that looks like "FI with S lens"? If there is, enable it. (Focus Indication with Screwmount lens").
01-05-2009, 04:57 PM   #3
Inactive Account




Join Date: Nov 2008
Location: Vietnam
Photos: Gallery
Posts: 13
Original Poster
@Mike Cash: thanks for your information but this body doesn't have this setting - I guess it replace by "F stop other than A" in CF.
01-06-2009, 05:37 PM   #4
Pentaxian
Lowell Goudge's Avatar

Join Date: Jan 2007
Location: Toronto
Photos: Gallery | Albums
Posts: 15,399
I believe the problem is that many M42 lenses do not have a wide enough base to short the focus information pin, furthest away from the lens locking pin on the mount, to the lens mount. With this pin left unconnected the camera thinks it has an AF lens and the wrong distance. Some people have suggested shorting the pin to the nount with tin foil and this makes it work. I simply live with it. I am considering getting a split image anyway for manual focus lenses

01-06-2009, 05:46 PM   #5
Inactive Account




Join Date: Dec 2008
Location: Ames, Iowa, USA
Photos: Albums
Posts: 2,965
Use aluminum foil to short the contacts on the body mount. The paint on the m42 is preventing electrical contact so the camera doesn't know the lens is there most likely.

If that works, you might remove the paint from the right location on the m42 lens.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
*ist, body, camera, dslr, focus, lens, m42, photography
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
*ist D + M42 and M Lenses? Dubesor Pentax DSLR Discussion 4 05-22-2010 04:49 AM
m42 adapter for Pentax ist *DL muzscman Pentax Camera and Field Accessories 5 01-11-2010 05:47 PM
Cheap flash for Pentax *ist DS with M42 lens? iht Troubleshooting and Beginner Help 11 08-24-2009 08:57 PM
*ist ds & m42 lenses frugal Pentax DSLR Discussion 4 07-28-2008 04:27 PM



All times are GMT -7. The time now is 07:08 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top