Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
02-07-2009, 01:26 AM   #1
New Member




Join Date: Feb 2009
Location: Toowoomba, Australia
Posts: 24
Error message when old SMC pentax 50mm f1.4 lense is attached to k20d

I have a question. My grandfather has an old pentax km series slr and attached to it was a SMC pentax 50mm 1.4 lense which i tried to attach it to my new pentax k20d but all i got was the error F----.

Does anyone out there know what I have to do to fix the problem?

Is it that the lense although mounts correctly to the k20d is still incompatible? Is it a setting in the camera? or something i need to change before it will accept the old lense?

Thank you in advance for any suggestions


Heidi

02-07-2009, 01:36 AM   #2
Loyal Site Supporter
Loyal Site Supporter
monochrome's Avatar

Join Date: Mar 2008
Location: Kirkwood (St. Louis) MO
Photos: Gallery | Albums
Posts: 20,455
QuoteOriginally posted by InKeepingSecrets Quote
I have a question. My grandfather has an old pentax km series slr and attached to it was a SMC pentax 50mm 1.4 lense which i tried to attach it to my new pentax k20d but all i got was the error F----.

Does anyone out there know what I have to do to fix the problem?

Is it that the lense although mounts correctly to the k20d is still incompatible? Is it a setting in the camera? or something i need to change before it will accept the old lense?

Thank you in advance for any suggestions


Heidi
First, go into the menus and find "enable aperture ring = yes" (I think this is toward the end of setup on the K20D, but you can find where in your user manual). Then you can use the lens (shutter will release).

Your camera will never display the lens info such as aperture because the lens doesn't have the electrical contacts on the lens mount to communicate with the camera electronics.

F--- is normal.
02-07-2009, 01:52 AM   #3
Veteran Member




Join Date: Jan 2009
Location: Canada
Posts: 1,255
QuoteOriginally posted by InKeepingSecrets Quote
I have a question. My grandfather has an old pentax km series slr and attached to it was a SMC pentax 50mm 1.4 lense which i tried to attach it to my new pentax k20d but all i got was the error F----.

Does anyone out there know what I have to do to fix the problem?

Is it that the lense although mounts correctly to the k20d is still incompatible? Is it a setting in the camera? or something i need to change before it will accept the old lense?

Thank you in advance for any suggestions


Heidi

After you allow for the aperture ring to be used, if the lens doesn't have an "A" setting on the aperture ring, use Manual mode and press the green button to set the correct exposure, i.e., the camera will automatically set the shutter speed depending on your ISO and aperture ring setting. You can even use the built-in flash: set the aperture to (approx.) guide number (which is in your manual) / distance from subject in meters. Have fun.

EDIT: BTW, the focus confirmation hexagon still works.
02-07-2009, 02:01 AM   #4
New Member




Join Date: Feb 2009
Location: Toowoomba, Australia
Posts: 24
Original Poster
Thank you so much! It worked perfectly... of course! I'm really happy about this since now i perfectly good free lense.

02-07-2009, 04:04 AM   #5
Veteran Member
ve2vfd's Avatar

Join Date: Aug 2007
Location: Montreal, Canada
Photos: Gallery
Posts: 2,433
Ahhhh free lenses! You know those are the best kind!!!

Pat
02-07-2009, 05:16 AM   #6
Site Supporter
Site Supporter
pschlute's Avatar

Join Date: Mar 2007
Location: Surrey, UK
Photos: Gallery
Posts: 1,248
QuoteOriginally posted by InKeepingSecrets Quote
Thank you so much! It worked perfectly... of course! I'm really happy about this since now i perfectly good free lense.
A very good lens indeed
02-08-2009, 03:37 AM   #7
New Member




Join Date: Sep 2006
Location: South West Germany
Posts: 14
Congrats, you have one of the best 50s ever made!
02-08-2009, 02:29 PM   #8
Inactive Account




Join Date: Mar 2008
Location: Dallas Texas
Posts: 319
If anyone wants a cheap 50mm F 2.0 lens, go to EBAY and search for ANY K1000. Someone selling a broken one is best (you don't want the camera anyway..right?) You might be able to getting the winning bid at $40.00 or less, I got mine for $25.00 and resold it for $75.00 to help pay for the DA 50mm I have today. People who search for just the lens, don't get the best deals, look for "the package" broken camera or not, it's the clean lens that counts.

Barry

07-17-2009, 05:31 PM   #9
New Member




Join Date: May 2008
Location: NYC
Posts: 19
WooT! I just got this same problem and did a search and lo and behold the question has been asnswered. Worked for me thanks alot!
04-19-2012, 10:20 PM   #10
New Member
EbisuHapa's Avatar

Join Date: Feb 2012
Location: Tokyo
Posts: 19
Error "F---" Thank you from 2012~

Old thread but thanks for the person who posted the remedy to the "F---" lens error... thought something was wrong with the camera itself until I came up on this thread. Much appreciated from 2012
04-24-2012, 06:09 PM   #11
Junior Member
JCharles's Avatar

Join Date: Nov 2008
Location: Bridgeport, CT
Posts: 26
It pays to learn how to work the older lenses. They are built to last and work well.
04-24-2012, 06:38 PM   #12
Pentaxian
Arjay Bee's Avatar

Join Date: Sep 2006
Location: Bamaga, QLD
Photos: Gallery | Albums
Posts: 3,057
I am just wondering how many lenses the original poster now has three years on - (or alternately how many old bodies)
04-29-2012, 09:41 AM   #13
Forum Member




Join Date: Nov 2011
Posts: 52
LOL, Over the years (decades) after buying K-mount sets just for the lenses alone. There are probably 40 plus bodies in our Cabinet. If anyone needs one for parts or replacement just send a PM. But oh! the lenses I have seen and sold. Best of all I have arrived at the cream of the crop. And a wife that wants to shoot me every time I walk in the door with a camera bag from a tag or garage sale. Having never really spent more than 50 dollars for any of the sets but the norm is around 15~20 dollars.
A few moths ago a $4,500 lens was acquired on the real cheap end. We rent that one out now and then (to Pro's) for a couple a hundred bucks a shoot. The advent of the digital body has been a boon for outstanding glass.

Last edited by pento57mm; 04-29-2012 at 09:47 AM.
07-09-2014, 04:20 AM   #14
New Member




Join Date: Dec 2008
Location: Oslo, Norway
Photos: Gallery
Posts: 2
QuoteOriginally posted by monochrome Quote
First, go into the menus and find "enable aperture ring = yes" (I think this is toward the end of setup on the K20D, but you can find where in your user manual). Then you can use the lens (shutter will release).
Thank you so much!! I had the same issue with a XR Rikenon (non-P) 50/2. After enabling "Custom Setting - Using aperture ring = 2 (Permitted; Pictures can be taken even when aperture ring position is other than A)", the "F--" error was still in the display, but the shutter responds. I was about to open the XR Rikenon up and "modify" the aperture pin. So many menus in DSLR when used to SLR...
Cheers
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
50mm, camera, dslr, error, error message, k20d, lense, pentax, pentax 50mm f1.4, photography, smc, smc pentax 50mm
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Pentax k-x '' card error '' message crossing Pentax DSLR Discussion 4 01-13-2010 01:17 PM
error message after viewing card kiwibird Troubleshooting and Beginner Help 3 12-31-2009 03:29 AM
PLEASE HELP!!! error msg when old lens attached BUBBLEE Troubleshooting and Beginner Help 9 04-22-2009 08:17 AM
Need Help...Error Message on K200D 68wSteve Pentax DSLR Discussion 7 04-05-2009 01:47 PM



All times are GMT -7. The time now is 12:00 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top