Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
02-13-2009, 09:44 AM   #1
Inactive Account




Join Date: Sep 2008
Location: Southeastern USA
Posts: 75
Opinions on Pentax USA Service Question

Hello all!

I recently sent in my K10D for warranty autofocus system adjustment. I did this the first week in January of this year because my warranty was up on January 30.

When returned, Pentax USA had installed 1.3 firmware and 8.1 system control firmware. Alright! Now we are cooking!

I began using all of my autofocus lenses and with a minor debug adjustment they performed virtually perfectly. Autofocusing was spot on - near 100% in focus if careful to place the sensor spot(s).

But, and here is the rub, manual focus as far as focusing using the focusing screen was WAY off with lenses faster than f/2.8. A 1.4 Nokton was the first to show me what was happening with manual focus.

Before this service, manual focus was always near perfect while AF was weak. Now vice versa.

The good thing is that the green hexagon gives my manual focusing great accuracy - and I can "manually focus" using the indicator just fine. After all, the green hexagon uses the cameras AF system.

Would you want the viewfinder image to be focusable on screen if it were you? Or would the AF hexagon indicator be enough for you? It really does work VERY well.

It just seems so different than my 30+ years experience with photography...

TIA

02-13-2009, 09:59 AM   #2
Veteran Member




Join Date: May 2007
Location: Somerset, UK
Photos: Gallery
Posts: 629
how can af affect manual focus? you just turn the ring!?
02-13-2009, 11:27 AM   #3
Inactive Account




Join Date: Sep 2008
Location: Southeastern USA
Posts: 75
Original Poster
QuoteOriginally posted by dopeytree Quote
how can af affect manual focus? you just turn the ring!?
Maybe I wasn't clear.

Yes you DO "turn the ring" to manually focus.

At which point you choose to stop "turning the ring" determines the focus point.

For 30 years I chose to stop "turning the ring" when the image ON THE FOCUSING SCREEN displayed the point at which I wanted focus to be in the shot.

This image from the screen at its visual sharpest is no longer what the camera records as focus. Due to some adjustment problem IN THE CAMERA it displays something different than what is recorded - a problem, no?

The AF system in the K10D is still functional while manually focusing. The green hexagon indicates WHAT THE AF SYSTEM determines is the correct focus. On my camera this is very accurate as compared to what the camera records. This is now my only choice for accurate focusing with manual focus lenses, especially fast lenses...

The green hexagon AF indicator is now my only way of determining correct manual focus since the screen image is no longer accurate or reliable.

For those who understand, what do you think? Would you send it back?

Last edited by Inspector 17; 02-13-2009 at 11:42 AM.
02-13-2009, 11:33 AM   #4
Veteran Member




Join Date: May 2007
Location: Somerset, UK
Photos: Gallery
Posts: 629
have you checked the diopeter thing the thing above the viewfinder? That's the only thing I can think of that may make a difference. I don't see how doing firmware ajustments can have any hardware difference to focus. All focus ajustment does it ajust the autofus by a few points but this is only for autofocus not manual as manual makes no use of electric use so no need to adjust the point of focus by a few points etc if that makes any sense?

Other thing is maybe they messed up the focus screen or something?

Do you have any samples?

02-14-2009, 06:48 AM   #5
Inactive Account




Join Date: Sep 2008
Location: Southeastern USA
Posts: 75
Original Poster
Pentax service could have adjusted the mirror assembly, the entire viewfinder assembly, or possibly even inadvertently moved the position of the screen.

As for how this problem shows itself, I was shooting a few dozen portraits last weekend. With the manual lens (Voigtlander Nokton), I focused on the closest eye USING THE FOCUSING SCREEN. The plane of focus in these captures was back around the ear with the eye well out of focus.

When I popped on the 77 Limited and began using autofocus, AUTOFOCUS was spot on. Great shots except for a couple of these where I focused using the screen.

The only way I can accurately use a fast lens now is NOT to use the focusing screen but instead use the green hexagon, which uses the autofocus system to determine focus. I think a fast lens will exhibit any screen/viewfinder misplacement much more than a slower lens.

Maybe someone knows a fix for focusing screen misalignment/misplacement? or should I heave expected this not to arise after Pentax service and ask them to fix this?

These kinds of focusing issues are what makes me leary of my choice to go with Pentax. When I see images from the Pentax glass I become reassured again. But...
02-14-2009, 06:54 AM   #6
Veteran Member




Join Date: May 2007
Location: Somerset, UK
Photos: Gallery
Posts: 629
Have you tried manual focusing on other lenses too such as the 77 limited? just to double check?

Have you checked at different apertures etc?

When the 77 limited autofocuses is it sharp in the view finder? as from what you've said above I imagine it should be slightly out of focus? due to the alignment difference.

I understand what your saying I'm just trying to eliminate all possibilities.

I'd ring them up and explain, get them to take a look and fix it for free as it was fine before.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
af, camera, dslr, firmware, focus, hexagon, indicator, lenses, photography, screen, system
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Pentax Customer Service mel Pentax DSLR Discussion 90 12-16-2011 06:03 PM
Pentax Customer Service? szbrozek General Talk 0 03-07-2008 05:19 AM
Pentax Service... Tom Lusk Photographic Technique 2 02-02-2008 08:31 AM
NYIP question...opinions wanted!!! Inspection Guy General Talk 6 10-08-2007 07:48 AM
Pentax Expedite Service codiac2600 Pentax DSLR Discussion 4 06-07-2007 11:42 PM



All times are GMT -7. The time now is 02:39 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top