Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
03-17-2009, 05:30 PM   #16
Veteran Member
enoxatnep's Avatar

Join Date: Nov 2008
Location: The edge of nowhere, Alberta, Canada
Photos: Gallery | Albums
Posts: 467
I shipped my K20D back to Pentax Canada this morning. The first freeze-up was a little irritating, but the second one three months later convinced me that this is not normal. I'm not waiting for the third freeze-up to occur after the warranty is expired.

Good on you, hoghead, for deciding to send yours in. And sarka ("I've spent an insane amount of time trying to correlate all of this"), no offence, but I can't for the life of me figure out why you didn't exchange/send yours in for repair after the first week!

03-17-2009, 08:11 PM   #17
New Member
sarka's Avatar

Join Date: Jan 2009
Location: Seward, Alaska
Posts: 22
K20D freeze

Because I have a pathological need to know how and why something isn't working - in detail. Makes me a good technician and teacher. And since I have a three year warranty, other cameras, and it will take longer and be more expensive to send it from this liitle town in Alaska, I'm in no rush.
Further details: the most common denominator seems to be the Shake Reduction. For two days now, as long as I leave shake reduction off I've had no lockup.
03-20-2009, 12:24 PM   #18
New Member
sarka's Avatar

Join Date: Jan 2009
Location: Seward, Alaska
Posts: 22
Sent it out yet?

Hi Hoghead,

Have you sent your k20d out yet, I'm getting ready to pack it up this weekend. have to rely on the G10 for a while.
03-20-2009, 12:36 PM   #19
Site Supporter
SA Photo's Avatar

Join Date: Mar 2008
Location: Virgina
Posts: 121
QuoteOriginally posted by sarka Quote
Hi Hoghead,

Have you sent your k20d out yet, I'm getting ready to pack it up this weekend. have to rely on the G10 for a while.
No, not yet. I want to make sure I don't have a wedding to shoot. Don't want to be without two cameras just in case of problems.

03-20-2009, 10:56 PM   #20
Site Supporter




Join Date: Jul 2008
Location: Detroit MI, USA
Posts: 502
QuoteOriginally posted by OPTMEKX& Quote
no such problem for me, it happen once but I change the SD card and all is well since then.

cheers,

rene
I wonder if this is not the root cause of all problems reported here. A lot of SD/SDHC cards are rated for high speed class 6 but they vary so much in quality. For example my San-disk class 4, 4G SDHC card is way faster than many class 6 cards in my K20 and past GX10. The K20 is very demanding on the card.

Has everyone here used a very high quality name brand such as San-disk? It sounds like it could be write problems to the SD/SDHC cards IMO.
03-21-2009, 05:27 AM   #21
Veteran Member
palmor's Avatar

Join Date: Dec 2006
Location: North of Boston, MA
Posts: 798
Wow, I am an early K20 adopter and I've never had this issue (and I go out for hours at a time shooting wildlife). I hope you guys find the root of the problem!




John
03-21-2009, 06:50 PM   #22
New Member
sarka's Avatar

Join Date: Jan 2009
Location: Seward, Alaska
Posts: 22
Sent it in

mailed the camera today with as much documentation of the problem as I could. We shall see what the result is.

In the end, the most consistent thing I could find about the problem was that when the camera would freeze I could hear the Shake Reduction buzzing away - even if SR was turned off.

At least I will be better focused on work for the next few weeks, with the demon camera out of my reach .
03-21-2009, 07:03 PM   #23
New Member
sarka's Avatar

Join Date: Jan 2009
Location: Seward, Alaska
Posts: 22
To James:
I had tried it with everything from a cheap ebay 4GB to a Sandisk Extreme III 8GB from Best Buy.
The problem would occur even if *no* memory card was inserted so it seems unrelated.

03-21-2009, 10:44 PM   #24
Veteran Member
enoxatnep's Avatar

Join Date: Nov 2008
Location: The edge of nowhere, Alberta, Canada
Photos: Gallery | Albums
Posts: 467
QuoteOriginally posted by sarka Quote
To James:
I had tried it with everything from a cheap ebay 4GB to a Sandisk Extreme III 8GB from Best Buy.
The problem would occur even if *no* memory card was inserted so it seems unrelated.
You're probably right, because when I asked if I should include my memory card with my K20D before sending it in to Pentax Canada, the service rep told me that wasn't necessary, but they wanted me to send in both of my camera batteries instead. (For the record, I use the Sandisk Extreme III 8GB, 30 MB/s Edition.)
03-22-2009, 05:19 AM   #25
Site Supporter
SA Photo's Avatar

Join Date: Mar 2008
Location: Virgina
Posts: 121
QuoteOriginally posted by sarka Quote
mailed the camera today with as much documentation of the problem as I could. We shall see what the result is.

In the end, the most consistent thing I could find about the problem was that when the camera would freeze I could hear the Shake Reduction buzzing away - even if SR was turned off.

At least I will be better focused on work for the next few weeks, with the demon camera out of my reach .
Did they give you a time frame on repair time?
03-24-2009, 04:02 PM   #26
New Member
sarka's Avatar

Join Date: Jan 2009
Location: Seward, Alaska
Posts: 22
repair time unknown

Hoghead,

Nothing to report yet on how long a fix might take. I might give them a call later this week. Even with Priority USPS it will take a few more days to get there from this little Alaska town.

I'm hoping for great news (an easy fix) and a fast turnaround but expecting the worst - slow turnaround and a message saying "no problem found, cleaned sensor", but that's my pessimistic self showing.
03-30-2009, 11:34 AM   #27
New Member
sarka's Avatar

Join Date: Jan 2009
Location: Seward, Alaska
Posts: 22
Hoghead -
Pentax responded to an email and let me know the camera was received on March 27th and that there was a typical turnaround time of 15 to 20 business days.

Luckily, I have ordered a K10D as backup that should arrive tomorrow.
And, crazy as this may sound, I got a fantastic deal on a brand new GX20 that should arrive today - so Pentax can take their time and do the job right and it won't bother me at all!
03-30-2009, 11:46 AM   #28
Site Supporter
SA Photo's Avatar

Join Date: Mar 2008
Location: Virgina
Posts: 121
Man,

I'd really hate to be without my K20 for three weeks at this time of year!
04-02-2009, 04:49 PM   #29
New Member
sarka's Avatar

Join Date: Jan 2009
Location: Seward, Alaska
Posts: 22
Pentax repair turnaround?

enoxatnep,

Have you had any information about your repair or turnaround time?
04-14-2009, 06:20 PM   #30
New Member
sarka's Avatar

Join Date: Jan 2009
Location: Seward, Alaska
Posts: 22
18 days round trip

Sent the camera on march 27 and got it back today, April 14.

It seems to be working well, no freeze up in the first couple of hours (which is longer than it has ever gone before without a problem) and the focus is noticeably better.

There is a heavy gouge or smudge on the focusing screen - very annoying.

the note sent back with the camera states that "Replacement of printed circuit boards and/or image sensor. adjust and calibrate all circuits for proper function.

Replaced CCD."
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
battery, camera, dslr, iso, photography
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
K20 "Memory Card Full" Error message FHPhotographer Pentax DSLR Discussion 2 02-10-2012 10:22 AM
Tripod problem / user error sterretje Pentax Camera and Field Accessories 8 05-18-2010 06:43 PM
AF-360FGZ defect or user error? Panache Pentax Camera and Field Accessories 21 11-05-2009 06:44 AM
K20 User Manual nulla Pentax DSLR Discussion 5 08-05-2008 04:54 PM
Firmware bugg, or user error? Gimbal Pentax DSLR Discussion 1 04-05-2007 01:13 PM



All times are GMT -7. The time now is 06:18 AM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top