Forgot Password
Pentax Camera Forums Home
 

View Poll Results: How often has your K20D frozen up?
It never has 5789.06%
It has once or twice 34.69%
It has a few times (3-5 times) 11.56%
It has many times (more than 5 times) 34.69%
Voters: 64. You may not vote on this poll

Reply
Show Printable Version Search this Thread
04-15-2009, 02:29 AM   #46
Veteran Member




Join Date: Sep 2007
Location: Melbourne
Posts: 602
QuoteOriginally posted by steve147 Quote
... a couple of black ones but mostly it locks after taking an image and that image does not get to the card.
The top LCD flashes and then its either the battery icon or as you say amount of shots and the main LCD is black.
Removing the battery clears it and i can take images as normal until it happens again,...
My K20D has the same issue.

04-15-2009, 02:55 AM   #47
Junior Member




Join Date: Nov 2008
Location: Taunton, UK
Posts: 48
I have had a situation like this on the K10D. I put it down to poor battery contacts. No one has suggested cleaning the battery contacts!
04-15-2009, 03:50 AM   #48
Inactive Account




Join Date: Apr 2009
Location: uk
Posts: 14
Hi enoxatnep
Pleased to hear you got your camera fixed and i hope it stays that way, i
presume it was on waranty which is lucky.
I just contacted a Pentax repairer not far from me and they dont do the K2Od
yet but they said if it was a board replacement for K10 for example
it would cost upwards of 150.
A lot of money to add on to the cost of the camera :-(
I may have forgotten to mention battery contacts in my other posts but i did clean mine but nothing changed and i was not surprised.
04-16-2009, 09:44 AM   #49
Inactive Account




Join Date: Aug 2008
Location: No(r)way
Photos: Gallery
Posts: 179
QuoteOriginally posted by enoxatnep Quote
I guess since I started this thread, I should let everyone know that I sent my K20D to Pentax Canada for repair and the pickslip they sent back with the camera said "circuit replaced". In only the few days I've used it since it has returned, there have been no problems, although I only had two freeze-ups over a 3-month period before I sent it in.
Have you tried to use cheap chineese batteries and a cheap memory card?


My K20D went "wacko" today. It froze all the time. Made wierd noises and vibrations. I tried to turn off the SR, but it froze.
I have just sent the camera in for repair.

When I said the camera produced white images with pink stripes, the man in the camera store said Pentax know about the problem.

This is a production failure, Pentax should fix cameras with this problem. With or without receipt.

Steve147, spam Pentax with mails regarding your problem. Someone will respond... maybe?

04-16-2009, 09:04 PM   #50
Veteran Member
enoxatnep's Avatar

Join Date: Nov 2008
Location: The edge of nowhere, Alberta, Canada
Photos: Gallery | Albums
Posts: 467
Original Poster
QuoteOriginally posted by NorthPentax Quote
Have you tried to use cheap chineese batteries and a cheap memory card?
I've always used Pentax batteries and a top-of-the-line memory card. Not sure what caused the freeze-ups other than a buggered-up circuit board. But again, a week after getting it back, so far so good.
04-17-2009, 01:23 PM   #51
New Member
breethagh's Avatar

Join Date: Nov 2008
Location: Poland
Photos: Gallery
Posts: 19
Hello.
I wonder is pentax serial numbers are shared with region export.

I got SN started with 9****** black numbers on white sticker, i bought mine in internet shop and im wondering if its imported one from US, Canada r Asia.
In Europe i saw in shops expositions K20D with Black sticker grey/white numbers started with 2******.

If someone be so kind and check his SN and post here, not all SN ofc but only start nr for example.
04-18-2009, 03:08 AM   #52
Inactive Account




Join Date: Apr 2009
Location: uk
Posts: 14
Mine is a thin black sticker with white numbers and it starts
275****
Not sure where it came from as it was second hand but i suspect
it was the UK.








QuoteOriginally posted by breethagh Quote
Hello.
I wonder is pentax serial numbers are shared with region export.

I got SN started with 9****** black numbers on white sticker, i bought mine in internet shop and im wondering if its imported one from US, Canada r Asia.
In Europe i saw in shops expositions K20D with Black sticker grey/white numbers started with 2******.

If someone be so kind and check his SN and post here, not all SN ofc but only start nr for example.
04-22-2009, 02:52 AM   #53
Inactive Account




Join Date: Apr 2009
Location: Estonia
Posts: 3
My K20D - bought new last April - has had the freezing problem from the day after I got it. It's the exact same issue: suddenly the buttons won't work, turning it off displays the battery indicator on the top LCD, and only popping the battery out and in again resolves the issue. It can be fine for weeks but can also happen several times during one day.

I haven't got white pictures with pink stripes, but I've had several completely pink (both lighter and darker pink) images.

I handed it in for warranty repair work in January, and when I got it back, it was claimed the problem had been solved by installing new firmware. It worked fine for a couple of months, but the last time I went out with it, the same thing happened again. It's really a bit annoying, but it's good to know it's not just me, then.

For the record, I've been using the Pentax original battery (no grip) and Silicon Power SD cards (have tried several, doesn't seem to matter).

04-23-2009, 12:45 PM   #54
New Member




Join Date: Apr 2009
Location: Ukraine
Posts: 2
QuoteOriginally posted by Cicak Quote
3000+ frames since December '08 and not one problem. In brief, I love this camera!
What SD-Card do you use?
04-23-2009, 01:04 PM   #55
New Member




Join Date: Apr 2009
Location: Ukraine
Posts: 2
QuoteOriginally posted by Kribu Quote
For the record, I've been using the Pentax original battery (no grip) and Silicon Power SD cards (have tried several, doesn't seem to matter).
Do you tests same SD-cards or different type?

I have been testing Kingston SDHC 4G - hangs after 15-20 shoots
Trancsend SDHC 4G - hangs after 50 shoots

Firmware upgrade don't help.

Pentax (in FAQ) recomends Panasonic, Toshiba, Sundisk SD-Cards...
Do any test this card with k20?

P.S. sorry for bad English
04-23-2009, 03:55 PM   #56
Inactive Account




Join Date: Aug 2008
Location: No(r)way
Photos: Gallery
Posts: 179
I've used Sandisk Extreme III SDHC, Lexar Professional SDHC and Apacer SDHC.
Freezes up with all cards, with OEM and other cheaper batteries.
04-24-2009, 05:53 AM   #57
Inactive Account




Join Date: Apr 2009
Location: uk
Posts: 14
After contacting Pentax service by phone i got nowhere trying to get them to admit
there are some rogue k20d models out there with the freeze problem.
All that was said was send it in and you will get a quote to fix it.
So i sent them a email outlining all the facts and mentioning many more people now are
getting this problem so it must be a manufacturing fault and what are they going to do about it.
I also said i would look into the legal side of selling a camera which packs up just after warranty with only 600 odd images taken.
The reply i got back was unbelievable

" Thank you for your inquiry.
When the problem cannot be resolved we recommend a repair at the Service Center. Please visit the following website for repair instructions and complete the Repair Information Form before sending the camera for repair.
Support - PENTAX U.K. Limited
I hope that your question has been answered to your satisfaction.
Should you have further questions regarding this matter, please do not hesitate to
contact us again.
When replying, please make sure this email is included.
With kind regards,
Kai Kugler
Pentax Digital Camera Support Team "


What the hell does that mean ? yes they admit to a problem and will fix it at their
expense like i asked or no we are not admitting anything and we dont really give a toss.
I suspect the last one as that is the impression i get from them, you would have thought with all this bad publicity on their flag ship k20d that they would take a bit more interest in user problems.
I did mange to find the UK Pentax MD's name and will write to him and see if i get a reply, its worth a try as nothing else has stirred them.
04-24-2009, 07:45 PM   #58
Veteran Member
fccwpe's Avatar

Join Date: Mar 2009
Location: Perris, CA
Photos: Gallery
Posts: 380
No Freezes

Got my K20D in January, ~8000 frames later, nothing is wrong. LOVE IT!
04-27-2009, 12:54 PM   #59
New Member




Join Date: Apr 2009
Location: Augusta, GA
Posts: 2
I got exactly the same problem ant it looks like on your photostream: batery indicator, frame number, bad pictures... Sending it back to B&H after just 5 days, hope the next one will work better. I miss my PZ-1P already
04-27-2009, 11:08 PM   #60
Loyal Site Supporter
imtheguy's Avatar

Join Date: Mar 2009
Location: Virginia Beach
Photos: Gallery | Albums
Posts: 2,950
Only owned for 2 months but already 4,000 shots using it every single day so that should count for a normal 3 months. Not a single hiccup of any kind. Using Sandisk Extreme III memory.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
battery, camera, dslr, k20d, lcd, months, photography, poll
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
UPS delivered K20d Garyleed Troubleshooting and Beginner Help 4 09-17-2009 07:01 PM
Impatiently waiting for the UPS person with my K20D pardes Welcomes and Introductions 4 04-13-2009 01:53 AM
Better focusing on the K20D than the K10D? - a poll Kameraten Pentax DSLR Discussion 12 05-20-2008 12:39 AM
Poll- K20D AF Leya216 Pentax DSLR Discussion 10 03-31-2008 10:17 PM
K20D Poll Mallee Boy Pentax DSLR Discussion 23 03-14-2008 03:00 PM



All times are GMT -7. The time now is 04:11 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top