Forgot Password
Pentax Camera Forums Home
 

View Poll Results: How often has your K20D frozen up?
It never has 5789.06%
It has once or twice 34.69%
It has a few times (3-5 times) 11.56%
It has many times (more than 5 times) 34.69%
Voters: 64. You may not vote on this poll

Reply
Show Printable Version Search this Thread
04-28-2009, 07:34 AM   #61
Inactive Account




Join Date: Jan 2009
Location: hungary
Posts: 6
just the same problem

04-28-2009, 10:37 PM   #62
elm
New Member




Join Date: Apr 2009
Location: Taiwan
Photos: Gallery
Posts: 1
I got the same problem and I sent it back to the dealer for a repair. Now my K20D works fine for almost 3 months. The dealer just told me a component needs to be changed. I still don't know what is the root cause.
05-06-2009, 12:36 AM   #63
New Member




Join Date: May 2009
Posts: 4
Dear all,

I have exactly the same problem. The problem started after about 4 months of my purchase. Though the it is not frequent, but it often happened at the worst time, making many valuable moment couldn't be captured. :-(

More than that, now, I can never put another battery into the camera when I'm using the vertical grip (i.e., now only one battery in grip) As it will be so troublesome to detach the grip and take out that battery to have the camera reset when the camera freezed. It is annoying!

About 3 weeks ago, I took the K20D to service centre to repair. As all you guys know, the problem occurred randomly, I was afraid I could not demonstrate the problem to the service centre. Therefore, I've also prepared a video clip which I took at the time of camera hanged up, showing the top LCD status when power on / off. The video clip has been provided to service centre as a reference.

After 7 working days, I called the centre and asked for status. No hints yet! From the conversation, I believed they were trying to say it is my memory card issue as they could not repeat the problem. It is ridiculous because I've already told them the same problem occurred on at least 5 different memory cards! And I told them it is pointless to see whether the problem can be repeated because I have already provided the video clip to them, and the problem just occurred randomly. They said they will continue to investigate and get back to me this week.

Till now, no update yet. I will call them very soon.

Feeling frustrated because the weather has been so good - I really want to take photo... :-(

Curry
05-06-2009, 03:31 PM   #64
Inactive Account




Join Date: Apr 2009
Location: uk
Posts: 14
Hi Curry
You have my sympathy and i know what you are going through.
I have had some heated discussions about the problem with UK Pentax tech
although both phone calls re directed me to Holland for some strange reason.
I did not really get any where from emails either.
After leaving the camera for a week as it was depressing me to the point where i did not want to use it i packaged it up and took it down to the post office this morning.
I attached a letter saying i was disgusted with the fact that these rogue cameras are still turning up now and again and they should not have been sent out in that condition, i also sent a CD with quite a few white images i got from days when i did use it for proof.
I will just have to wait now and see if they will repair it and also how much it will cost although i think they should do it for free as its a fault caused by them.





[QUOTE=curry;584253]Dear all,

I have exactly the same problem. The problem started after about 4 months of my purchase. Though the it is not frequent, but it often happened at the worst time, making many valuable moment couldn't be captured. :-(

05-16-2009, 08:59 AM   #65
New Member




Join Date: May 2009
Posts: 4
Hi Steve,

Finally, the repairing centre told me they've confirmed the problem is due to the malfunction in motherboard. Therefore, they replaced the PCB and I've told my camera back today (the repairing record also stated that the PCB has been replaced).

As my camera is still under warranty. there is no charge.

Up to now (about 10 hours after collected it back), there is no problem observed.

Hope the problem has been solved.

Curry



[QUOTE=steve147;585129]Hi Curry
You have my sympathy and i know what you are going through.
I have had some heated discussions about the problem with UK Pentax tech
although both phone calls re directed me to Holland for some strange reason.
I did not really get any where from emails either.
After leaving the camera for a week as it was depressing me to the point where i did not want to use it i packaged it up and took it down to the post office this morning.
I attached a letter saying i was disgusted with the fact that these rogue cameras are still turning up now and again and they should not have been sent out in that condition, i also sent a CD with quite a few white images i got from days when i did use it for proof.
I will just have to wait now and see if they will repair it and also how much it will cost although i think they should do it for free as its a fault caused by them.
05-16-2009, 04:38 PM   #66
Inactive Account




Join Date: Apr 2009
Location: uk
Posts: 14
Hi Curry
I am pleased you got yours fixed ok and if they replaced the board i would think
you should not have any more problems hopefully.
You have had better luck than i , mine was sent back the week before last
with a cd of images and a long letter explaining the fault.
I got it back last week only a few days later with no warning and the docket
said no fault found.
I was really mad and rang them up and the manager advised me to send it back in,
so i sent it back the next day.
So far this has cost me with fares to the post office and back about 25 just to
post it, i just hope they find the fault this time around.
In the UK it seems that Pentax have had a shake up since the Hoya thing and all
repairs now are done outside by Johnsons Photopia which only started a
couple of weeks ago so they said.
I just have to wait now and see what they come up with.


QuoteOriginally posted by curry Quote
Hi Steve,

Finally, the repairing centre told me they've confirmed the problem is due to the malfunction in motherboard. Therefore, they replaced the PCB and I've told my camera back today (the repairing record also stated that the PCB has been replaced).

As my camera is still under warranty. there is no charge.

Up to now (about 10 hours after collected it back), there is no problem observed.

Hope the problem has been solved.

Curry


05-16-2009, 06:08 PM   #67
Veteran Member




Join Date: Feb 2007
Location: Ontario
Posts: 433
Two K20s; close to 10k images; no freeze ups. Note that I only use quality SD cards and batteries. That may be part of the reason. Dave
05-17-2009, 11:12 AM   #68
New Member




Join Date: May 2009
Posts: 4
Hi Steve,

I'm sorry about that. I even believe they should refund the postal fee for you due to their irresponsible action to sending you back an un-repaired item!

It can be frustrated and annoyed in fighting for some simple things we indeed deserve. Don't give up! You are not alone.... wish you good luck.

Curry.

QuoteOriginally posted by steve147 Quote
Hi Curry
I am pleased you got yours fixed ok and if they replaced the board i would think
you should not have any more problems hopefully.
You have had better luck than i , mine was sent back the week before last
with a cd of images and a long letter explaining the fault.
I got it back last week only a few days later with no warning and the docket
said no fault found.
I was really mad and rang them up and the manager advised me to send it back in,
so i sent it back the next day.
So far this has cost me with fares to the post office and back about 25 just to
post it, i just hope they find the fault this time around.
In the UK it seems that Pentax have had a shake up since the Hoya thing and all
repairs now are done outside by Johnsons Photopia which only started a
couple of weeks ago so they said.
I just have to wait now and see what they come up with.


05-17-2009, 11:26 AM   #69
New Member




Join Date: May 2009
Posts: 4
Hi Dave,

I think the reported defect rate of K20D in this thread is high enough. It is not and it won't be 100%, otherwise no matter how bad the QA of Pentax is, they can still identiy the problem before such incidents happen, right?

I think you should either feel lucky for yourself and/or feel sympathy for those who suffered. You know, 999 successful results cannot prove the failure result of the 1 case is impossible.

BTW, I used Pentax batteries and "quality" memory cards (like Sandisk, Toshiba, Panasonic, etc) as well - but if you said K20D is only compatible with the most expensive cards... I will have nothing to say - except wishing Pentax to stay such special requirements on manual.

Curry.

QuoteOriginally posted by davef Quote
Two K20s; close to 10k images; no freeze ups. Note that I only use quality SD cards and batteries. That may be part of the reason. Dave
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
battery, camera, dslr, k20d, lcd, months, photography, poll
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
UPS delivered K20d Garyleed Troubleshooting and Beginner Help 4 09-17-2009 07:01 PM
Impatiently waiting for the UPS person with my K20D pardes Welcomes and Introductions 4 04-13-2009 01:53 AM
Better focusing on the K20D than the K10D? - a poll Kameraten Pentax DSLR Discussion 12 05-20-2008 12:39 AM
Poll- K20D AF Leya216 Pentax DSLR Discussion 10 03-31-2008 10:17 PM
K20D Poll Mallee Boy Pentax DSLR Discussion 23 03-14-2008 03:00 PM



All times are GMT -7. The time now is 01:19 AM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top