Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
03-28-2009, 06:17 AM   #1
Forum Member




Join Date: Aug 2008
Location: Munich, Germany
Photos: Albums
Posts: 61
M 50mm F1.7 aperture problem

I just observed that I can not set the aperture of my M 50mm F1.7 on my K200D. It always stays wide open. Even when using Optical Preview the aperture is wide open for any F-Stop I set on the lens. Is this normal??

03-28-2009, 06:37 AM   #2
A Proud PENTAXER !!!
Loyal Site Supporter
fwcetus's Avatar

Join Date: Sep 2006
Location: New England
Photos: Gallery | Albums
Posts: 1,248
QuoteOriginally posted by atyab Quote
I just observed that I can not set the aperture of my M 50mm F1.7 on my K200D. It always stays wide open. Even when using Optical Preview the aperture is wide open for any F-Stop I set on the lens. Is this normal??
Have you already enabled your K200D (in one of the Custom Menu settings on a K200D, I assume) to allow the use of the aperture ring at settings other than "A" (which is, of course, a setting that your M lens does not have)? (I assume that on the K200D, as on the DS and the K20D, that the default setting is to ~not~ allow the ring to be recognized.)
03-28-2009, 06:56 AM   #3
Site Supporter
Site Supporter
Nick Siebers's Avatar

Join Date: Jun 2008
Location: Madison, WI
Photos: Gallery | Albums
Posts: 2,152
Also, if you are in Av mode, the lens stays open despite checking optical preview. Nearly gave me a heart attack thinking something was broken. Works fine in M mode, though.
03-28-2009, 07:36 AM   #4
Site Supporter
Site Supporter
pschlute's Avatar

Join Date: Mar 2007
Location: Surrey, UK
Photos: Gallery
Posts: 1,317
As has been pointed out it will always be wide open in Av mode. You need to use M mode and stop-down metering via the green button.

03-28-2009, 08:22 AM   #5
Forum Member




Join Date: Aug 2008
Location: Munich, Germany
Photos: Albums
Posts: 61
Original Poster
Thank you guys. I had already done the "Permitted" setting. So its like the aperture stays open in the Av mode in all cases. And in the M mode, after pressing the green button, one gets the shutter speed for the set aperture.

I had also gotten worried about the lens. Thanks a lot!!
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
50mm, aperture, camera, dslr, f1.7, photography
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Pentax A 50mm f1.2 lazy aperture problem ilya80 Pentax SLR Lens Discussion 3 10-10-2010 09:17 AM
aperture problem with 50 1.7 kent Pentax SLR Lens Discussion 9 11-01-2009 05:11 AM
K200d aperture problem steveuk30 Pentax DSLR Discussion 3 10-29-2009 09:23 AM
Problem with stuck aperture ring on Pentax KA 50mm f/1.7 jhaji Pentax SLR Lens Discussion 8 08-15-2009 04:10 PM
FA 24-90 aperture problem penpig Pentax SLR Lens Discussion 1 01-26-2009 10:08 AM



All times are GMT -7. The time now is 01:48 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top