Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
04-14-2007, 07:44 AM   #1
New Member




Join Date: Apr 2007
Location: usa
Posts: 1
10-D and flash Safe Sync question

Hi All

I am trying to use my novatron 600 unit with umbrellas and I had to by a safe sync (Wein hshsb) but I can't get it to work. I have tried all the options that I could find on a search of this group and others. It just dos'nt want to work. If i hit the button on the side of the sync it works, so I assume it's the way the camera interfaces with the sync unit? Do I need to buy a "pentax" part ,can i solve this problem? My ist-d works with the cord plugged right into the front of the camera. TIA Jim

04-14-2007, 09:38 AM   #2
Veteran Member
benjikan's Avatar

Join Date: Jan 2007
Location: Paris, France
Photos: Gallery
Posts: 4,312
Synch

QuoteOriginally posted by jim bostelle Quote
Hi All

I am trying to use my novatron 600 unit with umbrellas and I had to by a safe sync (Wein hshsb) but I can't get it to work. I have tried all the options that I could find on a search of this group and others. It just dos'nt want to work. If i hit the button on the side of the sync it works, so I assume it's the way the camera interfaces with the sync unit? Do I need to buy a "pentax" part ,can i solve this problem? My ist-d works with the cord plugged right into the front of the camera. TIA Jim
I have worked with several brands of triggers, but not the Wein. I have heard others express the same concern. I have never had a problem triggering studio flash's from the K10D. Perhaps you could contact Wein to get their advice.

Ben
04-14-2007, 11:17 AM   #3
Veteran Member
jfdavis58's Avatar

Join Date: Nov 2006
Location: 13 S 0357397-3884316
Photos: Gallery
Posts: 876
Swap SafeSync for Wireless Controllers

Too bad you didn't join the forums sooner-like three months ago or so.

The hotshoe on the K10D is very tight. When you slip the SafeSync into the hot shoe it depresses the center contact of the SafeSync a bit further than most cameras. So much so, that it actually breaks contact inside the SafeSync. That little ball is in a sleeve, the ball contacts a small plate on the side of the sleeve; it moves too far up the sleeve to maintain contact. I've been through four SafeSync's; it's a design inadequacy. It's provable too.

Clamp the SafeSync in a small vise; connect it via PC cable to the flash, turn flash on. Take a test lead from a VOM and touch it to the little ball, Press the ball in as far as it goes. Hold it there. Touch the other end of the test lead to the side contact. VERRRRRy slllooowly release a bit of pressure on the lead touching the ball. As the ball moves out at some point it will contact the metal plate inside the sleeve and the flash will pop.

And like I said, found this three months ago; the forums are searchable.

I returned mine and bought Pocket Wizards. Got rid of the problem and the wire-cool!.
04-14-2007, 02:12 PM   #4
Inactive Account




Join Date: Oct 2006
Location: Boise, Idaho
Photos: Gallery | Albums
Posts: 1,414
I tried the Wein as well. I didn't get as far as testing to see why it didn't work, but it didn't. Good thing I tried it in the store before paying. I didn't have enough for PW so I got a cheaper radio system. I have been using it since mid December with no problems.

04-14-2007, 06:08 PM   #5
New Member




Join Date: Mar 2007
Location: NJ
Posts: 11
Radio Flash Sync

QuoteOriginally posted by davemdsn Quote
I tried the Wein as well. I didn't get as far as testing to see why it didn't work, but it didn't. Good thing I tried it in the store before paying. I didn't have enough for PW so I got a cheaper radio system. I have been using it since mid December with no problems.
Dave,

What radio system, and where did you buy it?

EZ
04-14-2007, 06:34 PM   #6
Senior Member




Join Date: Nov 2006
Location: Pensacola, FL
Posts: 182
I guess I just got lucky

Because my Wein safe synch works just fine. I read where several people on this forum have had problems but I haven't had any trouble.


QuoteOriginally posted by jim bostelle Quote
Hi All

I am trying to use my novatron 600 unit with umbrellas and I had to by a safe sync (Wein hshsb) but I can't get it to work. I have tried all the options that I could find on a search of this group and others. It just dos'nt want to work. If i hit the button on the side of the sync it works, so I assume it's the way the camera interfaces with the sync unit? Do I need to buy a "pentax" part ,can i solve this problem? My ist-d works with the cord plugged right into the front of the camera. TIA Jim
04-14-2007, 07:18 PM   #7
Inactive Account




Join Date: Oct 2006
Location: Boise, Idaho
Photos: Gallery | Albums
Posts: 1,414
EZ, the brand was "RPS Studio" and was purchased in a local camera shop. Although the brand name is different, it appears to be the same design as many of the ones on E-Bay. I paid about $85 US for it.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, dslr, photography, sync, unit
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
FlashWave remote flash trigger and sync speed question joshnl Flashes, Lighting, and Studio 16 07-14-2010 12:09 PM
PC Sync flashes safe on DSLR? Asudef Pentax DSLR Discussion 2 07-11-2010 09:00 PM
K200D, Hanimex PZ4200 flash, Wein Safe Sync HSHS jpramas Pentax DSLR Discussion 3 09-10-2009 09:01 PM



All times are GMT -7. The time now is 01:24 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top