Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
05-04-2009, 01:55 AM   #1
New Member




Join Date: Dec 2007
Location: india
Posts: 9
pentax k 10 d camera problem

i was purchase the camara from last 2 years ,today when i on the camera it is not response only battery indication show and off . after some time it will start. when i eject the card and try to start it will not start . what wrong with camera any body have this type of problem pl guide me.

05-04-2009, 03:57 AM   #2
Site Supporter




Join Date: Nov 2008
Location: Singapore
Photos: Gallery
Posts: 904
Is your battery fully charged? Try to use a fully charged battery and test again.
05-04-2009, 11:37 PM   #3
Loyal Site Supporter
Canada_Rockies's Avatar

Join Date: Nov 2007
Location: Sparwood, BC, Canada
Photos: Gallery | Albums
Posts: 9,144
Without a card, the camera will not start up. It must have a card in it to function properly.

Try cleaning the battery contacts carefully. A small amount of contamination will sometimes collect and make the battery voltage less than the camera requires. As Felix said, make sure that your battery is fully charged.
05-05-2009, 03:49 AM   #4
New Member




Join Date: Dec 2007
Location: india
Posts: 9
Original Poster
i repair this camera this is contact problem in card slot.camera repairer repair this , card was not contact properly newely it need to press it and card flab press presserely. the camera is now working properly.
thanks
suresh pardeshi

05-05-2009, 12:34 PM   #5
Loyal Site Supporter
Canada_Rockies's Avatar

Join Date: Nov 2007
Location: Sparwood, BC, Canada
Photos: Gallery | Albums
Posts: 9,144
QuoteOriginally posted by suresh pardeshi Quote
i repair this camera this is contact problem in card slot.camera repairer repair this , card was not contact properly newely it need to press it and card flab press presserely. the camera is now working properly.
thanks
suresh pardeshi
I am glad that your camera is now working correctly. Thanks for the update.
05-05-2009, 05:39 PM   #6
Senior Member
marcdsgn's Avatar

Join Date: Dec 2007
Location: Queensland
Photos: Gallery
Posts: 266
QuoteOriginally posted by Canada_Rockies Quote
Without a card, the camera will not start up.
Actually, not true in my case. Wish it was! I find it frustrating that my K10D does start up without a card because I've often snapped away several shots before glancing at the screen to see the ominous "No card" message.
05-05-2009, 05:44 PM   #7
Loyal Site Supporter
Canada_Rockies's Avatar

Join Date: Nov 2007
Location: Sparwood, BC, Canada
Photos: Gallery | Albums
Posts: 9,144
QuoteOriginally posted by marcdsgn Quote
Actually, not true in my case. Wish it was! I find it frustrating that my K10D does start up without a card because I've often snapped away several shots before glancing at the screen to see the ominous "No card" message.
I stand ... er ... sit ... corrected. I just tried mine.
05-05-2009, 08:43 PM   #8
Veteran Member
res3567's Avatar

Join Date: Sep 2008
Location: Houston Tx.
Photos: Gallery
Posts: 1,876
QuoteOriginally posted by marcdsgn Quote
Actually, not true in my case. Wish it was! I find it frustrating that my K10D does start up without a card because I've often snapped away several shots before glancing at the screen to see the ominous "No card" message.
Mine does too!

Don't that just plain suck?

I missed some good shots behind that!

Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, dslr, photography
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Pentax Digital Camera Utility 4 problem mba1971 Digital Processing, Software, and Printing 23 01-28-2012 07:31 PM
K-5 battery problem? camera problem? user problem? imtheguy Pentax K-5 39 11-03-2010 06:02 PM
Lens or camera problem? Pentax ME Johnct Pentax Film SLR Discussion 17 11-02-2010 01:27 PM
Pentax digital camera utility v 4.11 problem tomas99hagberg Troubleshooting and Beginner Help 4 05-30-2010 07:20 AM
Pentax Digital Camera Utility 4, K7 and Lens corrections problem Labuzan Digital Processing, Software, and Printing 2 12-28-2009 10:09 AM



All times are GMT -7. The time now is 11:39 AM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top