Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
05-17-2009, 06:03 AM   #1
Inactive Account




Join Date: Aug 2008
Location: No(r)way
Photos: Gallery
Posts: 179
The e-dial on my "new" K100D is not working

I bought a K100D for about $190USD. It looks almost brand new, but the e-dial don't work. The camera works great when I'm using the sceene and the Auto picture modus- The previous owner have used it for about 11 months and he said it had about 400 clicks on it.

How can an e-dial just stop working?

Someone knows about a problem like this?

This is probably going on the warranty, right?

05-17-2009, 06:28 AM   #2
Dom
Guest




Not knowing the K100D.
My only advise is check the custom settings.
05-17-2009, 07:17 AM   #3
Veteran Member
res3567's Avatar

Join Date: Sep 2008
Location: Houston Tx.
Photos: Gallery
Posts: 1,876
QuoteOriginally posted by NorthPentax Quote
I bought a K100D for about $190USD. It looks almost brand new, but the e-dial don't work. The camera works great when I'm using the sceene and the Auto picture modus- The previous owner have used it for about 11 months and he said it had about 400 clicks on it.

How can an e-dial just stop working?

Someone knows about a problem like this?

This is probably going on the warranty, right?
When you say dont work, what modes did you try it on?

Have you tried it in playback mode?

Need details.
05-17-2009, 07:40 AM   #4
Inactive Account




Join Date: Aug 2008
Location: No(r)way
Photos: Gallery
Posts: 179
Original Poster
I have checked the custom settings, resetted the camera etc.

I have tried with different lenses.

Tried it on all modes and playback. The magnifying tool won't work, so I think it has to be the dial that is broken.

My K20D is in Germany for repairs and now I have a broken K100D, just my luck!

05-17-2009, 07:43 AM   #5
Veteran Member




Join Date: Apr 2008
Location: Minnesota
Photos: Gallery
Posts: 1,530
The e-dial does not have a custom setting on the K100D/K100DS. In playback mode it is tied to zoom and display mode (single or multiple) or filter application. In shooting mode it will only work in Av, Tv or M mode to toggle the adjustable settings or for EV compensation.

In one of the shooting modes above when you spin the e-dial do you see the EV compensation change? It could be you have a stuck EV button.
05-17-2009, 07:52 AM   #6
Veteran Member
res3567's Avatar

Join Date: Sep 2008
Location: Houston Tx.
Photos: Gallery
Posts: 1,876
QuoteOriginally posted by MrApollinax Quote
The e-dial does not have a custom setting on the K100D/K100DS. In playback mode it is tied to zoom and display mode (single or multiple) or filter application. In shooting mode it will only work in Av, Tv or M mode to toggle the adjustable settings or for EV compensation.

In one of the shooting modes above when you spin the e-dial do you see the EV compensation change? It could be you have a stuck EV button.
Good suggestion.
05-17-2009, 08:14 AM   #7
Inactive Account




Join Date: Aug 2008
Location: No(r)way
Photos: Gallery
Posts: 179
Original Poster
EV button works. When I press it the LCD display shows me EV compensation 0.0 and nothing happens when I turn the e-dial.

Someone knows how the e-dial works? The dial feels normal.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, dslr, e-dial, k100d, photography
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem with E-dial (or "Jog wheel") on DS: Solved! Syb Pentax DSLR Discussion 10 04-06-2010 07:07 AM
Sports "Highside Exit" took 1st Place in DPReview "Missed It by THAT much, Part 1" Challenge MRRiley Post Your Photos! 27 02-21-2010 08:26 PM
working K-7 "green line" firmware fix Nass Pentax DSLR Discussion 3 09-02-2009 12:37 PM
Intermittently working "Catch-in-focus" while using m42 screwmount lens shuttervox Pentax DSLR Discussion 1 08-06-2009 07:55 PM
"Hunger for a DA*50-135?" or "The DA*50-135 as a bird lens!" or "Iron age birds?" Douglas_of_Sweden Post Your Photos! 4 08-13-2008 06:09 AM



All times are GMT -7. The time now is 12:11 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top