Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
05-17-2009, 09:13 PM   #1
Inactive Account




Join Date: Apr 2009
Location: Calgary, Canada
Photos: Gallery
Posts: 22
K20D No Card In The Camera

I bought the camera about a month ago and SanDisk Extreme III 4GB memory card. It is not bought on ebay and it is genuine SanDisk card $80. I didn't have any problems until today. Just got home after taking pictures in the local park and after transfering the pictures to my laptop via card reader camera gives me this error message "No card in the camera". I always take the card out and plug it in the card reader, transfer pictures, put it back in the camera and format the card. I tried also to use other cards and it seams that camera can't recognise none of them. They work in the other cameras but not in mine. I tried googling it but didn't find anything relevant about this except somebody that had same problem with
K10D but but nobody had a solution. I take very good care of my equipment, I never dropped it or did anything that would make it not work.

05-18-2009, 07:03 AM   #2
Veteran Member
rburgoss's Avatar

Join Date: May 2008
Location: San Jose, Costa Rica
Photos: Gallery | Albums
Posts: 972
Since you say you bought your memory card from eekbay, I have to ask the following question:

Are you sure its a genuine memory card?

Some time ago, there was a thread about this.

Fake Memory Cards - OCAU Wiki
Beware of fake memory cards
Fake SanDisk Compact Flash card
Fake memory cards demystified - Tips & Tricks - CNET Asia
Beware fake memory cards | Storage Bits | ZDNet.com

It is unbelievable how many counterfit things are out there. Not only Rolex watches or Louis Vuitton bags. You can find just about anything from band aids to fake Alka Seltzer and spark plugs. Remember. ANY PRODUCT THAT HAS A GOOD NAME, IT WILL BE COUTERFITTED SOMETIME. It doesn't need to be fancy or expensive.
05-18-2009, 07:17 AM   #3
Veteran Member




Join Date: Apr 2008
Location: Minnesota
Photos: Gallery
Posts: 1,530
QuoteOriginally posted by Nelepl Quote
I tried also to use other cards and it seams that camera can't recognise none of them. They work in the other cameras but not in mine.
Quick question, do all these cards work in a reader as well? If they work in everything except your camera chances are that something with the internal card reader in your camera has gone south. when you push the card in does it still slide and catch like you are clicking a retractable pen?
05-18-2009, 07:56 AM   #4
Inactive Account




Join Date: Apr 2009
Location: Calgary, Canada
Photos: Gallery
Posts: 22
Original Poster
QuoteQuote:
Since you say you bought your memory card from eekbay, I have to ask the following question:

Are you sure its a genuine memory card?

Some time ago, there was a thread about this.
It is NOT bought on ebay and it is genuine SanDisk card $80. It was bought in the same shop where I bought the camera and trust me I know what is fake, and the reason I said this in my first post is because not to get that kind of questions.

QuoteQuote:
Quick question, do all these cards work in a reader as well? If they work in everything except your camera chances are that something with the internal card reader in your camera has gone south. when you push the card in does it still slide and catch like you are clicking a retractable pen?
They work everywhere else except in the camera which means that there is the problem with the camera not the card. Card slides and catches when you put it in the camera.

Now I did something this morning. I put the card back in the camera and while I was looking at it I somehow pulled the card out little bit and suddenly camera read ti, so I guess there is some problem with connection inside the camera. I didn't take it out since, but I still don't like this and I want to know how to fix it. Even if it works for now it does not mean that it will not fail in the middle of the shoot so don't think that I fixed the problem, I just fixed it temporally. I still want to know if somebody else had the problem and how did they fix it.

05-18-2009, 09:05 AM   #5
Veteran Member




Join Date: Apr 2008
Location: Minnesota
Photos: Gallery
Posts: 1,530
The contacts on the reader should make contact with the card fingers about halfway up. So pulling out the card a little bit should not have fixed the problem. My guess is the locking mechanism once you push the card all the way is not pushing the card into the contacts properly when you push it in all the way. It could be that it is too far in and the card is bowing slightly casuing one of the center pins to not make contact. If you look at the card while inserted into the camera it should NOT be flush with the slot opening. It should protrude slightly starting where the card has a indented line. If it is flush then that is probably the cause of the issue you are seeing.
05-18-2009, 09:31 AM   #6
Inactive Account




Join Date: Jan 2008
Location: Portland, Maine
Posts: 218
Have you tried another SD card in the camera?
05-18-2009, 09:52 AM   #7
Loyal Site Supporter
Canada_Rockies's Avatar

Join Date: Nov 2007
Location: Sparwood, BC, Canada
Photos: Gallery | Albums
Posts: 9,142
As a no cost try, take some isopropyl alcohol and a microfiber cloth and clean throughly the contacts on the card. Make sure you don't snag them with the cloth. Let it dry fully, then insert and remove several times to make sure the inside contacts are also clean. If it works you owe me an on-line cup of coffee. If it doesn't, well you are not out much $$$.
05-18-2009, 12:52 PM   #8
Veteran Member
WheresWaldo's Avatar

Join Date: Sep 2006
Location: North Carolina
Photos: Gallery
Posts: 498
My K20D uas been at Pentax Colorado for three weeks with the same issue, they are waiting for some parts from Japan that must be arriving via row boat. They have no estimate of the date and said they would expedite the repair once they get the part in stock.

05-18-2009, 02:35 PM   #9
Inactive Account




Join Date: Apr 2009
Location: Calgary, Canada
Photos: Gallery
Posts: 22
Original Poster
Well it works for now by pulling the card up litle bit, I will se what will happen in future.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, card, dslr, photography, pictures, reader, sandisk
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Memory card error -- works on PC but not on camera K7er Pentax DSLR Discussion 6 02-14-2010 11:33 PM
problem w/my SD card or camera? Help please! BethC Troubleshooting and Beginner Help 7 12-16-2009 09:50 PM
If you plan to sell your memory card with your camera... emr Photographic Technique 7 07-08-2009 08:20 AM
Can I customize whitebalance in camera with a grey card dkittle Photographic Technique 21 02-08-2009 05:53 PM
SD card for K20D gamgee Pentax Camera and Field Accessories 3 03-17-2008 08:11 AM



All times are GMT -7. The time now is 12:43 PM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top