Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
05-25-2009, 06:30 PM   #1
Senior Member




Join Date: Dec 2008
Location: Blackville, South Carolina
Photos: Gallery
Posts: 149
No more SR for me!

Was messing with my new (old) equipment I got today, when I noticed that when I was using my MF lenses, that the camera was not asking me for focal length. I went to check the switch and this is what I found:
Any way to fix this? Or am I stuck with no SR for the life of this body?

RD

Attached Images
 
05-25-2009, 07:00 PM   #2
Pentaxian
Wheatfield's Avatar

Join Date: Apr 2008
Location: The wheatfields of Canada
Posts: 10,043
Send it in for repair.
05-25-2009, 07:07 PM   #3
Senior Member




Join Date: Dec 2008
Location: Blackville, South Carolina
Photos: Gallery
Posts: 149
Original Poster
Any idea how much that would cost?

RD
05-25-2009, 07:45 PM   #4
Veteran Member
vizjerei's Avatar

Join Date: May 2007
Location: Toronto
Photos: Gallery
Posts: 1,418
is this a K10D? did you find that switch? it happend to mine and i use super glue glue it back very carefully, and it works ever since I think it happens to the first shippment of the K10D.

05-25-2009, 08:08 PM   #5
Senior Member




Join Date: Dec 2008
Location: Blackville, South Carolina
Photos: Gallery
Posts: 149
Original Poster
Yes, this is my K10D. Unfortunately, I just got back from a camping trip last week where I shot a good bit, but people were wanting to look at my pics on the way home, and the lever went AWOL on me. I looked in my camera bag, and around where I first noticed it, but no luck.

RD
05-25-2009, 08:20 PM   #6
Veteran Member
-=JoN=-'s Avatar

Join Date: Nov 2006
Location: NYC
Posts: 1,000
u cant turn it w/ something else, ie, paper clip or something?
get it fixed....or...just a new reason to get a new body...LoL

how's the grip btw?
05-25-2009, 08:24 PM   #7
Veteran Member
vizjerei's Avatar

Join Date: May 2007
Location: Toronto
Photos: Gallery
Posts: 1,418
damn.. mine fall off when I take my camera out second day I got it, so it fall into my camera bag. so is the SR on right now? I tried to turn it before I glue the switch but it was no luck, since it need to rotate the metal part in the middle inorder to switch it on/off.

hope your is in on position. ( just press the info button to see if you have the hand icon on)

Last edited by vizjerei; 05-25-2009 at 08:40 PM.
05-25-2009, 08:31 PM   #8
Senior Member




Join Date: Dec 2008
Location: Blackville, South Carolina
Photos: Gallery
Posts: 149
Original Poster
Unfortunately, it was off when it broke. I had been shooting on a tripod. The grip is great -=JoN=-, but this isn't quite enough motivation to swing for the K-7. I'm on a self induced abstinence from buying camera gear for now. I promised myself before I buy that DA 55-300mm and DA 40mm and AF540FGZ I've been wanting that I would work on improving my work before I threw more money at my hobby.

RD

05-25-2009, 08:44 PM   #9
Veteran Member
vizjerei's Avatar

Join Date: May 2007
Location: Toronto
Photos: Gallery
Posts: 1,418
hmm try a pointy easer, press it hard on the swith and turn it clockwise, see if it will do it.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, dslr, photography, sr
Thread Tools Search this Thread
Search this Thread:

Advanced Search



All times are GMT -7. The time now is 10:05 PM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top