Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
05-29-2009, 04:15 PM   #1
Veteran Member
iceemn360's Avatar

Join Date: Jan 2009
Location: Hillsborough, Ca
Posts: 329
K20d- Memory Card error

I did a search on the forums but didnt quite find the solution I was looking for. Im in Costa Rica and have been using my K20d with no problems until today. I was taking photos with my Da 50-135 and got some great shots. when I went to up load photos from my camera to my mac computer, I recieved and error message saying that the card could not be recognized. i looked at the camera screen and there was a "memory card error" message. I always properly eject my camera/ sd cads so i figred the card just got corrupted somehow. Before reformatting it however, I put it in my K10d body that I brought with me and viola. photos. I uploaded them to the computer from the k10d. I then put the card back into the k20d and recieved the same message. I reformat my cards every time I begin a new so I reformatted the card via the camera. I still recieved a memory card error. I then reset the camera to factory setting via the camera menu and still recieved a memory card error. I checked the SD card slot and it appears that nothing is wrong with clean connections and no bent connections. I took another SD card that I have also been using for the past 3 months and put it into the k20d and recieved the same mermory card error message. i put the same card into my K10d and viola, photos......... I then tried 4 other SD cards that I brought with me and i continued to recieve the same error message for each card. ALL cards worked with my K10d....

What is going on?

05-29-2009, 05:45 PM   #2
Forum Member




Join Date: Nov 2008
Location: Salt Lake City
Posts: 86
Ah! I HAD THE SAME PROBLEM!

... I ended up just sending the bugger in to pentax repair in Colorado. The contacts on the SD card read board that communicate with the camera's motherboard were bad/broken. Sad thing is, I had impact damage that I had no idea was there. They voided my warranty but I really had no choice but to go ahead and pay $275. I would have repaired it myself but I didn't want to risk the chance of only ordering the SD card reader module and it ending up actually being the motherboard, which would have been a hassle to order and a bugger to solder and install, along with I wouldn't have been able to calibrate the new motherboard to my K20D's hardware.

I'm bummed that that had happened. I used my camera only a few hours earlier with NO PROBLEMS, didnt bump it or anything and... out of no where my SD card reader in the camera totally took a crap on me.

I got it back after two very long and painful weeks as I had to use my K200D that has a broken top status screen in the mean time... Got it back SUPER clean, works perfect.
05-29-2009, 05:54 PM   #3
Veteran Member




Join Date: Sep 2007
Location: Melbourne
Posts: 602
QuoteOriginally posted by steve500 Quote
.. The contacts on the SD card read board that communicate with the camera's motherboard were bad/broken. Sad thing is, I had impact damage that I had no idea was there....
A friend of mine had the same trouble. He dropped his K20D and one of the contacts broken.
05-29-2009, 06:06 PM   #4
Veteran Member
iceemn360's Avatar

Join Date: Jan 2009
Location: Hillsborough, Ca
Posts: 329
Original Poster
QuoteOriginally posted by ddhytz Quote
A friend of mine had the same trouble. He dropped his K20D and one of the contacts broken.
shucks. I was afraid of hearing something like this. I was going to photography my cousins wedding in a short two weeks time so I guess Ill have to work with my K10d for now. thanks a bunch!

05-29-2009, 06:13 PM   #5
Damn Brit
Guest




It's possible there is some residual condensation in the K20 from your trip to Costa Rica.
Why don't you try a hairdryer on it with the card door open?

Use your K10,it's better for weddings.
06-08-2009, 11:34 AM   #6
Veteran Member
WheresWaldo's Avatar

Join Date: Sep 2006
Location: North Carolina
Photos: Gallery
Posts: 498
I just got my Pentax K20D back from Colorado after getting the Memory card error. Well honestly I didm't get it back, they sent me a new one with only 36 actuations. Problem was one of the pins in the SD socket was bent. Apparently they couldn't fix it so I got a new camera instead. It did take 25 business days rather than the 15-20 they quote on the Pentax site.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, card, cards, dslr, error, k10d, k20d, memory, message, photography, photos, sd
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Memory card error jaysee15 Pentax DSLR Discussion 5 08-18-2011 09:26 AM
Memory card error chuckdua Troubleshooting and Beginner Help 10 09-29-2010 02:15 PM
memory card error problem cdm807 Troubleshooting and Beginner Help 15 10-17-2009 07:22 PM
Memory Card Error soundview Pentax DSLR Discussion 5 07-23-2008 09:08 AM
Memory card error skaktuss Pentax DSLR Discussion 8 04-26-2007 06:03 AM



All times are GMT -7. The time now is 01:43 AM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top